Update to 3.1.7:

Changes from 3.1.6 to 3.1.7
---------------------------
1. Gawk now has support for z/OS (IBM S/390 architecture).

2. Gawk now handles multibyte strings better in [s]printf with field
   widths and such.

3. Gawk now uses libsigsegv to print a message before core dumping. This
   handles infinite recursion of an awk function a little better.
   Use of the library can be disabled at configure time with the
   --disable-libsigsegv option for unusual systems.

4. The handling of BINMODE is now somewhat more sane.

5. A getline from a directory is no longer fatal; instead it returns -1.

6. Per POSIX, special variable names (like FS) cannot be used as function
   parameter names.

7. The new -O / --optimize option enables simple constant folding on
   the parse tree during parsing.  We hope that with time the number
   of optimizations will increase.

8. Updated to the latest autotools: Autoconf 2.63, Automake 1.11,
   Libtool 2.2.6a, and Gettext 0.17. Also latest Bison: 2.4.1.

9. Some improvement in testing for isinf / isnan in builtin.c.

10. Improved the handling of `a = a b c' to be more general.

11. Locale handling for %'d should now work on certain non-Unix /
    non-Linux systems.

12. Lots of bugs fixed, see the ChangeLog for the details.
This commit is contained in:
wiz 2009-08-08 16:23:48 +00:00
parent 7d06f9463f
commit 5fd44228df
4 changed files with 15 additions and 14 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.38 2007/11/02 07:17:59 adam Exp $
# $NetBSD: Makefile,v 1.39 2009/08/08 16:23:48 wiz Exp $
DISTNAME= gawk-3.1.6
DISTNAME= gawk-3.1.7
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GNU:=gawk/}
EXTRACT_SUFX= .tar.bz2

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.13 2009/06/14 18:03:31 joerg Exp $
@comment $NetBSD: PLIST,v 1.14 2009/08/08 16:23:48 wiz Exp $
bin/gawk
bin/${PKGNAME}
bin/igawk
@ -37,6 +37,7 @@ share/locale/es/LC_MESSAGES/gawk.mo
share/locale/fr/LC_MESSAGES/gawk.mo
share/locale/ga/LC_MESSAGES/gawk.mo
share/locale/he/LC_MESSAGES/gawk.mo
share/locale/id/LC_MESSAGES/gawk.mo
share/locale/it/LC_MESSAGES/gawk.mo
share/locale/ja/LC_MESSAGES/gawk.mo
share/locale/nl/LC_MESSAGES/gawk.mo

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.18 2007/11/02 07:18:00 adam Exp $
$NetBSD: distinfo,v 1.19 2009/08/08 16:23:48 wiz Exp $
SHA1 (gawk-3.1.6.tar.bz2) = fb45bded207af6a8e46cd63fcbb6fb064ecee607
RMD160 (gawk-3.1.6.tar.bz2) = e2639935d87d5c9fdb115a58ab1f598b69a76216
Size (gawk-3.1.6.tar.bz2) = 1861630 bytes
SHA1 (patch-ab) = b754cc6df0bd00d5b4e6bbd6bd2706703872489f
SHA1 (gawk-3.1.7.tar.bz2) = 77dfacb793d579fa6830152d943096bc4362a465
RMD160 (gawk-3.1.7.tar.bz2) = f35c04e947357404d410d62df87df9d6a88079de
Size (gawk-3.1.7.tar.bz2) = 2365837 bytes
SHA1 (patch-ab) = b021ffe202d4dec931fb78b28b9af459d66c73bd
SHA1 (patch-ad) = 68910553cf495b7b177c96479ceb2c549fe5350f

View file

@ -1,17 +1,17 @@
$NetBSD: patch-ab,v 1.11 2007/11/02 07:18:00 adam Exp $
$NetBSD: patch-ab,v 1.12 2009/08/08 16:23:48 wiz Exp $
--- Makefile.in.orig 2007-10-22 08:52:01.000000000 +0200
--- Makefile.in.orig 2009-07-21 19:29:59.000000000 +0000
+++ Makefile.in
@@ -148,7 +148,7 @@ CFLAGS = @CFLAGS@
@@ -191,7 +191,7 @@ CFLAGS = @CFLAGS@
CPP = @CPP@
CPPFLAGS = @CPPFLAGS@
CYGPATH_W = @CYGPATH_W@
-DEFS = -DDEFPATH=$(DEFPATH) -DHAVE_CONFIG_H -DGAWK -DLOCALEDIR="\"$(datadir)/locale\""
+DEFS = -DDEFPATH=$(DEFPATH) -DHAVE_CONFIG_H -DGAWK -DLOCALEDIR="\"$(prefix)/$(PKGLOCALEDIR)/locale\""
DEPDIR = @DEPDIR@
ECHO_C = @ECHO_C@
ECHO_N = @ECHO_N@
@@ -890,9 +890,7 @@ install-exec-hook:
DSYMUTIL = @DSYMUTIL@
DUMPBIN = @DUMPBIN@
@@ -1044,9 +1044,7 @@ install-exec-hook:
(cd $(DESTDIR)$(bindir); \
$(LN) gawk$(EXEEXT) gawk-$(VERSION)$(EXEEXT) 2>/dev/null ; \
$(LN) pgawk$(EXEEXT) pgawk-$(VERSION)$(EXEEXT) 2>/dev/null ; \