Rename some installed pixmaps so that this does not conflict with libgnomeui.
Bump PKGREVISION to 2. Found by wiz@.
This commit is contained in:
parent
c97fed2499
commit
5fe8866e38
5 changed files with 127 additions and 9 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.96 2004/02/14 17:21:55 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.97 2004/02/18 11:56:02 jmmv Exp $
|
||||
|
||||
DISTNAME= gnome-libs-1.4.2
|
||||
PKGREVISION= 1
|
||||
PKGREVISION= 2
|
||||
CATEGORIES= x11 gnome
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/gnome-libs/1.4/}
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.14 2004/02/18 11:25:36 jmmv Exp $
|
||||
@comment $NetBSD: PLIST,v 1.15 2004/02/18 11:56:02 jmmv Exp $
|
||||
bin/dns-helper
|
||||
bin/gconfigger
|
||||
bin/gnome-bug
|
||||
|
@ -572,11 +572,11 @@ ${PKGLOCALEDIR}/locale/zh_CN/LC_MESSAGES/gnome-libs.mo
|
|||
${PKGLOCALEDIR}/locale/zh_TW/LC_MESSAGES/gnome-libs.mo
|
||||
share/mime-info/gnome.mime
|
||||
share/pixmaps/calculator-font.png
|
||||
share/pixmaps/gnome-default-dlg.png
|
||||
share/pixmaps/gnome-error.png
|
||||
share/pixmaps/gnome-info.png
|
||||
share/pixmaps/gnome-question.png
|
||||
share/pixmaps/gnome-warning.png
|
||||
share/pixmaps/gnome1-default-dlg.png
|
||||
share/pixmaps/gnome1-error.png
|
||||
share/pixmaps/gnome1-info.png
|
||||
share/pixmaps/gnome1-question.png
|
||||
share/pixmaps/gnome1-warning.png
|
||||
share/pixmaps/no.xpm
|
||||
share/pixmaps/yes.xpm
|
||||
share/type-convert/gnome-make-postscript-mimes
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.15 2003/09/12 16:12:03 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.16 2004/02/18 11:56:02 jmmv Exp $
|
||||
|
||||
SHA1 (gnome-libs-1.4.2.tar.gz) = 9925d28237f0269a2678fdcfa7ec6033dab04789
|
||||
Size (gnome-libs-1.4.2.tar.gz) = 3781173 bytes
|
||||
|
@ -8,6 +8,8 @@ SHA1 (patch-ac) = 601cb8850ab9497fb9ab25843d1e9fd47306256e
|
|||
SHA1 (patch-ad) = 10e46c8965137c8c0a3acf177898ca07fb4c90fa
|
||||
SHA1 (patch-ae) = 85e0395394602628b4bec63ac0e96a31bacc9f10
|
||||
SHA1 (patch-af) = a5aea708fe8b46c421f818cab8dc033a2c224831
|
||||
SHA1 (patch-ag) = 7cc30aa025384c4d0c2d7250f0e6c6aa39c469b7
|
||||
SHA1 (patch-ah) = d0725757c6132e777c7d5d45453c7a744b51de2f
|
||||
SHA1 (patch-aj) = 292c4efccc9650c8244348bdcf22c3c1cbd3ebe6
|
||||
SHA1 (patch-ak) = fa6f2db6faff3ca6427784b84acf5856be24af82
|
||||
SHA1 (patch-an) = 94189a17d893cc7290354ddb200bea41dffb7953
|
||||
|
|
94
x11/gnome-libs/patches/patch-ag
Normal file
94
x11/gnome-libs/patches/patch-ag
Normal file
|
@ -0,0 +1,94 @@
|
|||
$NetBSD: patch-ag,v 1.7 2004/02/18 11:56:02 jmmv Exp $
|
||||
|
||||
--- libgnomeui/gnome-messagebox.c.orig 2000-06-29 03:40:25.000000000 +0200
|
||||
+++ libgnomeui/gnome-messagebox.c
|
||||
@@ -109,7 +109,7 @@ gnome_message_box_new (const gchar
|
||||
if (strcmp(GNOME_MESSAGE_BOX_INFO, message_box_type) == 0)
|
||||
{
|
||||
gtk_window_set_title (GTK_WINDOW (message_box), _("Information"));
|
||||
- s = gnome_unconditional_pixmap_file("gnome-info.png");
|
||||
+ s = gnome_unconditional_pixmap_file("gnome1-info.png");
|
||||
if (s) {
|
||||
pixmap = gnome_pixmap_new_from_file(s);
|
||||
g_free(s);
|
||||
@@ -118,7 +118,7 @@ gnome_message_box_new (const gchar
|
||||
else if (strcmp(GNOME_MESSAGE_BOX_WARNING, message_box_type) == 0)
|
||||
{
|
||||
gtk_window_set_title (GTK_WINDOW (message_box), _("Warning"));
|
||||
- s = gnome_unconditional_pixmap_file("gnome-warning.png");
|
||||
+ s = gnome_unconditional_pixmap_file("gnome1-warning.png");
|
||||
if (s) {
|
||||
pixmap = gnome_pixmap_new_from_file(s);
|
||||
g_free(s);
|
||||
@@ -127,7 +127,7 @@ gnome_message_box_new (const gchar
|
||||
else if (strcmp(GNOME_MESSAGE_BOX_ERROR, message_box_type) == 0)
|
||||
{
|
||||
gtk_window_set_title (GTK_WINDOW (message_box), _("Error"));
|
||||
- s = gnome_unconditional_pixmap_file("gnome-error.png");
|
||||
+ s = gnome_unconditional_pixmap_file("gnome1-error.png");
|
||||
if (s) {
|
||||
pixmap = gnome_pixmap_new_from_file(s);
|
||||
g_free(s);
|
||||
@@ -136,7 +136,7 @@ gnome_message_box_new (const gchar
|
||||
else if (strcmp(GNOME_MESSAGE_BOX_QUESTION, message_box_type) == 0)
|
||||
{
|
||||
gtk_window_set_title (GTK_WINDOW (message_box), _("Question"));
|
||||
- s = gnome_unconditional_pixmap_file("gnome-question.png");
|
||||
+ s = gnome_unconditional_pixmap_file("gnome1-question.png");
|
||||
if (s) {
|
||||
pixmap = gnome_pixmap_new_from_file(s);
|
||||
g_free(s);
|
||||
@@ -155,7 +155,7 @@ gnome_message_box_new (const gchar
|
||||
if ( (pixmap == NULL) ||
|
||||
(GNOME_PIXMAP(pixmap)->pixmap == NULL) ) {
|
||||
if (pixmap) gtk_widget_destroy(pixmap);
|
||||
- s = gnome_unconditional_pixmap_file ("gnome-default-dlg.png");
|
||||
+ s = gnome_unconditional_pixmap_file ("gnome1-default-dlg.png");
|
||||
if (s) {
|
||||
pixmap = gnome_pixmap_new_from_file(s);
|
||||
g_free(s);
|
||||
@@ -242,7 +242,7 @@ gnome_message_box_newv (const gchar
|
||||
if (strcmp(GNOME_MESSAGE_BOX_INFO, message_box_type) == 0)
|
||||
{
|
||||
gtk_window_set_title (GTK_WINDOW (message_box), _("Information"));
|
||||
- s = gnome_pixmap_file("gnome-info.png");
|
||||
+ s = gnome_pixmap_file("gnome1-info.png");
|
||||
if (s) {
|
||||
pixmap = gnome_pixmap_new_from_file(s);
|
||||
g_free(s);
|
||||
@@ -251,7 +251,7 @@ gnome_message_box_newv (const gchar
|
||||
else if (strcmp(GNOME_MESSAGE_BOX_WARNING, message_box_type) == 0)
|
||||
{
|
||||
gtk_window_set_title (GTK_WINDOW (message_box), _("Warning"));
|
||||
- s = gnome_pixmap_file("gnome-warning.png");
|
||||
+ s = gnome_pixmap_file("gnome1-warning.png");
|
||||
if (s) {
|
||||
pixmap = gnome_pixmap_new_from_file(s);
|
||||
g_free(s);
|
||||
@@ -260,7 +260,7 @@ gnome_message_box_newv (const gchar
|
||||
else if (strcmp(GNOME_MESSAGE_BOX_ERROR, message_box_type) == 0)
|
||||
{
|
||||
gtk_window_set_title (GTK_WINDOW (message_box), _("Error"));
|
||||
- s = gnome_pixmap_file("gnome-error");
|
||||
+ s = gnome_pixmap_file("gnome1-error");
|
||||
if (s) {
|
||||
pixmap = gnome_pixmap_new_from_file(s);
|
||||
g_free(s);
|
||||
@@ -269,7 +269,7 @@ gnome_message_box_newv (const gchar
|
||||
else if (strcmp(GNOME_MESSAGE_BOX_QUESTION, message_box_type) == 0)
|
||||
{
|
||||
gtk_window_set_title (GTK_WINDOW (message_box), _("Question"));
|
||||
- s = gnome_pixmap_file("gnome-question.png");
|
||||
+ s = gnome_pixmap_file("gnome1-question.png");
|
||||
if (s) {
|
||||
pixmap = gnome_pixmap_new_from_file(s);
|
||||
g_free(s);
|
||||
@@ -288,7 +288,7 @@ gnome_message_box_newv (const gchar
|
||||
if ( (pixmap == NULL) ||
|
||||
(GNOME_PIXMAP(pixmap)->pixmap == NULL) ) {
|
||||
if (pixmap) gtk_widget_destroy(pixmap);
|
||||
- s = gnome_pixmap_file("gnome-default.png");
|
||||
+ s = gnome_pixmap_file("gnome1-default.png");
|
||||
if (s) {
|
||||
pixmap = gnome_pixmap_new_from_file(s);
|
||||
g_free(s);
|
22
x11/gnome-libs/patches/patch-ah
Normal file
22
x11/gnome-libs/patches/patch-ah
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-ah,v 1.6 2004/02/18 11:56:02 jmmv Exp $
|
||||
|
||||
--- images/Makefile.in.orig 2002-08-16 00:25:24.000000000 +0200
|
||||
+++ images/Makefile.in
|
||||
@@ -185,12 +185,13 @@ install-pixmapDATA: $(pixmap_DATA)
|
||||
@$(NORMAL_INSTALL)
|
||||
$(mkinstalldirs) $(DESTDIR)$(pixmapdir)
|
||||
@list='$(pixmap_DATA)'; for p in $$list; do \
|
||||
+ d=`echo $$p | sed -e 's|^gnome-|gnome1-|'`; \
|
||||
if test -f $(srcdir)/$$p; then \
|
||||
- echo " $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(pixmapdir)/$$p"; \
|
||||
- $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(pixmapdir)/$$p; \
|
||||
+ echo " $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(pixmapdir)/$$d"; \
|
||||
+ $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(pixmapdir)/$$d; \
|
||||
else if test -f $$p; then \
|
||||
- echo " $(INSTALL_DATA) $$p $(DESTDIR)$(pixmapdir)/$$p"; \
|
||||
- $(INSTALL_DATA) $$p $(DESTDIR)$(pixmapdir)/$$p; \
|
||||
+ echo " $(INSTALL_DATA) $$p $(DESTDIR)$(pixmapdir)/$$d"; \
|
||||
+ $(INSTALL_DATA) $$p $(DESTDIR)$(pixmapdir)/$$d; \
|
||||
fi; fi; \
|
||||
done
|
||||
|
Loading…
Reference in a new issue