Remove unwanted hunk from patch-au.

linkage target for Darwin is already exists, and the additonal target
break build on MacOS X 10.4.11 as reported by PR#42993.
This commit is contained in:
obache 2010-09-22 09:13:47 +00:00
parent ebfb20af67
commit 6027a800eb
2 changed files with 5 additions and 18 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.26 2010/09/16 13:24:47 obache Exp $
$NetBSD: distinfo,v 1.27 2010/09/22 09:13:47 obache Exp $
SHA1 (Python-2.6.6.tar.bz2) = a1daf2c2c7cffe0939c015260447572fe75c7e50
RMD160 (Python-2.6.6.tar.bz2) = 2d63f4f0ad3c124a8e62215ca94bd0231350e912
@ -14,5 +14,5 @@ SHA1 (patch-am) = 60c108d05a16c531ee6cf99e5c7ad9a5f27c5f01
SHA1 (patch-an) = 17b4e17b3b562c29a050e9bb20447084ce82b8ab
SHA1 (patch-ao) = 8c6a156b0f0c2a6d319658477fff348e6a0c3603
SHA1 (patch-ap) = d23a869a449ab9dc166cfa149913b20c9acad9cb
SHA1 (patch-au) = e0e6595311d4ee1eda45d381cab87cbba46b21d3
SHA1 (patch-au) = 38030fc45afc2a8f53a41f26b649e731642b9148
SHA1 (patch-av) = d6bf0419015656a8d2f13d3132873e453c8a6b6e

View file

@ -1,21 +1,8 @@
$NetBSD: patch-au,v 1.6 2010/09/04 05:12:00 obache Exp $
$NetBSD: patch-au,v 1.7 2010/09/22 09:13:48 obache Exp $
--- Makefile.pre.in.orig 2009-02-24 11:07:44.000000000 +0000
--- Makefile.pre.in.orig 2010-08-01 22:05:31.000000000 +0000
+++ Makefile.pre.in
@@ -425,6 +425,12 @@ libpython$(VERSION).dylib: $(LIBRARY_OBJ
libpython$(VERSION).sl: $(LIBRARY_OBJS)
$(LDSHARED) $(LDFLAGS) -o $@ $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST)
+libpython$(VERSION).dylib: $(LIBRARY_OBJS)
+ $(LINKCC) -dynamiclib -install_name $(LIBDIR)/$@ \
+ -current_version 2.6.6 -compatibility_version $(VERSION) \
+ -o $@ -flat_namespace -undefined suppress $(LDFLAGS) \
+ $(LIBRARY_OBJS) $(SHLIBS) $(LIBC) $(LIBM)
+
# This rule is here for OPENSTEP/Rhapsody/MacOSX. It builds a temporary
# minimal framework (not including the Lib directory and such) in the current
# directory.
@@ -785,7 +791,8 @@ altbininstall: $(BUILDPYTHON)
@@ -785,7 +785,8 @@ altbininstall: $(BUILDPYTHON)
(cd $(DESTDIR)$(LIBDIR); $(LN) -sf $(INSTSONAME) $(LDLIBRARY)) \
fi \
fi; \