Updated stunnel to 4.07
Version 4.07, 2005.01.03, urgency: MEDIUM: * Bugfixes - Problem with infinite poll() timeout negative, but not equal to -1 fixed. - Problem with a file descriptor ready to be read just after a non-blocking connect call fixed. - Compile error with EAI_NODATA not defined or equal to EAI_NONAME fixed. - IP address and TCP port textual representation length (IPLEN) increased to 128 bytes. - OpenSSL engine support is only used if engine.h header file exists.
This commit is contained in:
parent
0f2472c400
commit
6034a1d81a
4 changed files with 12 additions and 34 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.45 2004/12/29 09:53:17 minskim Exp $
|
||||
# $NetBSD: Makefile,v 1.46 2005/01/03 12:17:44 martti Exp $
|
||||
|
||||
DISTNAME= stunnel-4.06
|
||||
DISTNAME= stunnel-4.07
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= ftp://ftp.fu-berlin.de/unix/security/stunnel/ \
|
||||
ftp://stunnel.mirt.net/stunnel/ \
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.16 2004/12/28 09:09:52 martti Exp $
|
||||
$NetBSD: distinfo,v 1.17 2005/01/03 12:17:44 martti Exp $
|
||||
|
||||
SHA1 (stunnel-4.06.tar.gz) = cfabfe5b34c694297df6fc1d92fea37217d8f1a1
|
||||
Size (stunnel-4.06.tar.gz) = 484200 bytes
|
||||
SHA1 (stunnel-4.07.tar.gz) = fe9661148bda73ce5a48cd21baf99ecbdc477e1d
|
||||
Size (stunnel-4.07.tar.gz) = 486230 bytes
|
||||
SHA1 (patch-aa) = c8795837b7582de4d863fdd551501a4ef561bb0e
|
||||
SHA1 (patch-ab) = fccc8ffaf5d6023dd20700d201638d022b8638da
|
||||
SHA1 (patch-ac) = 081f259bbce31cab7a574f98c1f8c03aaa3f6491
|
||||
SHA1 (patch-ab) = 4a0de1c531f155304531fd1334576e9cda03d2e2
|
||||
|
|
|
@ -1,16 +1,16 @@
|
|||
$NetBSD: patch-ab,v 1.14 2004/12/28 09:09:52 martti Exp $
|
||||
$NetBSD: patch-ab,v 1.15 2005/01/03 12:17:44 martti Exp $
|
||||
|
||||
--- configure.orig 2004-12-26 01:31:18.000000000 +0200
|
||||
+++ configure 2004-12-28 12:30:28.000000000 +0200
|
||||
@@ -21348,2 +21348,3 @@
|
||||
--- configure.orig 2004-12-30 13:57:47.000000000 +0200
|
||||
+++ configure 2005-01-03 14:13:54.000000000 +0200
|
||||
@@ -21497,2 +21497,3 @@
|
||||
|
||||
+if false; then
|
||||
# OSF hack instead of simple AC_CHECK_LIB here
|
||||
@@ -21475,2 +21476,3 @@
|
||||
@@ -21624,2 +21625,3 @@
|
||||
fi
|
||||
+fi
|
||||
|
||||
@@ -22019,3 +22021,3 @@
|
||||
@@ -22168,3 +22170,3 @@
|
||||
LIBS="$LIBS $wrap_LIB"
|
||||
-CPPFLAGS="$CPPFLAGS -DLIBDIR=\\\"$libdir\\\" -DCONFDIR=\\\"$sysconfdir/stunnel\\\" -DPIDFILE=\\\"$localstatedir/run/stunnel.pid\\\""
|
||||
+CPPFLAGS="$CPPFLAGS -DLIBDIR=\\\"$libdir\\\" -DCONFDIR=\\\"$sysconfdir\\\" -DPIDFILE=\\\"$localstatedir/run/stunnel.pid\\\""
|
||||
|
|
|
@ -1,21 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.5 2004/12/28 09:09:52 martti Exp $
|
||||
|
||||
*** src/network.c 2004-10-14 17:03:49.000000000 +0200
|
||||
--- src/network.c 2004-12-27 21:21:16.000000000 +0100
|
||||
***************
|
||||
*** 125,131 ****
|
||||
int retval;
|
||||
|
||||
do { /* skip "Interrupted system call" errors */
|
||||
! retval=poll(fds->ufds, fds->nfds, 1000*timeout);
|
||||
/* no timeout -> main loop */
|
||||
if(timeout<0 && retval>0 && s_poll_canread(fds, signal_pipe[0]))
|
||||
signal_pipe_empty();
|
||||
--- 125,131 ----
|
||||
int retval;
|
||||
|
||||
do { /* skip "Interrupted system call" errors */
|
||||
! retval=poll(fds->ufds, fds->nfds, timeout<0 ? -1 : 1000*timeout);
|
||||
/* no timeout -> main loop */
|
||||
if(timeout<0 && retval>0 && s_poll_canread(fds, signal_pipe[0]))
|
||||
signal_pipe_empty();
|
Loading…
Reference in a new issue