Upgrade to lesstif 0.82, from Jim Bernard.
I modified the test in the Makefile which checks for a previous installation of real motif, since it wouldn't work if HAVE_MOTIF was set in /etc/mk.conf.
This commit is contained in:
parent
54802d7bd4
commit
6035cc67ca
6 changed files with 46 additions and 48 deletions
|
@ -1,46 +1,50 @@
|
|||
# New ports collection makefile for: lesstif
|
||||
# Version required: 0.81
|
||||
# Version required: 0.82
|
||||
# Date created: December 10, 1996
|
||||
# Whom: 1wardd@airmail.net
|
||||
#
|
||||
# $NetBSD: Makefile,v 1.4 1997/12/22 07:52:03 hubertf Exp $
|
||||
# $NetBSD: Makefile,v 1.5 1998/01/16 17:07:12 agc Exp $
|
||||
# FreeBSD Id: Makefile,v 1.13 1997/09/08 08:34:13 tg Exp
|
||||
#
|
||||
|
||||
DISTNAME= lesstif-0.81
|
||||
DISTNAME= lesstif-0.82
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= ftp://ftp.lesstif.org/pub/hungry/lesstif/ \
|
||||
ftp://ftp.hungry.com/pub/hungry/lesstif/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
||||
# see below for shared lib version information
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_X11= yes
|
||||
# change this and remove the strip statement in post-install for debugging
|
||||
CONFIGURE_ENV+= CCFLAGS="-O -pipe"
|
||||
CONFIGURE_ENV= CCFLAGS="-O -pipe"
|
||||
|
||||
.if defined(HAVE_MOTIF)
|
||||
# this is worst case, when you're about to overwrite real Motif with Lesstif
|
||||
IS_INTERACTIVE= yes
|
||||
pre-extract:
|
||||
@echo "***********************************************************"
|
||||
@echo "* W a r n i n g *"
|
||||
@echo "* This port will overwrite your Motif installation. *"
|
||||
@echo "***********************************************************"
|
||||
@echo -n "Is this ok? (y/n) ==> "
|
||||
@(read ans; \
|
||||
case x"$$ans" in \
|
||||
xy*|xY*) \
|
||||
return 0; \
|
||||
;; \
|
||||
*) \
|
||||
echo "Okay, I won't install it then...."; \
|
||||
echo "(Don't worry about the following \"*** Error code 1\"s)"; \
|
||||
return 1; \
|
||||
;; \
|
||||
esac)
|
||||
.endif
|
||||
|
||||
pre-fetch:
|
||||
@if [ -d ${X11BASE}/include/Xm ]; then \
|
||||
if [ -d ${X11BASE}/lib/X11/lesstif ]; then \
|
||||
echo "Upgrading a previous Lesstif installation"; \
|
||||
return 0; \
|
||||
fi; \
|
||||
echo "***********************************************************"; \
|
||||
echo "* W a r n i n g *"; \
|
||||
echo "* This port will overwrite your Motif installation. *"; \
|
||||
echo "***********************************************************"; \
|
||||
echo -n "Is this ok? (y/n) ==> "; \
|
||||
(read ans; \
|
||||
case x"$$ans" in \
|
||||
xy*|xY*) \
|
||||
return 0; \
|
||||
;; \
|
||||
*) \
|
||||
echo "Okay, I won't install it then...."; \
|
||||
echo "(Don't worry about the following \"*** Error code 1\"s)"; \
|
||||
return 1; \
|
||||
;; \
|
||||
esac) \
|
||||
fi
|
||||
|
||||
|
||||
post-install:
|
||||
|
@ -54,11 +58,3 @@ post-install:
|
|||
${LDCONFIG} -m ${PREFIX}/lib
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
||||
|
||||
# Shared lib versions
|
||||
# dist version BSD shared lib version
|
||||
# ------------ ----------------------
|
||||
# 0.78 0.0
|
||||
# 0.79 0.1
|
||||
# 0.80 0.1
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (lesstif-0.81.tar.gz) = a77362a3869d5aba8868b7e3de9d496f
|
||||
MD5 (lesstif-0.82.tar.gz) = c612c843030c622fea626a73de340dd0
|
||||
|
|
|
@ -1,15 +1,15 @@
|
|||
--- configure.orig Fri Sep 5 19:47:03 1997
|
||||
+++ configure Mon Sep 8 10:07:36 1997
|
||||
@@ -2556,7 +2556,7 @@
|
||||
--- configure.orig Wed Nov 19 16:32:40 1997
|
||||
+++ configure Thu Nov 27 15:23:19 1997
|
||||
@@ -2672,7 +2672,7 @@
|
||||
|
||||
|
||||
major_shared=0
|
||||
-minor_shared=81
|
||||
-minor_shared=82
|
||||
+minor_shared=1
|
||||
pico_version=
|
||||
|
||||
|
||||
@@ -2591,7 +2591,7 @@
|
||||
@@ -2708,7 +2708,7 @@
|
||||
|
||||
lexicographic_readdir=1
|
||||
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- config/free_net-bsd-shared.mk.orig Mon Apr 28 19:26:48 1997
|
||||
+++ config/free_net-bsd-shared.mk Thu May 22 22:59:55 1997
|
||||
--- config/free_net-bsd-shared.mk.orig Wed Nov 19 16:21:24 1997
|
||||
+++ config/free_net-bsd-shared.mk Thu Nov 27 16:01:50 1997
|
||||
@@ -26,15 +26,10 @@
|
||||
|
||||
${SHARED_LIB}: $(SH_OBJS)
|
||||
|
@ -14,5 +14,5 @@
|
|||
- rm -f ${lib_dir}/lib${lib_name}.so
|
||||
- ln -s ${lib_dir}/${SHARED_LIB} ${lib_dir}/lib${lib_name}.so
|
||||
|
||||
clean::
|
||||
rm -f ${SHARED_LIB} lib${lib_name}.so ${SH_OBJS}
|
||||
install-list::
|
||||
echo ${lib_dir}/${SHARED_LIB}
|
||||
|
|
|
@ -1,10 +1,11 @@
|
|||
--- clients/Motif-1.2/mwm/Makefile.in.orig Mon Apr 28 19:25:17 1997
|
||||
+++ clients/Motif-1.2/mwm/Makefile.in Mon Apr 21 10:19:32 1997
|
||||
@@ -88,6 +88,6 @@
|
||||
--- clients/Motif-1.2/mwm/Makefile.in.orig Wed Nov 19 16:20:11 1997
|
||||
+++ clients/Motif-1.2/mwm/Makefile.in Thu Nov 27 16:06:36 1997
|
||||
@@ -93,7 +93,7 @@
|
||||
|
||||
mwmlex.o: y.tab.h
|
||||
|
||||
-$(srcdir)/version.h: Makefile
|
||||
+version.h $(srcdir)/version.h: Makefile
|
||||
echo "#define VERSION \"@major_shared@.@minor_shared@\"" > $(srcdir)/version.h
|
||||
echo "#define VERSION \"@major_shared@.@minor_shared@\"" \
|
||||
> $(srcdir)/version.h
|
||||
|
||||
|
|
|
@ -1,8 +1,9 @@
|
|||
@comment $NetBSD: PLIST,v 1.4 1997/12/02 23:25:15 hubertf Exp $
|
||||
@comment $NetBSD: PLIST,v 1.5 1998/01/16 17:07:19 agc Exp $
|
||||
bin/mwm
|
||||
bin/mxmkmf
|
||||
bin/uil
|
||||
bin/xmbind
|
||||
include/Mrm/MrmAppl.h
|
||||
include/Mrm/MrmDecls.h
|
||||
include/Mrm/MrmPrivate.h
|
||||
include/Mrm/MrmPublic.h
|
||||
|
|
Loading…
Reference in a new issue