fix for powerpc.

This commit is contained in:
dmcmahill 2001-05-03 22:03:31 +00:00
parent 5614b8f2ff
commit 6048b53973
4 changed files with 37 additions and 16 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.7 2001/05/03 15:35:44 dmcmahill Exp $
# $NetBSD: Makefile,v 1.8 2001/05/03 22:03:31 dmcmahill Exp $
# FreeBSD: ports/devel/sdcc/Makefile,v 1.5 2000/04/15 15:13:38 knu Exp
DISTNAME= sdcc-2.2.1-src
@ -29,11 +29,16 @@ USE_GMAKE= yes
USE_PERL5= yes
CONFIGURE_ARGS+=--datadir=${LOCALBASE}/share/sdcc
# needed for some arch's. -fdollars-in-identifiers is enabled
# by default on some, not on others
CPPFLAGS+= -fdollars-in-identifiers
CONFIGURE_ENV+= MACHINE_ARCH=${MACHINE_ARCH}
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
.include "../../mk/bsd.prefs.mk"
.if ${OPSYS} == "NetBSD"
CONFIGURE_ENV+= CPPFLAGS=-I${WRKDIR}/include
CPPFLAGS+= -I${WRKDIR}/include
post-extract:
${MKDIR} ${WRKDIR}/include

View file

@ -1,16 +1,16 @@
$NetBSD: distinfo,v 1.4 2001/04/29 16:15:15 dmcmahill Exp $
$NetBSD: distinfo,v 1.5 2001/05/03 22:03:31 dmcmahill Exp $
SHA1 (sdcc-2.2.1-src.tar.gz) = c0d448bbdc86620d87b781f62635c51ab44b2235
Size (sdcc-2.2.1-src.tar.gz) = 2015592 bytes
SHA1 (patch-aa) = 94c041b23f72f0bd51ef76625c450f4938811808
SHA1 (patch-ab) = 41d6d664da79ba97061d74428dc9cd3d3329901c
SHA1 (patch-ac) = 1f02ed2239cc8c5c8a4286303bf0d6fa87ac42d8
SHA1 (patch-ac) = f291412d2fd15052ff8dd86874a4f2e208cb31ff
SHA1 (patch-ad) = 87e80d25073d3e225c2094145df64867c287ad30
SHA1 (patch-ae) = 5f6414ea1c00524efbf95745532471035afbfd52
SHA1 (patch-af) = eda3a2f04a7a929ba117abab5a15283a5c47ef12
SHA1 (patch-ag) = 966234636ef78fa4bc46bb959664f27ef386a01d
SHA1 (patch-ah) = cd19f7fa5a3c684eaf8982a4866bb7691f368ffa
SHA1 (patch-ai) = 40df752b589e746d568de5af6e0e589445a57632
SHA1 (patch-ai) = 35dac8265be56cc77c5547fa0bc1240d80801f72
SHA1 (patch-aj) = 9f936132c94b4920df1a276dbebfc1f050ef7ac0
SHA1 (patch-ak) = 412efd5a8ba3713d0efd7e7fa994deaae5e03507
SHA1 (patch-al) = a1f8378bf7cf7a204743fdba44bdf5bd5f278a04

View file

@ -1,13 +1,21 @@
$NetBSD: patch-ac,v 1.3 2001/04/23 17:33:06 wulf Exp $
$NetBSD: patch-ac,v 1.4 2001/05/03 22:03:31 dmcmahill Exp $
--- configure.orig Mon Apr 9 20:25:23 2001
+++ configure Mon Apr 9 20:25:58 2001
@@ -1083,7 +1083,7 @@
# ./install, which can be erroneously created by make from ./install.sh.
a bug with -ggdb on powerpc was tickled by some of the code for ucsim
so don't use it on that platform.
--- configure.orig Sat Sep 30 17:37:31 2000
+++ configure Thu May 3 15:06:17 2001
@@ -1084,5 +1084,5 @@
echo $ac_n "checking for a BSD compatible install""... $ac_c" 1>&6
echo "configure:1086: checking for a BSD compatible install" >&5
-if test -z "$INSTALL"; then
+if true; then
if eval "test \"`echo '$''{'ac_cv_path_install'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
@@ -2324,5 +2324,5 @@
EOF
$CC -v -ggdb -c _test_.c 1>&5 2>&5
-if test "$?" = "0"; then
+if test "$?" = "0" -a "$MACHINE_ARCH" != "powerpc" ; then
sdcc_cv_CCggdb="yes"
else

View file

@ -1,13 +1,21 @@
$NetBSD: patch-ai,v 1.2 2001/04/23 17:33:06 wulf Exp $
$NetBSD: patch-ai,v 1.3 2001/05/03 22:03:31 dmcmahill Exp $
--- sim/ucsim/configure.orig Mon Apr 9 20:37:52 2001
+++ sim/ucsim/configure Mon Apr 9 20:38:10 2001
@@ -812,7 +812,7 @@
# ./install, which can be erroneously created by make from ./install.sh.
a bug with -ggdb on powerpc was tickled by some of the code for ucsim
so don't use it on that platform.
--- sim/ucsim/configure.orig Fri Sep 29 15:59:12 2000
+++ sim/ucsim/configure Thu May 3 11:01:54 2001
@@ -813,5 +813,5 @@
echo $ac_n "checking for a BSD compatible install""... $ac_c" 1>&6
echo "configure:815: checking for a BSD compatible install" >&5
-if test -z "$INSTALL"; then
+if true; then
if eval "test \"`echo '$''{'ac_cv_path_install'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
@@ -2292,5 +2292,5 @@
EOF
$CXX -v -ggdb -c _test_.c 1>&5 2>&5
-if test "$?" = "0"; then
+if test "$?" = "0" -a "$MACHINE_ARCH" != "powerpc"; then
s51_cv_CXXggdb="yes"
else