Initial import of py-cookiecutter, version 1.3.0,
into the NetBSD Packages Collection. Cookiecutter is a command-line utility that creates projects from cookiecutters (project templates), e.g. creating a Python package project from a Python package project template.
This commit is contained in:
parent
e2fd1c1a26
commit
604ffdfd7f
6 changed files with 156 additions and 0 deletions
4
devel/py-cookiecutter/DESCR
Normal file
4
devel/py-cookiecutter/DESCR
Normal file
|
@ -0,0 +1,4 @@
|
|||
Cookiecutter is a command-line utility that creates
|
||||
projects from cookiecutters (project templates),
|
||||
e.g. creating a Python package project from a
|
||||
Python package project template.
|
51
devel/py-cookiecutter/Makefile
Normal file
51
devel/py-cookiecutter/Makefile
Normal file
|
@ -0,0 +1,51 @@
|
|||
# $NetBSD: Makefile,v 1.1 2016/05/16 15:05:48 nils Exp $
|
||||
|
||||
DISTNAME= cookiecutter-1.3.0
|
||||
GITHUB_PROJECT= cookiecutter
|
||||
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=audreyr/}
|
||||
EXTRACT_SUFX= .zip
|
||||
|
||||
MAINTAINER= gde@llew.me
|
||||
HOMEPAGE= ${MASTER_SITE_GITHUB:=audreyr/cookiecutter/}
|
||||
COMMENT= Command-line utility that creates projects from project templates
|
||||
LICENSE= modified-bsd
|
||||
|
||||
USE_LANGUAGES= # none
|
||||
USE_TOOLS+= make:build
|
||||
AUTO_MKDIRS= yes
|
||||
INSTALLATION_DIRS+= ${PKGMANDIR}/man1/
|
||||
|
||||
BUILD_DEPENDS+= ${PYPKGPREFIX}-sphinx>=1.2.3nb1:../../textproc/py-sphinx
|
||||
BUILD_DEPENDS+= ${PYPKGPREFIX}-chardet>=2.3.0:../../converters/py-chardet
|
||||
BUILD_DEPENDS+= ${PYPKGPREFIX}-test>=2.3.0:../../devel/py-test
|
||||
DEPENDS+= ${PYPKGPREFIX}-future>=0.15.2:../../devel/py-future
|
||||
DEPENDS+= ${PYPKGPREFIX}-binaryornot>=0.2.0:../../devel/py-binaryornot
|
||||
DEPENDS+= ${PYPKGPREFIX}-jinja2>=2.7:../../textproc/py-jinja2
|
||||
DEPENDS+= ${PYPKGPREFIX}-click>=6.3:../../devel/py-click
|
||||
DEPENDS+= ${PYPKGPREFIX}-whichcraft>=0.1.1:../../devel/py-whichcraft
|
||||
DEPENDS+= ${PYPKGPREFIX}-ruamel-yaml>=0.10.12:../../devel/py-ruamel-yaml
|
||||
DEPENDS+= ${PYPKGPREFIX}-markupsafe-[0-9]*:../../textproc/py-markupsafe
|
||||
|
||||
# for python < 3.0
|
||||
.include "../../lang/python/pyversion.mk"
|
||||
.if ${_PYTHON_VERSION} < 30
|
||||
DEPENDS+= ${PYPKGPREFIX}-mock-[0-9]*:../../devel/py-mock
|
||||
.endif
|
||||
|
||||
PLIST_SUBST+= PYVERSSUFFIX=${PYVERSSUFFIX}
|
||||
REPLACE_PYTHON+= setup.py
|
||||
REPLACE_PYTHON+= cookiecutter/*.py
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}
|
||||
|
||||
post-build:
|
||||
cd ${WRKSRC}/docs/ && make SPHINXBUILD=${PREFIX}/bin/sphinx-build${PYVERSSUFFIX} man
|
||||
|
||||
post-install:
|
||||
${INSTALL_MAN} ${WRKSRC}/docs/_build/man/cookiecutter.1 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/
|
||||
|
||||
.include "../../lang/python/application.mk"
|
||||
.include "../../lang/python/egg.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
46
devel/py-cookiecutter/PLIST
Normal file
46
devel/py-cookiecutter/PLIST
Normal file
|
@ -0,0 +1,46 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2016/05/16 15:05:48 nils Exp $
|
||||
bin/cookiecutter
|
||||
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
|
||||
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
|
||||
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
|
||||
${PYSITELIB}/${EGG_INFODIR}/entry_points.txt
|
||||
${PYSITELIB}/${EGG_INFODIR}/not-zip-safe
|
||||
${PYSITELIB}/${EGG_INFODIR}/requires.txt
|
||||
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
|
||||
${PYSITELIB}/cookiecutter/__init__.py
|
||||
${PYSITELIB}/cookiecutter/__init__.pyc
|
||||
${PYSITELIB}/cookiecutter/__init__.pyo
|
||||
${PYSITELIB}/cookiecutter/cli.py
|
||||
${PYSITELIB}/cookiecutter/cli.pyc
|
||||
${PYSITELIB}/cookiecutter/cli.pyo
|
||||
${PYSITELIB}/cookiecutter/config.py
|
||||
${PYSITELIB}/cookiecutter/config.pyc
|
||||
${PYSITELIB}/cookiecutter/config.pyo
|
||||
${PYSITELIB}/cookiecutter/exceptions.py
|
||||
${PYSITELIB}/cookiecutter/exceptions.pyc
|
||||
${PYSITELIB}/cookiecutter/exceptions.pyo
|
||||
${PYSITELIB}/cookiecutter/find.py
|
||||
${PYSITELIB}/cookiecutter/find.pyc
|
||||
${PYSITELIB}/cookiecutter/find.pyo
|
||||
${PYSITELIB}/cookiecutter/generate.py
|
||||
${PYSITELIB}/cookiecutter/generate.pyc
|
||||
${PYSITELIB}/cookiecutter/generate.pyo
|
||||
${PYSITELIB}/cookiecutter/hooks.py
|
||||
${PYSITELIB}/cookiecutter/hooks.pyc
|
||||
${PYSITELIB}/cookiecutter/hooks.pyo
|
||||
${PYSITELIB}/cookiecutter/main.py
|
||||
${PYSITELIB}/cookiecutter/main.pyc
|
||||
${PYSITELIB}/cookiecutter/main.pyo
|
||||
${PYSITELIB}/cookiecutter/prompt.py
|
||||
${PYSITELIB}/cookiecutter/prompt.pyc
|
||||
${PYSITELIB}/cookiecutter/prompt.pyo
|
||||
${PYSITELIB}/cookiecutter/replay.py
|
||||
${PYSITELIB}/cookiecutter/replay.pyc
|
||||
${PYSITELIB}/cookiecutter/replay.pyo
|
||||
${PYSITELIB}/cookiecutter/utils.py
|
||||
${PYSITELIB}/cookiecutter/utils.pyc
|
||||
${PYSITELIB}/cookiecutter/utils.pyo
|
||||
${PYSITELIB}/cookiecutter/vcs.py
|
||||
${PYSITELIB}/cookiecutter/vcs.pyc
|
||||
${PYSITELIB}/cookiecutter/vcs.pyo
|
||||
man/man1/cookiecutter.1
|
8
devel/py-cookiecutter/distinfo
Normal file
8
devel/py-cookiecutter/distinfo
Normal file
|
@ -0,0 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.1 2016/05/16 15:05:48 nils Exp $
|
||||
|
||||
SHA1 (cookiecutter-1.3.0.zip) = 621a7f8f3ad0bd543917ca9c57cb70d7a80ed18f
|
||||
RMD160 (cookiecutter-1.3.0.zip) = 0f402dee6e5dd85b689dcc8c473fc755cd7d029b
|
||||
SHA512 (cookiecutter-1.3.0.zip) = 540300e917b1f91c9936d799e2ac3afd61ff8eb95639dc31dc61fd9aece6f9f283dd688a3ac780c5cb6eae299a85fbb89e1cf78cdefdd14501a9debff83eddfe
|
||||
Size (cookiecutter-1.3.0.zip) = 274125 bytes
|
||||
SHA1 (patch-docs_Makefile) = c0451b26ea79a8ebd7ca0f733264806fea84857d
|
||||
SHA1 (patch-setup.py) = 1dd484db3ebb1202ead6a2bf48746751c5e1ab2b
|
19
devel/py-cookiecutter/patches/patch-docs_Makefile
Normal file
19
devel/py-cookiecutter/patches/patch-docs_Makefile
Normal file
|
@ -0,0 +1,19 @@
|
|||
$NetBSD: patch-docs_Makefile,v 1.1 2016/05/16 15:05:48 nils Exp $
|
||||
|
||||
removed non-working check for sphinx
|
||||
|
||||
--- docs/Makefile.orig 2015-03-16 12:49:03.000000000 +0000
|
||||
+++ docs/Makefile
|
||||
@@ -8,9 +8,9 @@ PAPER =
|
||||
BUILDDIR = _build
|
||||
|
||||
# User-friendly check for sphinx-build
|
||||
-ifeq ($(shell which $(SPHINXBUILD) >/dev/null 2>&1; echo $$?), 1)
|
||||
-$(error The '$(SPHINXBUILD)' command was not found. Make sure you have Sphinx installed, then set the SPHINXBUILD environment variable to point to the full path of the '$(SPHINXBUILD)' executable. Alternatively you can add the directory with the executable to your PATH. If you don't have Sphinx installed, grab it from http://sphinx-doc.org/)
|
||||
-endif
|
||||
+#ifeq ($(shell which $(SPHINXBUILD) >/dev/null 2>&1; echo $$?), 1)
|
||||
+#$(error The '$(SPHINXBUILD)' command was not found. Make sure you have Sphinx installed, then set the SPHINXBUILD environment variable to point to the full path of the '$(SPHINXBUILD)' executable. Alternatively you can add the directory with the executable to your PATH. If you don't have Sphinx installed, grab it from http://sphinx-doc.org/)
|
||||
+#endif
|
||||
|
||||
# Internal variables.
|
||||
PAPEROPT_a4 = -D latex_paper_size=a4
|
28
devel/py-cookiecutter/patches/patch-setup.py
Normal file
28
devel/py-cookiecutter/patches/patch-setup.py
Normal file
|
@ -0,0 +1,28 @@
|
|||
$NetBSD: patch-setup.py,v 1.1 2016/05/16 15:05:48 nils Exp $
|
||||
|
||||
Fix build with python-3.x and C locale.
|
||||
https://github.com/audreyr/cookiecutter/pull/639
|
||||
|
||||
--- setup.py.orig 2015-11-10 22:47:32.000000000 +0000
|
||||
+++ setup.py
|
||||
@@ -1,6 +1,7 @@
|
||||
#!/usr/bin/env python
|
||||
|
||||
import os
|
||||
+import io
|
||||
import sys
|
||||
|
||||
try:
|
||||
@@ -20,10 +21,10 @@ if sys.argv[-1] == 'tag':
|
||||
os.system("git push --tags")
|
||||
sys.exit()
|
||||
|
||||
-with open('README.rst') as readme_file:
|
||||
+with io.open('README.rst', 'r', encoding='utf-8') as readme_file:
|
||||
readme = readme_file.read()
|
||||
|
||||
-with open('HISTORY.rst') as history_file:
|
||||
+with io.open('HISTORY.rst', 'r', encoding='utf-8') as history_file:
|
||||
history = history_file.read().replace('.. :changelog:', '')
|
||||
|
||||
requirements = [
|
Loading…
Reference in a new issue