set this up to use the older ServiceDiscovery API when appropriate
This commit is contained in:
parent
5083fcfd02
commit
607e28d161
3 changed files with 31 additions and 4 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.5 2009/05/07 18:01:22 plunky Exp $
|
||||
# $NetBSD: Makefile,v 1.6 2009/05/12 14:36:28 plunky Exp $
|
||||
|
||||
DISTNAME= bthfp-0.1
|
||||
CATEGORIES= comms
|
||||
|
@ -18,8 +18,13 @@ INSTALLATION_DIRS= bin ${PKGMANDIR}/man1
|
|||
|
||||
USE_BSD_MAKEFILE= yes
|
||||
|
||||
# (work in progress) make sure it uses old SDP API
|
||||
CPPFLAGS+= -DSDP_COMPAT
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
# This uses the older ServiceDiscovery API
|
||||
.if (${OPSYS} == "NetBSD" && \
|
||||
(!empty(OS_VERSION:M5.99.*) || !empty(OS_VERSION:M[6-9].*)))
|
||||
MAKE_ENV+= HAVE_LIBSDP=no
|
||||
.endif
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/bthfp ${DESTDIR}${PREFIX}/bin
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.2 2008/06/21 20:47:28 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.3 2009/05/12 14:36:28 plunky Exp $
|
||||
|
||||
SHA1 (bthfp-0.1.tar.gz) = f0cefa424596545dec3c7d61eb9e608e8178871b
|
||||
RMD160 (bthfp-0.1.tar.gz) = 5185c59ee67a7482ec8c424172fdeebed5bb3238
|
||||
Size (bthfp-0.1.tar.gz) = 8522 bytes
|
||||
SHA1 (patch-aa) = 66e1d2be8a9de92b7a47bea8bba0adb68510d740
|
||||
SHA1 (patch-ab) = 83a4185d99f658ca7a1779c5854dc71855277baf
|
||||
|
|
21
comms/bthfp/patches/patch-ab
Normal file
21
comms/bthfp/patches/patch-ab
Normal file
|
@ -0,0 +1,21 @@
|
|||
$NetBSD: patch-ab,v 1.1 2009/05/12 14:36:28 plunky Exp $
|
||||
|
||||
--- Makefile.orig 2009-05-12 13:22:31.000000000 +0100
|
||||
+++ Makefile 2009-05-12 13:23:00.000000000 +0100
|
||||
@@ -4,7 +4,14 @@
|
||||
SRCS= bthfp.c
|
||||
MAN= bthfp.1
|
||||
|
||||
-DPADD+= ${LIBBLUETOOTH} ${LIBEVENT} ${LIBSDP}
|
||||
-LDADD+= -lbluetooth -levent -lsdp
|
||||
+DPADD+= ${LIBBLUETOOTH} ${LIBEVENT}
|
||||
+LDADD+= -lbluetooth -levent
|
||||
+
|
||||
+.if (${HAVE_LIBSDP:Uyes} == "no")
|
||||
+CPPFLAGS+= -DSDP_COMPAT
|
||||
+.else
|
||||
+DPADD+= ${LIBSDP}
|
||||
+LDADD+= -lsdp
|
||||
+.endif
|
||||
|
||||
.include <bsd.prog.mk>
|
Loading…
Reference in a new issue