Update socat to 1.4.0.2

- Change to my NetBSD email address

####################### V 1.4.0.2:

corrections:
	exec'd write-only addresses get a chance to flush before being killed
	error handler: print notice on error-exit
	filan printed wrong file type information

####################### V 1.4.0.1:

corrections:
	socks4a constructed invalid header. Problem found, reported, and fixed
	by Thomas Themel, by Peter Palfrader, and by rik
	with nofork, don't forget to apply some process related options
	(chroot, setsid, setpgid, ...)

####################### V 1.4.0.0:

new features:
	simple openssl server (ssl-l), experimental openssl trust
	new options "cafile", "capath", "key", "cert", "egd", and "pseudo" for
	openssl
	new options "retry", "forever", and "intervall"
	option "fork" for address TCP improves `gender changer´
	options "sigint", "sigquit", and "sighup" control passing of signals to
	sub process (thanks to David Shea who contributed to this issue)
	readline takes respect to the prompt issued by the peer address
	options "prompt" and "noprompt" allow to override readline's new
	default behaviour
	readline supports invisible password with option "noecho"
	socat option -lp allows to set hostname in log output
	socat option -lu turns on microsecond resolution in log output

corrections:
	before reading available data, check if writing on other channel is
	possible
	tcp6, udp6: support hostname specification (not only IP address), and
	map IP4 names to IP6 addresses
	openssl client checks server certificate per default
	support unidirectional communication with exec/system subprocess
	try to restore original terminal settings when terminating
	test.sh uses tmp dir /tmp/$USER/$$ instead of /tmp/$$
	socks4 failed on platforms where long does not have 32 bits
	(thanks to Peter Palfrader and Thomas Seyrat)
	hstrerror substitute wrote wrong messages (HP-UX, Solaris)
	proxy error message was truncated when answer contained multiple spaces

porting:
	compiles with AIX xlc, HP-UX cc, Tru64 cc (but might not link)
This commit is contained in:
adrianp 2004-09-30 12:42:45 +00:00
parent 70b06d8f88
commit 608c757adf
3 changed files with 14 additions and 14 deletions

View file

@ -1,15 +1,14 @@
# $NetBSD: Makefile,v 1.2 2004/03/26 02:27:49 wiz Exp $
# $NetBSD: Makefile,v 1.3 2004/09/30 12:42:45 adrianp Exp $
DISTNAME= socat-1.3.2.2
PKGREVISION= 1
DISTNAME= socat-1.4.0.2
CATEGORIES= net
MASTER_SITES= http://www.dest-unreach.org/socat/download/
MAINTAINER= adrianp@stindustries.net
MAINTAINER= adrianp@NetBSD.org
HOMEPAGE= http://www.dest-unreach.org/socat/
COMMENT= "netcat++" (extended design, new implementation)
WRKSRC= ${WRKDIR}/socat-1.3
WRKSRC= ${WRKDIR}/socat-1.4
GNU_CONFIGURE= YES
USE_BUILDLINK3= YES
USE_GNU_READLINE= YES

View file

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2004/02/14 22:43:38 minskim Exp $
$NetBSD: distinfo,v 1.2 2004/09/30 12:42:46 adrianp Exp $
SHA1 (socat-1.3.2.2.tar.gz) = 5026fdc2f65af4a7c711d08fc3cbace5123465ec
Size (socat-1.3.2.2.tar.gz) = 285280 bytes
SHA1 (patch-aa) = fae16d2affc6d821f51675cd8f456d41efb0cff9
SHA1 (socat-1.4.0.2.tar.gz) = ef10a2fb1ee0739b8c86b6b4143b851548810bc1
Size (socat-1.4.0.2.tar.gz) = 318982 bytes
SHA1 (patch-aa) = 80e88873bd80c98f8d9209c1b2204c8addb2bdb0

View file

@ -1,15 +1,16 @@
$NetBSD: patch-aa,v 1.1.1.1 2004/02/14 22:43:38 minskim Exp $
$NetBSD: patch-aa,v 1.2 2004/09/30 12:42:46 adrianp Exp $
--- Makefile.in.orig 2003-10-19 03:01:41.000000000 -0500
+++ Makefile.in
@@ -21,11 +21,11 @@ srcdir = @srcdir@
--- Makefile.in.orig 2004-09-30 13:23:21.000000000 +0000
+++ Makefile.in 2004-09-30 13:24:30.000000000 +0000
@@ -21,12 +21,12 @@
VPATH = @srcdir@
CC = @CC@
-CCOPTS = $(CCOPT) -Wall -Wno-parentheses
+CCOPTS = $(CCOPT)
INCLS = -I. @V_INCL@
CPPFLAGS = -I. @CPPFLAGS@
#0 INCLS = -I. @V_INCL@
DEFS = @DEFS@
-LIBS = @LIBS@
+LIBS = @LDFLAGS@ @LIBS@