Strongly buildlinkify. Note dependency on tcp_wrappers for platforms
without -lwrap. Also prevent finding any existing Berkeley DB 3.x in /usr/local.
This commit is contained in:
parent
f8d6e1d4b5
commit
6091f731ba
4 changed files with 13 additions and 33 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.25 2001/11/01 00:17:42 zuntum Exp $
|
||||
# $NetBSD: Makefile,v 1.26 2001/11/02 02:59:28 jlam Exp $
|
||||
#
|
||||
|
||||
.include "../../databases/mysql-client/Makefile.common"
|
||||
.include "../mysql-client/Makefile.common"
|
||||
|
||||
PKGNAME= ${DISTNAME:S/-/-server-/}
|
||||
SVR4_PKGNAME= mysqs
|
||||
|
@ -9,11 +9,16 @@ COMMENT= MySQL, a free SQL database (server)
|
|||
|
||||
DEPENDS+= ${DISTNAME:S/-/-client-/}:../../databases/mysql-client
|
||||
|
||||
USE_BUILDLINK_ONLY= YES
|
||||
|
||||
# hardwire use of included mit-pthreads on NetBSD
|
||||
.if (${OPSYS} == "NetBSD")
|
||||
CONFIGURE_ARGS+= --with-mit-threads
|
||||
.endif
|
||||
|
||||
CONFIGURE_ARGS+= --with-libwrap
|
||||
CONFIGURE_ARGS+= --without-berkeley-db
|
||||
|
||||
# platforms on which included mit-pthreads is usable
|
||||
ONLY_FOR_PLATFORM= NetBSD-*-alpha NetBSD-*-arm32 NetBSD-*-i386 \
|
||||
NetBSD-*-sparc NetBSD-*-m68k SunOS-*-sparc \
|
||||
|
@ -40,4 +45,5 @@ post-install:
|
|||
${INSTALL_MAN} ${WRKSRC}/man/safe_mysqld.1 ${PREFIX}/man/man1
|
||||
PKG_PREFIX=${PREFIX} ${SH} ${INSTALL_FILE} ${PKGNAME} POST-INSTALL
|
||||
|
||||
.include "../../security/tcp_wrappers/buildlink.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.8 2001/10/08 17:28:12 veego Exp $
|
||||
$NetBSD: distinfo,v 1.9 2001/11/02 02:59:28 jlam Exp $
|
||||
|
||||
SHA1 (mysql-3.23.43.tar.gz) = ebae00aeac2b301ebaf9a919c070a0005d4b1ac3
|
||||
Size (mysql-3.23.43.tar.gz) = 11777006 bytes
|
||||
SHA1 (patch-aa) = 05c56d81e17893dd267fcd5f68d8c378f024a06f
|
||||
SHA1 (patch-ae) = 3df96ba682364349ae1d955328da76cc59810b1b
|
||||
SHA1 (patch-af) = 5492aad46ff87863856ae459f8237f2bf8722ce4
|
||||
SHA1 (patch-ae) = 110821fa59b2cb63daa8c93c6d97a14bb463a49d
|
||||
SHA1 (patch-af) = 45a0e51567d869c40ed7a13c67648279c40c730a
|
||||
SHA1 (patch-ah) = 7cd4278c9bdc5220de04f7e6b62bb8d11c892ffb
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-ae,v 1.7 2001/10/08 17:24:17 veego Exp $
|
||||
$NetBSD: patch-ae,v 1.8 2001/11/02 02:59:28 jlam Exp $
|
||||
|
||||
--- configure.in-orig Wed Oct 3 18:08:31 2001
|
||||
+++ configure.in Sun Oct 7 19:56:24 2001
|
||||
|
@ -10,16 +10,3 @@ $NetBSD: patch-ae,v 1.7 2001/10/08 17:24:17 veego Exp $
|
|||
AC_SUBST(bench_dirs)
|
||||
|
||||
# Don't build readline, i have it already
|
||||
@@ -1727,7 +1726,11 @@
|
||||
# This requires readline to be in a standard place. Mosty for linux
|
||||
# there readline may be a shared library.
|
||||
readline_dir=""
|
||||
- readline_link="-lreadline"
|
||||
+ if test -z "$readline_lib"
|
||||
+ then
|
||||
+ readline_lib="readline"
|
||||
+ fi
|
||||
+ readline_link="-l$readline_lib"
|
||||
fi
|
||||
AC_SUBST(readline_dir)
|
||||
AC_SUBST(readline_link)
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-af,v 1.7 2001/10/08 17:24:17 veego Exp $
|
||||
$NetBSD: patch-af,v 1.8 2001/11/02 02:59:29 jlam Exp $
|
||||
|
||||
--- configure-orig Wed Oct 3 18:08:48 2001
|
||||
+++ configure Sun Oct 7 19:58:54 2001
|
||||
|
@ -10,16 +10,3 @@ $NetBSD: patch-af,v 1.7 2001/10/08 17:24:17 veego Exp $
|
|||
|
||||
|
||||
# Don't build readline, i have it already
|
||||
@@ -9638,7 +9637,11 @@
|
||||
# This requires readline to be in a standard place. Mosty for linux
|
||||
# there readline may be a shared library.
|
||||
readline_dir=""
|
||||
- readline_link="-lreadline"
|
||||
+ if test -z "$readline_lib"
|
||||
+ then
|
||||
+ readline_lib="readline"
|
||||
+ fi
|
||||
+ readline_link="-l$readline_lib"
|
||||
fi
|
||||
|
||||
|
||||
|
|
Loading…
Reference in a new issue