Update opencpn to 4.0.0. Changes since 3.2.2:
- Increased performance in all modes, particularly when using OpenGL graphics acceleration. - Additional network interface methods, including TCP/IP client/server and UDP broadcast. - Support for multiple data source instances, including Filtering and prioritization of messages Output of NMEA data streams for real-time integration into ship systems - Improved support for Mac OS X systems, including 64 bit native support. - Integrated Tablet/Touch screen support. - AIS Personal Locater Beacon (PLB) configuration and tracking. - Enhanced AIS target tracking modes. - GRIB PlugIn feature additions. Graphical GRIB email request generation. Moving particle wind overlay. Enhanced GRIB data type support. - Dashboard PlugIn feature additions. More selectable instruments. - Major update to embedded Users Manual. - Measurably improved performance and reliability over all supported platforms.
This commit is contained in:
parent
e7120f7592
commit
60cbae90c8
8 changed files with 740 additions and 475 deletions
|
@ -1,10 +1,9 @@
|
|||
# $NetBSD: Makefile,v 1.2 2014/07/08 14:59:40 jperkin Exp $
|
||||
# $NetBSD: Makefile,v 1.3 2015/01/22 12:34:15 bouyer Exp $
|
||||
#
|
||||
|
||||
VERSION= 3.2.2
|
||||
VERSION= 4.0.0
|
||||
DISTNAME= OpenCPN-${VERSION}-Source
|
||||
PKGNAME= opencpn-${VERSION}
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= geography
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=opencpn/${VERSION}/}
|
||||
|
||||
|
@ -18,6 +17,7 @@ USE_TOOLS= gettext
|
|||
USE_CMAKE= yes
|
||||
|
||||
CMAKE_ARGS+= -DPREFIX:PATH=${PREFIX} -DPREFIX_PLUGINS:PATH=${PREFIX}/lib/opencpn
|
||||
CMAKE_ARGS+= -DBUNDLE_DOCS=ON -DBUNDLE_GSHHS=CRUDE -DBUNDLE_TCDATA=ON
|
||||
CMAKE_MODULE_PATH_OVERRIDE = \
|
||||
plugins/grib_pi/CMakeLists.txt \
|
||||
plugins/demo_pi_sample/src/CMakeLists.txt \
|
||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -1,9 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.1 2014/05/25 18:26:57 bouyer Exp $
|
||||
$NetBSD: distinfo,v 1.2 2015/01/22 12:34:15 bouyer Exp $
|
||||
|
||||
SHA1 (OpenCPN-3.2.2-Source.tar.gz) = 7395a97e50c2a47adce5bd9f62bf56cea1e41746
|
||||
RMD160 (OpenCPN-3.2.2-Source.tar.gz) = 8a0232a52c3cd954fc934b3edcec78c45149f250
|
||||
Size (OpenCPN-3.2.2-Source.tar.gz) = 158329955 bytes
|
||||
SHA1 (patch-CMakeLists.txt) = 2b4d3f525843ca8fa0e6d0b17cc51273a08f92e9
|
||||
SHA1 (patch-FindPortaudio.cmake) = 8e8de78e3b19e83cb35781161c28c4f655ca26fc
|
||||
SHA1 (patch-src_chart1.cpp) = d80d301d6e814ecd21c3fca1eed4af108774ffd2
|
||||
SHA1 (patch-src_tcmgr.cpp) = efdd45f07a19f2acf256307fa5195f9909d46961
|
||||
SHA1 (OpenCPN-4.0.0-Source.tar.gz) = a8fe31476a3472cff18e55179094cbc4434699ce
|
||||
RMD160 (OpenCPN-4.0.0-Source.tar.gz) = 614889e41c8cd5453f3210781201cb29912d8cc1
|
||||
Size (OpenCPN-4.0.0-Source.tar.gz) = 193305992 bytes
|
||||
SHA1 (patch-CMakeLists.txt) = 57abad7a02bf5fa64a522aceeddc4c67a3d5a3e2
|
||||
SHA1 (patch-FindPortaudio.cmake) = e1bebe2203c6f3dc76f92ee5bdcb01eca66b6b9a
|
||||
SHA1 (patch-src_chart1.cpp) = ae7c1d8a59c9a275914a613205de71e2dca89dc6
|
||||
SHA1 (patch-src_crashprint.cpp) = a96e8aa980eb3b19c3dce3343582511d608e6625
|
||||
SHA1 (patch-src_tcmgr.cpp) = 3fb4edf3368f3f3907f231ebcabd8e5061699040
|
||||
|
|
|
@ -1,17 +1,16 @@
|
|||
$NetBSD: patch-CMakeLists.txt,v 1.1 2014/05/25 18:26:57 bouyer Exp $
|
||||
$NetBSD: patch-CMakeLists.txt,v 1.2 2015/01/22 12:34:15 bouyer Exp $
|
||||
|
||||
/usr/lib/libdl* is not available on NetBSD
|
||||
|
||||
--- CMakeLists.txt.orig 2014-05-23 16:28:34.000000000 +0200
|
||||
+++ CMakeLists.txt 2014-05-23 16:28:41.000000000 +0200
|
||||
@@ -818,10 +818,6 @@
|
||||
--- CMakeLists.txt.orig 2014-05-26 21:26:36.000000000 +0200
|
||||
+++ CMakeLists.txt 2014-06-16 11:41:17.000000000 +0200
|
||||
@@ -1007,9 +1007,9 @@
|
||||
|
||||
# Certain older Cmake FindGTK2 modules ( e.g. cmake-2.8.0-2) do not yield all of the required link libraries
|
||||
# So, add them manually. These declarations may be redundant in some architectures, but do no harm.
|
||||
-IF(UNIX)
|
||||
-TARGET_LINK_LIBRARIES( ${PACKAGE_NAME} dl )
|
||||
+IF(CMAKE_SYSTEM_NAME MATCHES ".*Linux")
|
||||
TARGET_LINK_LIBRARIES( ${PACKAGE_NAME} dl )
|
||||
-ENDIF(UNIX)
|
||||
-
|
||||
+ENDIF(CMAKE_SYSTEM_NAME MATCHES ".*Linux")
|
||||
|
||||
IF(GTK2_FOUND)
|
||||
TARGET_LINK_LIBRARIES( ${PACKAGE_NAME} gobject-2.0 )
|
||||
ENDIF(GTK2_FOUND)
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: patch-FindPortaudio.cmake,v 1.1 2014/05/25 18:26:57 bouyer Exp $
|
||||
$NetBSD: patch-FindPortaudio.cmake,v 1.2 2015/01/22 12:34:15 bouyer Exp $
|
||||
|
||||
really find portaudio in portaudio2 subdir
|
||||
|
||||
--- FindPortaudio.cmake.orig 2013-05-08 17:41:43.000000000 +0200
|
||||
+++ FindPortaudio.cmake 2014-05-24 21:28:16.000000000 +0200
|
||||
--- FindPortaudio.cmake.orig 2014-05-26 21:26:36.000000000 +0200
|
||||
+++ FindPortaudio.cmake 2014-05-26 21:30:22.000000000 +0200
|
||||
@@ -45,24 +45,13 @@
|
||||
set(PORTAUDIO_FOUND TRUE)
|
||||
else (PORTAUDIO_LIBRARIES AND PORTAUDIO_INCLUDE_DIRS)
|
||||
|
|
|
@ -1,10 +1,11 @@
|
|||
$NetBSD: patch-src_chart1.cpp,v 1.1 2014/05/25 18:26:57 bouyer Exp $
|
||||
$NetBSD: patch-src_chart1.cpp,v 1.2 2015/01/22 12:34:15 bouyer Exp $
|
||||
|
||||
Adapt for tty devices on NetBSD
|
||||
Reported in FS#1403
|
||||
|
||||
--- src/chart1.cpp.orig 2014-05-23 15:58:32.000000000 +0200
|
||||
+++ src/chart1.cpp 2014-05-23 16:03:10.000000000 +0200
|
||||
@@ -7305,7 +7305,9 @@
|
||||
--- src/chart1.cpp.orig 2014-05-26 21:26:36.000000000 +0200
|
||||
+++ src/chart1.cpp 2014-05-26 21:30:22.000000000 +0200
|
||||
@@ -8032,7 +8032,9 @@
|
||||
|
||||
#include <termios.h>
|
||||
#include <sys/ioctl.h>
|
||||
|
@ -14,7 +15,7 @@ Adapt for tty devices on NetBSD
|
|||
|
||||
#endif
|
||||
|
||||
@@ -7371,6 +7373,15 @@
|
||||
@@ -8098,6 +8100,15 @@
|
||||
|
||||
int isTTYreal(const char *dev)
|
||||
{
|
||||
|
@ -30,7 +31,7 @@ Adapt for tty devices on NetBSD
|
|||
struct serial_struct serinfo;
|
||||
int ret = 0;
|
||||
|
||||
@@ -7387,6 +7398,7 @@
|
||||
@@ -8114,6 +8125,7 @@
|
||||
}
|
||||
|
||||
return ret;
|
||||
|
@ -38,7 +39,7 @@ Adapt for tty devices on NetBSD
|
|||
}
|
||||
|
||||
|
||||
@@ -7427,11 +7439,13 @@
|
||||
@@ -8154,11 +8166,13 @@
|
||||
|
||||
// We try to add a few more, arbitrarily, for those systems that have fixed, traditional COM ports
|
||||
|
||||
|
|
21
geography/opencpn/patches/patch-src_crashprint.cpp
Normal file
21
geography/opencpn/patches/patch-src_crashprint.cpp
Normal file
|
@ -0,0 +1,21 @@
|
|||
$NetBSD: patch-src_crashprint.cpp,v 1.1 2015/01/22 12:34:15 bouyer Exp $
|
||||
|
||||
backtrace support is linux-only for now
|
||||
|
||||
--- src/crashprint.cpp.orig 2015-01-20 16:46:17.000000000 +0000
|
||||
+++ src/crashprint.cpp 2015-01-20 16:46:24.000000000 +0000
|
||||
@@ -76,6 +76,7 @@
|
||||
// general functions
|
||||
|
||||
void wxCrashPrint::Report () {
|
||||
+#if defined(__linux__)
|
||||
wxString appname = wxTheApp->GetAppName();
|
||||
|
||||
// get the backtrace with symbols
|
||||
@@ -136,5 +137,5 @@
|
||||
wxPrintf (_T("%s\n"), lines[i].c_str());
|
||||
}
|
||||
}
|
||||
-
|
||||
+#endif
|
||||
}
|
|
@ -1,9 +1,11 @@
|
|||
$NetBSD: patch-src_tcmgr.cpp,v 1.1 2014/05/25 18:26:57 bouyer Exp $
|
||||
64bit time_t fix
|
||||
$NetBSD: patch-src_tcmgr.cpp,v 1.2 2015/01/22 12:34:15 bouyer Exp $
|
||||
|
||||
--- src/tcmgr.cpp.orig 2014-05-23 17:16:52.000000000 +0200
|
||||
+++ src/tcmgr.cpp 2014-05-23 17:18:08.000000000 +0200
|
||||
@@ -569,7 +569,7 @@
|
||||
64bit time_t fix
|
||||
Reported in FS#1403
|
||||
|
||||
--- src/tcmgr.cpp.orig 2014-05-26 21:26:36.000000000 +0200
|
||||
+++ src/tcmgr.cpp 2014-05-26 21:30:22.000000000 +0200
|
||||
@@ -518,7 +518,7 @@
|
||||
f += fact * w[n] * (fr[deriv-n] - fl[deriv-n]);
|
||||
fact *= (double)(deriv - n)/(n+1) * (1.0/TIDE_BLEND_TIME);
|
||||
}
|
||||
|
|
Loading…
Reference in a new issue