link -lrt on netbsd. needed by new binutils.

shm_open() is referenced in a direct part of the output, but only
visible via being needed via an indirect reference, and this seems
to no longer be allowed.
This commit is contained in:
mrg 2023-01-15 05:36:37 +00:00
parent 8ed3bdb2c3
commit 60cc949634
2 changed files with 19 additions and 14 deletions

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.12 2021/10/26 10:44:04 nia Exp $
$NetBSD: distinfo,v 1.13 2023/01/15 05:36:37 mrg Exp $
BLAKE2s (ioquake3-1.36.20200125-daae32ddfdab2172a628072ed3ff7dd1fc1563fe.tar.gz) = 73f65b336d36d24d523d96078b61f65c927d5a6e9636bee29413d0197e45472a
SHA512 (ioquake3-1.36.20200125-daae32ddfdab2172a628072ed3ff7dd1fc1563fe.tar.gz) = 689a0efa6eaf88fcf98616c100df625b77617c55e351455cc25727fea525748855c58e2288f04d86372d392a556f2ef4926e2c808f75e104ac328baa9458c4d1
Size (ioquake3-1.36.20200125-daae32ddfdab2172a628072ed3ff7dd1fc1563fe.tar.gz) = 7691640 bytes
SHA1 (patch-Makefile) = fd04edd2718644694945cae1623ae22035c27d13
SHA1 (patch-Makefile) = 7d11e12f312caa2517f768702fddc3ec15fa81f5
SHA1 (patch-code_qcommon_q__platform.h) = 7845c7ba9431c7a34c5fbfde702cc0b7e1dc66d5
SHA1 (patch-code_renderergl1_tr__init.c) = a9968c3035d6558ea65ec1bd00afd628a01eab49
SHA1 (patch-code_renderergl2_tr__init.c) = c38bb445cbb70f35cac4114b46c7172cacc7d44f

View file

@ -1,4 +1,4 @@
$NetBSD: patch-Makefile,v 1.1 2021/05/21 15:01:52 nia Exp $
$NetBSD: patch-Makefile,v 1.2 2023/01/15 05:36:38 mrg Exp $
- Add support for NetBSD-style uname.
- Build client on NetBSD.
@ -6,8 +6,10 @@ $NetBSD: patch-Makefile,v 1.1 2021/05/21 15:01:52 nia Exp $
https://github.com/ioquake/ioq3/pull/466
--- Makefile.orig 2019-12-07 13:16:15.000000000 +0000
+++ Makefile
- Add -lrt on NetBSD that binutils 2.39 wants.
--- Makefile.orig 2019-12-07 05:16:15.000000000 -0800
+++ Makefile 2023-01-14 18:34:38.285233929 -0800
@@ -6,8 +6,8 @@
COMPILE_PLATFORM=$(shell uname | sed -e 's/_.*//' | tr '[:upper:]' '[:lower:]' | sed -e 's/\//_/g')
COMPILE_ARCH=$(shell uname -m | sed -e 's/i.86/x86/' | sed -e 's/^arm.*/arm/')
@ -19,7 +21,7 @@ https://github.com/ioquake/ioq3/pull/466
COMPILE_ARCH=$(shell uname -p | sed -e 's/i.86/x86/')
endif
@@ -65,6 +65,10 @@ ifeq ($(PLATFORM),mingw64)
@@ -65,6 +65,10 @@
MINGW=1
endif
@ -30,7 +32,7 @@ https://github.com/ioquake/ioq3/pull/466
ifeq ($(COMPILE_ARCH),i86pc)
COMPILE_ARCH=x86
endif
@@ -338,7 +342,7 @@ MKDIR=mkdir -p
@@ -338,7 +342,7 @@
EXTRA_FILES=
CLIENT_EXTRA_FILES=
@ -39,7 +41,7 @@ https://github.com/ioquake/ioq3/pull/466
TOOLS_CFLAGS += -DARCH_STRING=\"$(COMPILE_ARCH)\"
endif
@@ -712,7 +716,7 @@ ifeq ($(PLATFORM),freebsd)
@@ -712,7 +716,7 @@
# flags
BASE_CFLAGS = \
-Wall -fno-strict-aliasing -Wimplicit -Wstrict-prototypes \
@ -48,7 +50,7 @@ https://github.com/ioquake/ioq3/pull/466
CLIENT_CFLAGS += $(SDL_CFLAGS)
HAVE_VM_COMPILED = true
@@ -766,7 +770,7 @@ else # ifeq freebsd
@@ -766,7 +770,7 @@
ifeq ($(PLATFORM),openbsd)
BASE_CFLAGS = -Wall -fno-strict-aliasing -Wimplicit -Wstrict-prototypes \
@ -57,14 +59,17 @@ https://github.com/ioquake/ioq3/pull/466
CLIENT_CFLAGS += $(SDL_CFLAGS)
OPTIMIZEVM = -O3
@@ -848,13 +852,32 @@ ifeq ($(PLATFORM),netbsd)
@@ -846,15 +850,34 @@
SHLIBEXT=so
SHLIBCFLAGS=-fPIC
SHLIBLDFLAGS=-shared $(LDFLAGS)
THREAD_LIBS=-lpthread
- BASE_CFLAGS = -Wall -fno-strict-aliasing -Wimplicit -Wstrict-prototypes
- THREAD_LIBS=-lpthread
+ THREAD_LIBS=-lpthread -lrt
+
+ BASE_CFLAGS = -Wall -fno-strict-aliasing -Wimplicit -Wstrict-prototypes \
+ -pipe -DUSE_ICON -DARCH_STRING=\\\"$(ARCH)\\\"
+
- BASE_CFLAGS = -Wall -fno-strict-aliasing -Wimplicit -Wstrict-prototypes
+ CLIENT_LIBS += $(SDL_LIBS)
+ RENDERER_LIBS = $(SDL_LIBS)
+