Update php71 to
16 Feb 2017, PHP 7.1.2 - Core: . Improved GENERATOR_CREATE opcode handler. (Bob, Dmitry) . Fixed bug #73877 (readlink() returns garbage for UTF-8 paths). (Anatol) . Fixed bug #73876 (Crash when exporting **= in expansion of assign op). (Sara) . Fixed bug #73962 (bug with symlink related to cyrillic directory). (Anatol) . Fixed bug #73969 (segfault in debug_print_backtrace). (andrewnester) . Fixed bug #73994 (arginfo incorrect for unpack). (krakjoe) . Fixed bug #73973 (assertion error in debug_zval_dump). (andrewnester) - DOM: . Fixed bug #54382 (getAttributeNodeNS doesn't get xmlns* attributes). (aboks) - DTrace: . Fixed bug #73965 (DTrace reported as enabled when disabled). (Remi) - FCGI: . Fixed bug #73904 (php-cgi fails to load -c specified php.ini file). (Anatol) . Fixed bug #72898 (PHP_FCGI_CHILDREN is not included in phpinfo()). (Anatol) - FPM: . Fixed bug #69865 (php-fpm does not close stderr when using syslog). (m6w6) - GD: . Fixed bug #73968 (Premature failing of XBM reading). (cmb) - GMP: . Fixed bug #69993 (test for gmp.h needs to test machine includes). (Jordan Gigov) - Hash: . Added hash_hkdf() function. (Andrey Andreev) . Fixed bug #73961 (environmental build dependency in hash sha3 source). (krakjoe) - Intl: . Fix bug #73956 (Link use CC instead of CXX). (Remi) - LDAP: . Fixed bug #73933 (error/segfault with ldap_mod_replace and opcache). (Laruence) - MySQLi: . Fixed bug #73949 (leak in mysqli_fetch_object). (krakjoe) - Mysqlnd: . Fixed bug #69899 (segfault on close() after free_result() with mysqlnd). (Richard Fussenegger) - Opcache: . Fixed bug #73983 (crash on finish work with phar in cli + opcache). (Anatol) - OpenSSL: . Fixed bug #71519 (add serial hex to return value array). (xrobau) . Fixed bug #73692 (Compile ext/openssl with openssl 1.1.0 on Win). (Anatol) . Fixed bug #73978 (openssl_decrypt triggers bug in PDO). (Jakub Zelenka) - PDO_Firebird: . Implemented FR #72583 (All data are fetched as strings). (Dorin Marcoci) - PDO_PgSQL: . Fixed bug #73959 (lastInsertId fails to throw an exception for wrong sequence name). (andrewnester) - Phar: . Fixed bug #70417 (PharData::compress() doesn't close temp file). (cmb) - posix: . Fixed bug #71219 (configure script incorrectly checks for ttyname_r). (atoh) - Session: . Fixed bug #69582 (session not readable by root in CLI). (EvgeniySpinov) - SPL: . Fixed bug #73896 (spl_autoload() crashes when calls magic _call()). (Dmitry) - Standard: . Fixed bug #69442 (closing of fd incorrect when PTS enabled). (jaytaph) . Fixed bug #47021 (SoapClient stumbles over WSDL delivered with "Transfer-Encoding: chunked"). (Rowan Collins) . Fixed bug #72974 (imap is undefined service on AIX). (matthieu.sarter) . Fixed bug #72979 (money_format stores wrong length AIX). (matthieu.sarter) . Fixed bug #73374 (intval() with base 0 should detect binary). (Leigh) . Fixed bug #69061 (mail.log = syslog contains double information). (Tom Sommer) - ZIP: . Fixed bug #70103 (ZipArchive::addGlob ignores remove_all_path option). (cmb, Mitch Hagstrand)
This commit is contained in:
parent
102389db83
commit
60dd9aa21c
5 changed files with 10 additions and 34 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: phpversion.mk,v 1.172 2017/02/18 13:09:19 taca Exp $
|
||||
# $NetBSD: phpversion.mk,v 1.173 2017/02/18 13:13:07 taca Exp $
|
||||
#
|
||||
# This file selects a PHP version, based on the user's preferences and
|
||||
# the installed packages. It does not add a dependency on the PHP
|
||||
|
@ -89,7 +89,7 @@ PHPVERSION_MK= defined
|
|||
# Define each PHP's version.
|
||||
PHP56_VERSION= 5.6.30
|
||||
PHP70_VERSION= 7.0.16
|
||||
PHP71_VERSION= 7.1.1
|
||||
PHP71_VERSION= 7.1.2
|
||||
|
||||
# Define initial release of major version.
|
||||
PHP56_RELDATE= 20140828
|
||||
|
|
|
@ -1,11 +1,10 @@
|
|||
# $NetBSD: Makefile,v 1.7 2017/01/26 00:40:47 maya Exp $
|
||||
# $NetBSD: Makefile,v 1.8 2017/02/18 13:13:07 taca Exp $
|
||||
|
||||
#
|
||||
# We can't omit PKGNAME here to handle PKG_OPTIONS.
|
||||
#
|
||||
PKGNAME= php-${PHP_VERSION:S/RC/rc/}
|
||||
CATEGORIES= lang
|
||||
PKGREVISION= 1
|
||||
|
||||
HOMEPAGE= http://www.php.net/
|
||||
COMMENT= PHP Hypertext Preprocessor version 7.1
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2016/08/04 14:09:03 jdolecek Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 2017/02/18 13:13:07 taca Exp $
|
||||
bin/phar
|
||||
bin/phar.phar
|
||||
bin/php
|
||||
|
@ -260,6 +260,7 @@ include/php/main/win95nt.h
|
|||
include/php/sapi/cli/cli.h
|
||||
lib/php/build/Makefile.global
|
||||
lib/php/build/acinclude.m4
|
||||
lib/php/build/ax_check_compile_flag.m4
|
||||
lib/php/build/config.guess
|
||||
lib/php/build/config.sub
|
||||
lib/php/build/libtool.m4
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.12 2017/01/19 14:43:25 taca Exp $
|
||||
$NetBSD: distinfo,v 1.13 2017/02/18 13:13:07 taca Exp $
|
||||
|
||||
SHA1 (php-7.1.1.tar.bz2) = 40c4ff13013de1fc896ab1aaada6d9f63529a658
|
||||
RMD160 (php-7.1.1.tar.bz2) = 4236dacc38aa9c576387b40b1a53e1967f68807f
|
||||
SHA512 (php-7.1.1.tar.bz2) = 005471c0233e04fd95e159f8106ecfb059500076482cd49b26d2597ac390f4fa09ec14146058cdcd38e7d27665ac1d2afdc758f41b86e7fb88c8ba405b6e6415
|
||||
Size (php-7.1.1.tar.bz2) = 15774720 bytes
|
||||
SHA1 (php-7.1.2.tar.bz2) = 1f9b81136dd4bd4cca5092f87cac3b5c23708d36
|
||||
RMD160 (php-7.1.2.tar.bz2) = 508fb098c9ff9434345b8f33dd9ff4b11c0fcd6b
|
||||
SHA512 (php-7.1.2.tar.bz2) = b4a3492f4af92facd16e7dfb47ec16b43e4c5b25be193ff6e36418173893edb75ca4ca94767b643a6971d60578727fa1f67f20cc84b9a140cb1b9a367ec34a6f
|
||||
Size (php-7.1.2.tar.bz2) = 15740771 bytes
|
||||
SHA1 (patch-acinclude.m4) = b682280fd89950c082c2226bdb7364b0dc475bad
|
||||
SHA1 (patch-configure) = a129e19ef87338f6e53ccc967c40ddcde7c7357c
|
||||
SHA1 (patch-ext_gd_config.m4) = 93b62daad93b9ee6dc28e06016f739bc26b0dc9f
|
||||
|
@ -16,7 +16,6 @@ SHA1 (patch-ext_phar_phar_phar.php) = f630e3946b21b76d4fe857a43e00e25c9445f2c8
|
|||
SHA1 (patch-ext_recode_recode.c) = a97a1815d6a41410f68c289debbb9396128a2159
|
||||
SHA1 (patch-ext_sqlite3_libsqlite_sqlite3.c) = 8a529a1b3f7c97731f2e719d006f67c3a7259bb5
|
||||
SHA1 (patch-ext_standard_basic__functions.c) = f97a2748c7b15fbd9a2d3c21e56079088cc05d56
|
||||
SHA1 (patch-ext_standard_php__dns.h) = 8f89b4bb3553d922b1395c1c66bf5feccf0c4000
|
||||
SHA1 (patch-makedist) = 2ac0e0391c031c4fcf4993e2269cde4c6bfddfd5
|
||||
SHA1 (patch-php.ini-development) = dd65962000ec06439fae3c9bf252fa46be4e33fd
|
||||
SHA1 (patch-php.ini-production) = ae61dffedf574b688fe576b0b2af748b7a28cd89
|
||||
|
|
|
@ -1,23 +0,0 @@
|
|||
$NetBSD: patch-ext_standard_php__dns.h,v 1.2 2016/12/20 07:24:04 maya Exp $
|
||||
|
||||
Fix memory leak.
|
||||
|
||||
--- ext/standard/php_dns.h.orig 2016-04-28 18:13:00.000000000 +0000
|
||||
+++ ext/standard/php_dns.h
|
||||
@@ -32,9 +32,15 @@
|
||||
#elif defined(HAVE_RES_NSEARCH)
|
||||
#define php_dns_search(res, dname, class, type, answer, anslen) \
|
||||
res_nsearch(res, dname, class, type, answer, anslen);
|
||||
+#ifdef __GLIBC__
|
||||
#define php_dns_free_handle(res) \
|
||||
- res_nclose(res); \
|
||||
+ res_nclose(res); \
|
||||
+ php_dns_free_res(res)
|
||||
+#else
|
||||
+#define php_dns_free_handle(res) \
|
||||
+ res_ndestroy(res); \
|
||||
php_dns_free_res(res)
|
||||
+#endif
|
||||
|
||||
#elif defined(HAVE_RES_SEARCH)
|
||||
#define php_dns_search(res, dname, class, type, answer, anslen) \
|
Loading…
Reference in a new issue