devel/py-jaraco.path: import py-jaraco.path-3.3.1

Python module with miscellaneous path functions.
This commit is contained in:
wiz 2021-11-21 10:37:02 +00:00
parent 4c9da0ebf0
commit 60e47aa91c
6 changed files with 71 additions and 0 deletions

View file

@ -0,0 +1 @@
Python module with miscellaneous path functions.

View file

@ -0,0 +1,25 @@
# $NetBSD: Makefile,v 1.1 2021/11/21 10:37:02 wiz Exp $
DISTNAME= jaraco.path-3.3.1
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= devel python
MASTER_SITES= ${MASTER_SITE_PYPI:=j/jaraco.path/}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://github.com/jaraco/jaraco.path
COMMENT= Miscellaneous path functions
LICENSE= mit
BUILD_DEPENDS+= ${PYPKGPREFIX}-setuptools_scm>=3.4.1:../../devel/py-setuptools_scm
USE_LANGUAGES= # none
PYTHON_VERSIONS_INCOMPATIBLE= 27
TEST_ENV+= PYTHONPATH=${WRKSRC}/build/lib
do-test:
cd ${WRKSRC} && ${SETENV} ${TEST_ENV} py.test-${PYVERSSUFFIX}
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -0,0 +1,9 @@
@comment $NetBSD: PLIST,v 1.1 2021/11/21 10:37:02 wiz Exp $
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/requires.txt
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
${PYSITELIB}/jaraco/path.py
${PYSITELIB}/jaraco/path.pyc
${PYSITELIB}/jaraco/path.pyo

View file

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.1 2021/11/21 10:37:02 wiz Exp $
BLAKE2s (jaraco.path-3.3.1.tar.gz) = 168b646de8069942f2b9bd5ba2968a6b8b7240f4d23de326b47e319def213228
SHA512 (jaraco.path-3.3.1.tar.gz) = 00dac02fdc6df469f8661d552b16a8ee6150d86a7df9459264377a03e96fd94608f9782ad4cc2b2df67c64a10f8af26ed650b0bac0b1e59607d429abdbe64309
Size (jaraco.path-3.3.1.tar.gz) = 13287 bytes
SHA1 (patch-jaraco_path.py) = 66902a42b2055d628f9a02ba2154abf12db1a28d
SHA1 (patch-setup.cfg) = 5313ea9fa85ce2f046e537fbe18ca82a29a30b8d

View file

@ -0,0 +1,15 @@
$NetBSD: patch-jaraco_path.py,v 1.1 2021/11/21 10:37:02 wiz Exp $
On python>=3.4, this is in functools.
--- jaraco/path.py.orig 2021-02-25 22:38:22.000000000 +0000
+++ jaraco/path.py
@@ -18,7 +18,7 @@ import importlib
import pathlib
from typing import Dict, Union
-from singledispatch import singledispatch
+from functools import singledispatch
log = logging.getLogger(__name__)

View file

@ -0,0 +1,14 @@
$NetBSD: patch-setup.cfg,v 1.1 2021/11/21 10:37:02 wiz Exp $
singledispatch is part of python>=3.4
--- setup.cfg.orig 2021-02-25 22:38:43.851145000 +0000
+++ setup.cfg
@@ -20,7 +20,6 @@ include_package_data = true
python_requires = >=3.6
install_requires =
pyobjc; platform_system == "Darwin" and platform_python_implementation != "PyPy"
- singledispatch >= 3.6
setup_requires = setuptools_scm[toml] >= 3.4.1
[options.packages.find]