nagios-plugin-mqueue: Avoid use of strict C89 mode when C99 functions

are in use. Honour CFLAGS.

Should help the build on some platforms.
This commit is contained in:
nia 2023-07-12 20:14:48 +00:00
parent a341d10550
commit 61716cc396
3 changed files with 17 additions and 2 deletions

View File

@ -1,8 +1,9 @@
# $NetBSD: Makefile,v 1.1 2023/04/21 00:59:41 manu Exp $
# $NetBSD: Makefile,v 1.2 2023/07/12 20:14:48 nia Exp $
#
DISTNAME= check_mqueue-0.1
PKGNAME= nagios-plugin-mqueue-${DISTNAME:C/.*-//}
PKGREVISION= 1
CATEGORIES= net
MASTER_SITES= http://ftp.espci.fr/pub/nagios-local/
EXTRACT_SUFX= .tgz

View File

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.1 2023/04/21 00:59:41 manu Exp $
$NetBSD: distinfo,v 1.2 2023/07/12 20:14:48 nia Exp $
BLAKE2s (check_mqueue-0.1.tgz) = 6c87c6b19e1fa9c6ab49b81ded3ad3607b1bb2eaec8432c6c23c49a78b675282
SHA512 (check_mqueue-0.1.tgz) = 984a0a7c10510ac2e70e5873b081317eb57e01254624042089a2347033bdeb3513ba13850456ecc7dc9d24b5b56c9fae386563062d142b88648b93525f491065
Size (check_mqueue-0.1.tgz) = 1889 bytes
SHA1 (patch-Makefile) = d2d632b3f2e72c476700e72427586dd996781213

View File

@ -0,0 +1,13 @@
$NetBSD: patch-Makefile,v 1.1 2023/07/12 20:14:48 nia Exp $
Don't override CFLAGS or compile in strict ANSI mode (the code uses some
C99 functions).
--- Makefile.orig 2023-04-05 14:17:28.000000000 +0000
+++ Makefile
@@ -1,4 +1,4 @@
-CFLAGS= -Wall -Werror -ansi
+CFLAGS+= -std=c99
all: check_mqueue