py-weasyprint0: exclude pytest-flake8 and pytest-isort from testing
This commit is contained in:
parent
ec450e3fca
commit
617705e7a2
4 changed files with 35 additions and 8 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.11 2022/08/24 08:41:08 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.12 2022/11/30 09:24:13 adam Exp $
|
||||
|
||||
DISTNAME= WeasyPrint-0.42.3
|
||||
PKGNAME= ${PYPKGPREFIX}-${DISTNAME:tl}
|
||||
|
@ -21,8 +21,6 @@ DEPENDS+= ${PYPKGPREFIX}-pdfrw>=0.4:../../textproc/py-pdfrw
|
|||
DEPENDS+= ${PYPKGPREFIX}-pyphen>=0.8:../../textproc/py27-pyphen
|
||||
DEPENDS+= ${PYPKGPREFIX}-tinycss2>=0.5:../../textproc/py27-tinycss2
|
||||
TEST_DEPENDS+= ${PYPKGPREFIX}-test-cov-[0-9]*:../../devel/py27-test-cov
|
||||
TEST_DEPENDS+= ${PYPKGPREFIX}-test-flake8-[0-9]*:../../devel/py-test-flake8
|
||||
TEST_DEPENDS+= ${PYPKGPREFIX}-test-isort-[0-9]*:../../devel/py-test-isort
|
||||
TEST_DEPENDS+= ${PYPKGPREFIX}-test-runner-[0-9]*:../../devel/py-test-runner
|
||||
|
||||
PYTHON_VERSIONS_ACCEPTED= 27
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.5 2021/10/26 11:12:16 nia Exp $
|
||||
$NetBSD: distinfo,v 1.6 2022/11/30 09:24:13 adam Exp $
|
||||
|
||||
BLAKE2s (WeasyPrint-0.42.3.tar.gz) = 2cc65ae04d91c2ca8b90ee54a43750c7de1cad7d986401cd7f77efdc4d0d8554
|
||||
SHA512 (WeasyPrint-0.42.3.tar.gz) = d6007934c301904308bd4821626d6a7bb504268c5c71a31f7486faebb3dd649fad18774737cab39eb13a0916635bb58eba2c8432c72cc5a461cea2a5d874b1ee
|
||||
Size (WeasyPrint-0.42.3.tar.gz) = 399972 bytes
|
||||
SHA1 (patch-setup.py) = a7657e79ac611f3122a81d7f2c6c195e52ba9399
|
||||
SHA1 (patch-setup.cfg) = b5aa0edebaefc2ae2c9c7748ffadb89c4e5d1828
|
||||
SHA1 (patch-setup.py) = 4bfa57670448b87b7713dd05a2651729b0935ac2
|
||||
|
|
15
print/py-weasyprint0/patches/patch-setup.cfg
Normal file
15
print/py-weasyprint0/patches/patch-setup.cfg
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-setup.cfg,v 1.1 2022/11/30 09:24:13 adam Exp $
|
||||
|
||||
Do not use flake8 and isort for tests.
|
||||
|
||||
--- setup.cfg.orig 2022-11-30 08:28:48.000000000 +0000
|
||||
+++ setup.cfg
|
||||
@@ -6,7 +6,7 @@ build-dir = docs/_build
|
||||
test = pytest
|
||||
|
||||
[tool:pytest]
|
||||
-addopts = --cov=weasyprint --flake8 --isort
|
||||
+addopts = --cov=weasyprint
|
||||
norecursedirs = dist .cache .git build *.egg-info .eggs venv
|
||||
|
||||
[egg_info]
|
|
@ -1,10 +1,23 @@
|
|||
$NetBSD: patch-setup.py,v 1.3 2021/04/29 13:15:32 joerg Exp $
|
||||
$NetBSD: patch-setup.py,v 1.4 2022/11/30 09:24:13 adam Exp $
|
||||
|
||||
Adjust script path to allow multiple Python version installs.
|
||||
|
||||
--- setup.py.orig 2017-12-22 23:26:45.000000000 +0000
|
||||
Do not require pytest-flake8 and pytest-isort as PkgSrc does have Python 2.7
|
||||
versions anymore.
|
||||
|
||||
--- setup.py.orig 2018-03-27 20:48:21.000000000 +0000
|
||||
+++ setup.py
|
||||
@@ -83,7 +83,7 @@ setup(
|
||||
@@ -75,15 +75,15 @@ setup(
|
||||
setup_requires=pytest_runner,
|
||||
test_suite='weasyprint.tests',
|
||||
tests_require=[
|
||||
- 'pytest-runner', 'pytest-cov', 'pytest-flake8', 'pytest-isort'],
|
||||
+ 'pytest-runner', 'pytest-cov'],
|
||||
extras_require={
|
||||
'test': [
|
||||
- 'pytest-runner', 'pytest-cov', 'pytest-flake8', 'pytest-isort'],
|
||||
+ 'pytest-runner', 'pytest-cov'],
|
||||
':python_version < "3.0"': ['CairoSVG >= 1.0.20, < 2.0.0'],
|
||||
':python_version >= "3.0"': ['CairoSVG >= 1.0.20']},
|
||||
entry_points={
|
||||
'console_scripts': [
|
||||
|
|
Loading…
Reference in a new issue