Update p5-IO-Tty to 1.00. Major changes from version 0.04 include
additions to the API and a complete rewrite of the way a pty is allocated, and the use of openpty() in *BSD to open the allocated pty, and other bug fixes. We had to fix Makefile.PL to correctly invoke the preprocessor. The changes have been forwarded to the author. This closes pkg/15896 by Shell Hung <shell@shellhung.org>.
This commit is contained in:
parent
c57452c60e
commit
61900df227
4 changed files with 35 additions and 36 deletions
|
@ -1,31 +1 @@
|
|||
IO::Tty and IO::Pty provide an interface to pseudo tty's
|
||||
|
||||
To build this distribution run
|
||||
|
||||
perl Makefile.PL
|
||||
make
|
||||
make install
|
||||
|
||||
There is no make test for this distribution as it is hard to automate.
|
||||
But they is a script included calle try.
|
||||
|
||||
If try is run with arguments it will run then as a command with the
|
||||
output connected via a pseudo tty, eg
|
||||
|
||||
perl -Mblib try ls
|
||||
|
||||
If run without arguments it should output something like
|
||||
|
||||
io_pty_ttyname/dev/ttya0
|
||||
master IO::Pty=GLOB(0x81a8d40) *Symbol::GEN0 /dev/ttya0
|
||||
slave IO::Tty=GLOB(0x81a4d34) *Symbol::GEN1 /dev/ttya0
|
||||
1
|
||||
2
|
||||
3
|
||||
4
|
||||
5
|
||||
6
|
||||
7
|
||||
8
|
||||
9
|
||||
10
|
||||
IO::Tty and IO::Pty provide an interface to pseudo-ttys.
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.7 2001/11/26 06:49:51 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.8 2002/03/22 06:57:34 jlam Exp $
|
||||
#
|
||||
|
||||
DISTNAME= IO-Tty-0.04
|
||||
DISTNAME= IO-Tty-1.00
|
||||
PKGNAME= p5-${DISTNAME:C/T/t/}
|
||||
SVR4_PKGNAME= p5itt
|
||||
CATEGORIES= devel perl5
|
||||
|
|
|
@ -1,4 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.2 2001/04/21 00:44:38 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.3 2002/03/22 06:57:34 jlam Exp $
|
||||
|
||||
SHA1 (IO-Tty-0.04.tar.gz) = 97a1e35ff6f3baadc76635efabbabb97e0646a58
|
||||
Size (IO-Tty-0.04.tar.gz) = 17443 bytes
|
||||
SHA1 (IO-Tty-1.00.tar.gz) = fdc04a6cb230a71951fb922303b3e83c54486e4c
|
||||
Size (IO-Tty-1.00.tar.gz) = 23077 bytes
|
||||
SHA1 (patch-aa) = eff79e37c1c00331873eed38f66717f788fbe64a
|
||||
|
|
28
devel/p5-IO-Tty/patches/patch-aa
Normal file
28
devel/p5-IO-Tty/patches/patch-aa
Normal file
|
@ -0,0 +1,28 @@
|
|||
$NetBSD: patch-aa,v 1.1 2002/03/22 06:57:35 jlam Exp $
|
||||
|
||||
--- Makefile.PL.orig Wed Mar 13 07:40:44 2002
|
||||
+++ Makefile.PL Fri Mar 22 01:40:50 2002
|
||||
@@ -64,10 +64,10 @@
|
||||
ESQ
|
||||
close(TST);
|
||||
|
||||
-if (system("$Config{'cpp'} $Config{'cppflags'} compilerok.c > preprocessorok.log 2>&1")) {
|
||||
+if (system("$Config{'cppstdin'} $Config{'cppflags'} $Config{'cppminus'} < compilerok.c > preprocessorok.log 2>&1")) {
|
||||
die <<"__EOT__";
|
||||
|
||||
-ERROR: cannot run the configured preprocessor '$Config{'cpp'}'
|
||||
+ERROR: cannot run the configured preprocessor '$Config{'cppstdin'}'
|
||||
(see conf/preprocessor.log). Please fix this by adjusting
|
||||
perls Config.pm, creating a symlink to the right location
|
||||
or maybe by just adding it to your PATH. You could also build
|
||||
@@ -246,8 +246,8 @@
|
||||
}
|
||||
close CPPIN;
|
||||
|
||||
-if(system("$Config{'cpp'} $Config{'cppflags'} @{[keys %define]} ttsymsdefined.in > ttsymsdefined.out")) {
|
||||
- die "ERROR: cannot run cpp";
|
||||
+if(system("$Config{'cppstdin'} $Config{'cppflags'} @{[keys %define]} $Config{'cppminus'} < ttsymsdefined.in > ttsymsdefined.out")) {
|
||||
+ die "ERROR: cannot run preprocessor";
|
||||
}
|
||||
|
||||
open (CPPOUT, "ttsymsdefined.out") or die "open: $!";
|
Loading…
Reference in a new issue