Import qpdf-4.0.1 as print/qpdf, packaged by dillo@.

QPDF is a command-line program that does structural, content-preserving
transformations on PDF files.  It could have been called something
like pdf-to-pdf. It also provides many useful capabilities to
developers of PDF-producing software or for people who just want
to look at the innards of a PDF file to learn more about how they
work.

QPDF is capable of creating linearized (also known as web-optimized)
files and encrypted files. It is also capable of converting PDF
files with object streams (also known as compressed objects) to
files with no compressed objects or to generate object streams from
files that don't have them (or even those that already do). QPDF
also supports a special mode designed to allow you to edit the
content of PDF files in a text editor. For more details, please
see the documentation links below.

QPDF includes support for merging and splitting PDFs through the
ability to copy objects from one PDF file into another and to
manipulate the list of pages in a PDF file. The QPDF library also
makes it possible for you to create PDF files from scratch. In this
mode, you are responsible for supplying all the contents of the
file, while the QPDF library takes care off all the syntactical
representation of the objects, creation of cross references tables
and, if you use them, object streams, encryption, linearization,
and other syntactic details.

QPDF is not a PDF content creation library, a PDF viewer, or a
program capable of converting PDF into other formats. In particular,
QPDF knows nothing about the semantics of PDF content streams. If
you are looking for something that can do that, you should look
elsewhere. However, once you have a valid PDF file, QPDF can be
used to transform that file in ways perhaps your original PDF
creation can't handle. For example, programs generate simple PDF
files but can't password-protect them, web-optimize them, or perform
other transformations of that type.
This commit is contained in:
wiz 2013-01-31 21:45:23 +00:00
parent fa99a4de6b
commit 61a24c2f1b
5 changed files with 115 additions and 0 deletions

35
print/qpdf/DESCR Normal file
View file

@ -0,0 +1,35 @@
QPDF is a command-line program that does structural, content-preserving
transformations on PDF files. It could have been called something
like pdf-to-pdf. It also provides many useful capabilities to
developers of PDF-producing software or for people who just want
to look at the innards of a PDF file to learn more about how they
work.
QPDF is capable of creating linearized (also known as web-optimized)
files and encrypted files. It is also capable of converting PDF
files with object streams (also known as compressed objects) to
files with no compressed objects or to generate object streams from
files that don't have them (or even those that already do). QPDF
also supports a special mode designed to allow you to edit the
content of PDF files in a text editor. For more details, please
see the documentation links below.
QPDF includes support for merging and splitting PDFs through the
ability to copy objects from one PDF file into another and to
manipulate the list of pages in a PDF file. The QPDF library also
makes it possible for you to create PDF files from scratch. In this
mode, you are responsible for supplying all the contents of the
file, while the QPDF library takes care off all the syntactical
representation of the objects, creation of cross references tables
and, if you use them, object streams, encryption, linearization,
and other syntactic details.
QPDF is not a PDF content creation library, a PDF viewer, or a
program capable of converting PDF into other formats. In particular,
QPDF knows nothing about the semantics of PDF content streams. If
you are looking for something that can do that, you should look
elsewhere. However, once you have a valid PDF file, QPDF can be
used to transform that file in ways perhaps your original PDF
creation can't handle. For example, programs generate simple PDF
files but can't password-protect them, web-optimize them, or perform
other transformations of that type.

23
print/qpdf/Makefile Normal file
View file

@ -0,0 +1,23 @@
# $NetBSD: Makefile,v 1.1 2013/01/31 21:45:23 wiz Exp $
#
DISTNAME= qpdf-4.0.1
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=qpdf/}
MAINTAINER= dillo@NetBSD.org
HOMEPAGE= http://qpdf.sourceforge.net/
COMMENT= Structural, content-preserving transformations on PDF files
LICENSE= artistic-2.0
GNU_CONFIGURE= yes
USE_LIBTOOL= yes
USE_TOOLS+= gmake perl:run pkg-config
USE_LANGUAGES= c c++
PKGCONFIG_OVERRIDE+= libqpdf.pc.in
REPLACE_PERL= qpdf/fix-qdf
.include "../../devel/pcre/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

37
print/qpdf/PLIST Normal file
View file

@ -0,0 +1,37 @@
@comment $NetBSD: PLIST,v 1.1 2013/01/31 21:45:23 wiz Exp $
bin/fix-qdf
bin/qpdf
bin/zlib-flate
include/qpdf/Buffer.hh
include/qpdf/BufferInputSource.hh
include/qpdf/Constants.h
include/qpdf/DLL.h
include/qpdf/FileInputSource.hh
include/qpdf/InputSource.hh
include/qpdf/Pipeline.hh
include/qpdf/Pl_Buffer.hh
include/qpdf/Pl_Concatenate.hh
include/qpdf/Pl_Count.hh
include/qpdf/Pl_Discard.hh
include/qpdf/Pl_Flate.hh
include/qpdf/Pl_StdioFile.hh
include/qpdf/PointerHolder.hh
include/qpdf/QPDF.hh
include/qpdf/QPDFExc.hh
include/qpdf/QPDFObject.hh
include/qpdf/QPDFObjectHandle.hh
include/qpdf/QPDFTokenizer.hh
include/qpdf/QPDFWriter.hh
include/qpdf/QPDFXRefEntry.hh
include/qpdf/QTC.hh
include/qpdf/QUtil.hh
include/qpdf/Types.h
include/qpdf/qpdf-c.h
lib/libqpdf.la
lib/pkgconfig/libqpdf.pc
man/man1/fix-qdf.1
man/man1/qpdf.1
man/man1/zlib-flate.1
share/doc/qpdf/qpdf-manual.html
share/doc/qpdf/qpdf-manual.pdf
share/doc/qpdf/stylesheet.css

6
print/qpdf/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1 2013/01/31 21:45:23 wiz Exp $
SHA1 (qpdf-4.0.1.tar.gz) = 029ad13e1089396df34aeee3c5e386789715112a
RMD160 (qpdf-4.0.1.tar.gz) = e687b293ef45ee3e60600c2ae8c660f013a10c91
Size (qpdf-4.0.1.tar.gz) = 5031080 bytes
SHA1 (patch-make_libtool.mk) = ea3eea0c454f61f002bc7d55681fc99ea1c4c7d3

View file

@ -0,0 +1,14 @@
$NetBSD: patch-make_libtool.mk,v 1.1 2013/01/31 21:45:24 wiz Exp $
Sent upstream, will be fixed in 4.1.0.
--- make/libtool.mk.orig 2013-01-17 14:51:04.000000000 +0000
+++ make/libtool.mk
@@ -116,7 +116,6 @@ install: all
libqpdf/$(OUTPUT_DIR)/libqpdf.la \
$(DESTDIR)$(libdir)/libqpdf.la
$(LIBTOOL) --finish $(DESTDIR)$(libdir)
- $(RM) $(DESTDIR)$(libdir)/libqpdf.la
$(LIBTOOL) --mode=install install -c \
qpdf/$(OUTPUT_DIR)/qpdf \
$(DESTDIR)$(bindir)/qpdf