Refer to IPL_NAME if IPL_NAT is not defined. This hopefully fixes
a build failure reported by build builds. And while here, suppress GCC3 warnings by doing s/log()/xlog()/.
This commit is contained in:
parent
c0b38da808
commit
61ce658fb3
3 changed files with 29 additions and 2 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.2 2004/02/24 01:10:31 xtraeme Exp $
|
||||
# $NetBSD: Makefile,v 1.3 2004/09/18 12:47:33 uebayasi Exp $
|
||||
|
||||
DISTNAME= jftpgw-0.13.4
|
||||
CATEGORIES= net
|
||||
|
@ -20,6 +20,14 @@ RCD_SCRIPTS= jftpgw
|
|||
EGDIR= ${PREFIX}/share/examples/jftpgw
|
||||
CONF_FILES= ${EGDIR}/jftpgw.conf ${PKG_SYSCONFDIR}/jftpgw.conf
|
||||
|
||||
SUBST_CLASSES+= log
|
||||
SUBST_STAGE.log= post-patch
|
||||
SUBST_FILES.log= active.c bindport.c cache.c cmds.c config.c \
|
||||
ftpread.c fw_auth_cmds.c jftpgw.c log.c log.h \
|
||||
login.c openport.c passive.c states.c std_cmds.c \
|
||||
util.c
|
||||
SUBST_SED.log= -e "s,\([[:space:]]\)\(log(\),\1x\2,"
|
||||
|
||||
SUBST_CLASSES+= config
|
||||
SUBST_STAGE.config= post-build
|
||||
SUBST_FILES.config= jftpgw.conf.sample
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2004/02/23 01:32:33 xtraeme Exp $
|
||||
$NetBSD: distinfo,v 1.2 2004/09/18 12:47:33 uebayasi Exp $
|
||||
|
||||
SHA1 (jftpgw-0.13.4.tar.gz) = 9bc043bafc2be73b29a446429b76b58345ae55e8
|
||||
Size (jftpgw-0.13.4.tar.gz) = 255160 bytes
|
||||
SHA1 (patch-aa) = 8af643cbdd2e6c4f620cd8f7a0d51419ce7f6769
|
||||
SHA1 (patch-ab) = 610cfa10d5282c5877f40529092c346db7d90078
|
||||
|
|
18
net/jftpgw/patches/patch-ab
Normal file
18
net/jftpgw/patches/patch-ab
Normal file
|
@ -0,0 +1,18 @@
|
|||
$NetBSD: patch-ab,v 1.1 2004/09/18 12:47:33 uebayasi Exp $
|
||||
|
||||
--- support/ipfilter.c.orig 2003-02-20 07:30:26.000000000 +0900
|
||||
+++ support/ipfilter.c
|
||||
@@ -55,6 +55,13 @@ get_realdst(fd, laddrp, faddrp, np)
|
||||
np->nl_outip = faddrp->sin_addr;
|
||||
np->nl_flags = IPN_TCP;
|
||||
|
||||
+#ifndef IPL_NAT
|
||||
+# ifdef IPL_NAME
|
||||
+# define IPL_NAT IPL_NAME
|
||||
+# else
|
||||
+# error Neither IPL_NAT nor IPL_NAME undefined
|
||||
+# endif
|
||||
+#endif
|
||||
if ((natfd = open(IPL_NAT, O_RDONLY)) < 0) {
|
||||
perror("open");
|
||||
return(0);
|
Loading…
Reference in a new issue