Update ircservices to 5.0.64.
While here, fixes PR#43618 (getline) and set LICENSE=gnu-gpl-v2. Version 5.0 ----------- 2009/07/31 .64 ChanServ DEPROTECT no longer removes channel owner mode, to prevent abuse by rogue users. Reported by Kieron Thwaites <ron2k.za@gmail.com>
This commit is contained in:
parent
3f82c92826
commit
61d8a67bb0
3 changed files with 40 additions and 6 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.35 2010/02/19 20:20:32 joerg Exp $
|
||||
# $NetBSD: Makefile,v 1.36 2010/07/15 11:48:21 obache Exp $
|
||||
#
|
||||
|
||||
DISTNAME= ircservices-5.0.63
|
||||
DISTNAME= ircservices-5.0.64
|
||||
CATEGORIES= chat
|
||||
MASTER_SITES= http://www.ircservices.za.net/download/old/ \
|
||||
ftp://ftp.esper.net/ircservices/old/
|
||||
|
@ -9,6 +9,7 @@ MASTER_SITES= http://www.ircservices.za.net/download/old/ \
|
|||
MAINTAINER= virtus@wanadoo.nl
|
||||
HOMEPAGE= http://www.ircservices.za.net/
|
||||
COMMENT= Services for IRC networks
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
|
|
|
@ -1,8 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.13 2007/11/24 00:47:36 adrianp Exp $
|
||||
$NetBSD: distinfo,v 1.14 2010/07/15 11:48:21 obache Exp $
|
||||
|
||||
SHA1 (ircservices-5.0.63.tar.gz) = 5c08af0d56bc99f9dc8f331eae9963beb3e28dad
|
||||
RMD160 (ircservices-5.0.63.tar.gz) = d61d5bf3dc28ac38a391b3918289d74ce2106ace
|
||||
Size (ircservices-5.0.63.tar.gz) = 1167436 bytes
|
||||
SHA1 (ircservices-5.0.64.tar.gz) = 6a12e05368da5dc251dd73b999856f2fc572a352
|
||||
RMD160 (ircservices-5.0.64.tar.gz) = 4b6b0fc113a9ff0c9aa45d4462a48b3836d27d49
|
||||
Size (ircservices-5.0.64.tar.gz) = 1163863 bytes
|
||||
SHA1 (patch-aa) = cff60257c4f5ebdfd0af4984008d2677b293029b
|
||||
SHA1 (patch-ab) = a15821c44bd9738080436a3626ec62d96c37db63
|
||||
SHA1 (patch-ac) = d567871c9cbb05b329247155c55e26e265476b48
|
||||
SHA1 (patch-ad) = b838e722e2c4019775b25cbc85ea2c5cf3510927
|
||||
|
|
32
chat/ircservices/patches/patch-ad
Normal file
32
chat/ircservices/patches/patch-ad
Normal file
|
@ -0,0 +1,32 @@
|
|||
$NetBSD: patch-ad,v 1.1 2010/07/15 11:48:22 obache Exp $
|
||||
|
||||
Avoid to conflict with getline(3) in IEEE Std 1003.1-2008.
|
||||
|
||||
--- lang/langcomp.c.orig 2009-07-31 14:54:04.000000000 +0000
|
||||
+++ lang/langcomp.c
|
||||
@@ -41,7 +41,6 @@
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
#include <unistd.h>
|
||||
-#undef getline
|
||||
|
||||
/* CR/LF values--used instead of '\r' and '\n' to avoid platform-dependent
|
||||
* messiness */
|
||||
@@ -115,7 +114,7 @@ static int stringnum(const char *name)
|
||||
/* Read a non-comment, non-blank line from the input file. Return NULL at
|
||||
* end of file. */
|
||||
|
||||
-static char *getline(FILE *f)
|
||||
+static char *get_line(FILE *f)
|
||||
{
|
||||
static char buf[1024];
|
||||
char *s;
|
||||
@@ -196,7 +195,7 @@ int main(int ac, char **av)
|
||||
return 1;
|
||||
}
|
||||
|
||||
- while (maxerr > 0 && (line = getline(in)) != NULL) {
|
||||
+ while (maxerr > 0 && (line = get_line(in)) != NULL) {
|
||||
if (*line == '\t') {
|
||||
if (curstring == -2) {
|
||||
fprintf(stderr, "%s:%d: Junk at beginning of file\n",
|
Loading…
Reference in a new issue