Make it understand "-net tap,ifname=tap3" on NetBSD.
This commit is contained in:
parent
dc77e9fd82
commit
61ecca2bf3
3 changed files with 19 additions and 2 deletions
|
@ -1,7 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.94 2012/07/23 11:17:54 ryoon Exp $
|
||||
# $NetBSD: Makefile,v 1.95 2012/08/03 17:51:47 asau Exp $
|
||||
|
||||
DISTNAME= qemu-1.1.1-1
|
||||
PKGNAME= qemu-1.1.1.1
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= emulators
|
||||
MASTER_SITES= http://wiki.qemu.org/download/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.76 2012/07/23 11:17:54 ryoon Exp $
|
||||
$NetBSD: distinfo,v 1.77 2012/08/03 17:51:47 asau Exp $
|
||||
|
||||
SHA1 (qemu-1.1.1-1.tar.bz2) = 0754fe79279f58445d4a6e2c18afcbc3f0e1bb00
|
||||
RMD160 (qemu-1.1.1-1.tar.bz2) = e1fa73652dbcfd234f862ce1979adf16182f00bc
|
||||
|
@ -15,5 +15,6 @@ SHA1 (patch-hw_ppc__oldworld.c) = e339647c92c7cbfe67b61b96bc655a47e7af2123
|
|||
SHA1 (patch-hw_xilinx__axienet.c) = ffd6a41d7c76ef11d63b27ffc263b668ee569e99
|
||||
SHA1 (patch-ioport.c) = 2bf04d5bf59b7e8939b20c168fb618a955bfa5a4
|
||||
SHA1 (patch-memory.c) = 6c7485270a5315c7eb174cb988a074fbbb760c3b
|
||||
SHA1 (patch-net_tap-bsd.c) = 48b95f1c8433ae460c569d679958fbd706f798e6
|
||||
SHA1 (patch-roms_seabios_tools_buildversion.sh) = 5ab15a25f47762a7abe30da0beb7b77facc88b13
|
||||
SHA1 (patch-slirp_tcp__subr.c) = 413f508eeb7fae166a3a512bd98dc63314b59af8
|
||||
|
|
15
emulators/qemu/patches/patch-net_tap-bsd.c
Normal file
15
emulators/qemu/patches/patch-net_tap-bsd.c
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-net_tap-bsd.c,v 1.1 2012/08/03 17:51:47 asau Exp $
|
||||
|
||||
Make it understand "-net tap,ifname=tap3" on NetBSD.
|
||||
|
||||
--- net/tap-bsd.c.orig 2012-07-17 18:11:14.000000000 +0000
|
||||
+++ net/tap-bsd.c
|
||||
@@ -49,7 +49,7 @@ int tap_open(char *ifname, int ifname_si
|
||||
struct stat s;
|
||||
#endif
|
||||
|
||||
-#if defined(__FreeBSD__) || defined(__FreeBSD_kernel__) || defined(__OpenBSD__)
|
||||
+#if defined(__FreeBSD__) || defined(__FreeBSD_kernel__) || defined(__OpenBSD__) || defined(__NetBSD__)
|
||||
/* if no ifname is given, always start the search from tap0/tun0. */
|
||||
int i;
|
||||
char dname[100];
|
Loading…
Reference in a new issue