Update xlispstat to 3.52.9, provided in pr 6617 by Johnny C. Lam.
This commit is contained in:
parent
f799c41fed
commit
61ed436dc0
7 changed files with 66 additions and 66 deletions
|
@ -1,16 +1,20 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 1998/10/03 20:28:08 frueauf Exp $
|
||||
# $NetBSD: Makefile,v 1.2 1998/12/21 10:45:31 frueauf Exp $
|
||||
# FreeBSD Id: Makefile,v 1.7 1998/08/20 07:35:21 asami Exp
|
||||
#
|
||||
|
||||
DISTNAME= xlispstat-3-52-5
|
||||
PKGNAME= xlispstat-3.52.5
|
||||
DISTNAME= xlispstat-3-52-9
|
||||
PKGNAME= xlispstat-3.52.9
|
||||
CATEGORIES= math lang
|
||||
MASTER_SITES= ftp://ftp.stat.umn.edu/pub/xlispstat/3-52/
|
||||
|
||||
MAINTAINER= packages@netbsd.org
|
||||
HOMEPAGE= http://www.stat.umn.edu/~luke/xls/xlsinfo/xlsinfo.html
|
||||
|
||||
CONFLICTS= xlispstat-3.52.5
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_X11= yes
|
||||
|
||||
ALL_TARGET= xlispstat
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
$NetBSD: md5,v 1.1.1.1 1998/10/03 20:28:08 frueauf Exp $
|
||||
$NetBSD: md5,v 1.2 1998/12/21 10:45:31 frueauf Exp $
|
||||
|
||||
MD5 (xlispstat-3-52-5.tar.gz) = 6fd817d1f07f9a2d51567c6500d41841
|
||||
MD5 (xlispstat-3-52-9.tar.gz) = b1038d45dd0b0bfef905642ac3805a58
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 1998/10/03 20:28:09 frueauf Exp $
|
||||
|
||||
--- Makefile.in.orig Mon Mar 23 13:44:59 1998
|
||||
+++ Makefile.in Fri Oct 2 18:11:53 1998
|
||||
@@ -117,6 +117,8 @@
|
||||
compiler/lift.fsl compiler/gencode.fsl compiler/peephole.fsl \
|
||||
compiler/assemble.fsl compiler/cmpfront.fsl
|
||||
|
||||
+all: xlispstat
|
||||
+
|
||||
xlispstat: setup.shell xlisp.wks
|
||||
./setup.shell xlispstat ${XLSLIB}
|
||||
chmod a+x xlispstat
|
|
@ -1,44 +1,54 @@
|
|||
$NetBSD: patch-ac,v 1.1.1.1 1998/10/03 20:28:09 frueauf Exp $
|
||||
$NetBSD: patch-ac,v 1.2 1998/12/21 10:45:31 frueauf Exp $
|
||||
|
||||
--- Makefile.in.orig Sat Oct 3 16:06:56 1998
|
||||
+++ Makefile.in Sat Oct 3 16:48:58 1998
|
||||
@@ -34,7 +34,8 @@
|
||||
--- Makefile.in.orig Wed Sep 16 15:19:33 1998
|
||||
+++ Makefile.in Sun Dec 20 04:19:56 1998
|
||||
@@ -6,7 +6,8 @@
|
||||
##############################################################################
|
||||
##############################################################################
|
||||
#
|
||||
-# XLSLIB -- directory for xlisp executable, startup, example, and help files
|
||||
+# XLSLIB -- directory for xlisp example and help files
|
||||
+# XLSLIBEXEC -- directory for xlisp executable and startup
|
||||
# BINDIR -- directory for xlispstat shell script
|
||||
#
|
||||
# For the remaining parameters, if your machine has a subdirectory in the
|
||||
@@ -34,7 +35,8 @@
|
||||
prefix = @prefix@
|
||||
exec_prefix = @exec_prefix@
|
||||
|
||||
-XLSLIB=${prefix}/lib/xlispstat
|
||||
+XLSLIB=${prefix}/share/xlispstat
|
||||
+LIBEXEC=${prefix}/libexec/xlispstat
|
||||
+XLSLIBEXEC=${prefix}/libexec/xlispstat
|
||||
BINDIR=${exec_prefix}/bin
|
||||
|
||||
GRAPHSYS = @GRAPHSYS@
|
||||
@@ -120,7 +121,7 @@
|
||||
all: xlispstat
|
||||
@@ -118,7 +120,7 @@
|
||||
compiler/assemble.fsl compiler/cmpfront.fsl
|
||||
|
||||
xlispstat: setup.shell xlisp.wks
|
||||
- ./setup.shell xlispstat ${XLSLIB}
|
||||
+ ./setup.shell xlispstat ${XLSLIB} ${LIBEXEC}
|
||||
+ ./setup.shell xlispstat ${XLSLIB} ${XLSLIBEXEC}
|
||||
chmod a+x xlispstat
|
||||
|
||||
xlisp.wks: xlisp ${CMPFSLFILES} ${FSLFILES} ${AUTOFSLFILES}
|
||||
@@ -144,10 +145,10 @@
|
||||
@@ -142,10 +144,10 @@
|
||||
|
||||
installexecs: xlispstat xlisp installdirs
|
||||
-cp xlispstat ${BINDIR}/xlispstat
|
||||
- -cp xlisp ${XLSLIB}
|
||||
+ -cp xlisp ${LIBEXEC}
|
||||
+ -cp xlisp ${XLSLIBEXEC}
|
||||
|
||||
installlsp: xlisp.wks xlisp.hlp ${AUTOFSLFILES} ${CMPFSLFILES} installdirs
|
||||
- -cp xlisp.wks ${XLSLIB}
|
||||
+ -cp xlisp.wks ${LIBEXEC}
|
||||
+ -cp xlisp.wks ${XLSLIBEXEC}
|
||||
-cp xlisp.hlp ${XLSLIB}
|
||||
-cp Autoload/_autoidx.lsp Autoload/*.fsl ${XLSLIB}/Autoload
|
||||
-cp Data/*.lsp ${XLSLIB}/Data
|
||||
@@ -157,6 +158,7 @@
|
||||
@@ -155,6 +157,7 @@
|
||||
installdirs:
|
||||
-mkdir -p ${BINDIR}
|
||||
-mkdir -p ${XLSLIB}
|
||||
+ -mkdir -p ${LIBEXEC}
|
||||
+ -mkdir -p ${XLSLIBEXEC}
|
||||
-mkdir ${XLSLIB}/Data
|
||||
-mkdir ${XLSLIB}/Examples
|
||||
-mkdir ${XLSLIB}/Autoload
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-ad,v 1.1.1.1 1998/10/03 20:28:09 frueauf Exp $
|
||||
$NetBSD: patch-ad,v 1.2 1998/12/21 10:45:31 frueauf Exp $
|
||||
|
||||
--- setup.shell.orig Wed Sep 7 16:34:36 1994
|
||||
+++ setup.shell Sat Oct 3 16:50:37 1998
|
||||
|
@ -6,14 +6,14 @@ $NetBSD: patch-ad,v 1.1.1.1 1998/10/03 20:28:09 frueauf Exp $
|
|||
cat > $1 <<+++
|
||||
#!/bin/sh
|
||||
XLISPLIB=$2 export XLISPLIB
|
||||
+LIBEXEC=$3 export LIBEXEC
|
||||
+XLSLIBEXEC=$3 export XLSLIBEXEC
|
||||
if test -f xlisp.wks; then WKS="xlisp.wks";
|
||||
-else WKS="\${XLISPLIB}/xlisp.wks";
|
||||
+else WKS="\${LIBEXEC}/xlisp.wks";
|
||||
+else WKS="\${XLSLIBEXEC}/xlisp.wks";
|
||||
fi
|
||||
if test -f xlisp; then XLISP=xlisp;
|
||||
-else XLISP="\${XLISPLIB}/xlisp"
|
||||
+else XLISP="\${LIBEXEC}/xlisp"
|
||||
+else XLISP="\${XLSLIBEXEC}/xlisp"
|
||||
fi
|
||||
exec \${XLISP} -w\${WKS} \$*
|
||||
+++
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
This is XLISP-STAT 3.52 Release 5 for generic bsd systems (with simple
|
||||
This is XLISP-STAT 3.52 Release 9 for generic bsd systems (with simple
|
||||
tektronix graphics from the gnuplot system), or X11.
|
||||
|
||||
XLISP-STAT is a statistical environment based on a dialect of the Lisp
|
||||
|
|
|
@ -1,44 +1,43 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 1998/10/03 20:28:09 frueauf Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 1998/12/21 10:45:31 frueauf Exp $
|
||||
bin/xlispstat
|
||||
libexec/xlispstat/xlisp
|
||||
libexec/xlispstat/xlisp.wks
|
||||
share/xlispstat/Autoload/_autoidx.lsp
|
||||
share/xlispstat/Autoload/bayes.fsl
|
||||
share/xlispstat/Autoload/glim.fsl
|
||||
share/xlispstat/Autoload/maximize.fsl
|
||||
share/xlispstat/Autoload/nonlin.fsl
|
||||
share/xlispstat/Autoload/oneway.fsl
|
||||
share/xlispstat/Autoload/stepper.fsl
|
||||
share/xlispstat/Data/absorbtion.lsp
|
||||
share/xlispstat/Data/stackloss.lsp
|
||||
share/xlispstat/Data/randu.lsp
|
||||
share/xlispstat/Data/puromycin.lsp
|
||||
share/xlispstat/Data/oxygen.lsp
|
||||
share/xlispstat/Data/metabolism.lsp
|
||||
share/xlispstat/Data/leukemia.lsp
|
||||
share/xlispstat/Data/iris.lsp
|
||||
share/xlispstat/Data/heating.lsp
|
||||
share/xlispstat/Data/diabetes.lsp
|
||||
share/xlispstat/Data/car-prices.lsp
|
||||
share/xlispstat/Data/book.lsp
|
||||
share/xlispstat/Data/aircraft.lsp
|
||||
share/xlispstat/Data/book.lsp
|
||||
share/xlispstat/Data/car-prices.lsp
|
||||
share/xlispstat/Data/diabetes.lsp
|
||||
share/xlispstat/Data/heating.lsp
|
||||
share/xlispstat/Data/iris.lsp
|
||||
share/xlispstat/Data/leukemia.lsp
|
||||
share/xlispstat/Data/metabolism.lsp
|
||||
share/xlispstat/Data/oxygen.lsp
|
||||
share/xlispstat/Data/puromycin.lsp
|
||||
share/xlispstat/Data/randu.lsp
|
||||
share/xlispstat/Data/stackloss.lsp
|
||||
share/xlispstat/Data/tutorial.lsp
|
||||
share/xlispstat/Examples/abrasiondemo.lsp
|
||||
share/xlispstat/Examples/tour.lsp
|
||||
share/xlispstat/Examples/rotatedemo.lsp
|
||||
share/xlispstat/Examples/regdemo.lsp
|
||||
share/xlispstat/Examples/plotcontrols.lsp
|
||||
share/xlispstat/Examples/inspect.lsp
|
||||
share/xlispstat/Examples/fstat.lsp
|
||||
share/xlispstat/Examples/dataprotos.lsp
|
||||
share/xlispstat/Examples/bcdemo.lsp
|
||||
share/xlispstat/Examples/addhandrotate.lsp
|
||||
share/xlispstat/Examples/addbox.lsp
|
||||
share/xlispstat/Examples/addhandrotate.lsp
|
||||
share/xlispstat/Examples/bcdemo.lsp
|
||||
share/xlispstat/Examples/dataprotos.lsp
|
||||
share/xlispstat/Examples/fstat.lsp
|
||||
share/xlispstat/Examples/inspect.lsp
|
||||
share/xlispstat/Examples/plotcontrols.lsp
|
||||
share/xlispstat/Examples/regdemo.lsp
|
||||
share/xlispstat/Examples/rotatedemo.lsp
|
||||
share/xlispstat/Examples/tour.lsp
|
||||
share/xlispstat/Examples/tourdemo.lsp
|
||||
share/xlispstat/Autoload/_autoidx.lsp
|
||||
share/xlispstat/Autoload/stepper.fsl
|
||||
share/xlispstat/Autoload/oneway.fsl
|
||||
share/xlispstat/Autoload/nonlin.fsl
|
||||
share/xlispstat/Autoload/maximize.fsl
|
||||
share/xlispstat/Autoload/glim.fsl
|
||||
share/xlispstat/Autoload/bayes.fsl
|
||||
share/xlispstat/Autoload/symaclet.fsl
|
||||
share/xlispstat/xlisp.hlp
|
||||
@dirrm libexec/xlispstat
|
||||
@dirrm share/xlispstat/Autoload
|
||||
@dirrm share/xlispstat/Data
|
||||
@dirrm share/xlispstat/Examples
|
||||
@dirrm share/xlispstat
|
||||
@dirrm libexec/xlispstat
|
||||
|
|
Loading…
Reference in a new issue