Use nbcompat, update some patches. Fixes build on SunOS.

This commit is contained in:
jperkin 2015-07-09 12:00:13 +00:00
parent 0080ad2437
commit 620b6ab350
4 changed files with 27 additions and 7 deletions

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.9 2011/07/03 22:04:06 dholland Exp $
$NetBSD: distinfo,v 1.10 2015/07/09 12:00:13 jperkin Exp $
SHA1 (ifp-line-0.3.tar.gz) = e511157878a08fbea6a2c702e726e131dd20cb2f
RMD160 (ifp-line-0.3.tar.gz) = 71fee7e02daeb9b3dc2e7da53236057b9d5a9f63
Size (ifp-line-0.3.tar.gz) = 138272 bytes
SHA1 (patch-Makefile_am) = f855283ab54a49c30a08f408a67ffa6c3ac88a72
SHA1 (patch-Makefile_in) = e196e6d59a3bf8d1af58f4a5f94a3fa16c3af4af
SHA1 (patch-Makefile_am) = a273f2e813b43b717155a2dcf7bc1372d23b936b
SHA1 (patch-Makefile_in) = cf64aab56fbf9d7b58535a341c93176a6709b02b
SHA1 (patch-ifp__routines.c) = 654fbb77f3404e987e7fb777da7cd0e1e92f4b72

View file

@ -1,8 +1,8 @@
$NetBSD: patch-Makefile_am,v 1.1 2011/07/03 22:04:51 dholland Exp $
$NetBSD: patch-Makefile_am,v 1.2 2015/07/09 12:00:14 jperkin Exp $
Avoid confusing make with multiple paths to the same file.
--- Makefile.am~ 2005-12-10 07:35:04.000000000 +0000
--- Makefile.am.orig 2005-12-10 07:35:04.000000000 +0000
+++ Makefile.am
@@ -5,7 +5,7 @@ EXTRA_DIST = $(man1_MANS) $(pkgdata_DATA
bin_PROGRAMS = ifp

View file

@ -1,8 +1,8 @@
$NetBSD: patch-Makefile_in,v 1.1 2011/07/03 22:04:51 dholland Exp $
$NetBSD: patch-Makefile_in,v 1.2 2015/07/09 12:00:14 jperkin Exp $
Avoid confusing make with multiple paths to the same file.
--- Makefile.in~ 2005-12-10 08:35:05.000000000 +0000
--- Makefile.in.orig 2005-12-10 08:35:05.000000000 +0000
+++ Makefile.in
@@ -70,7 +70,7 @@ binPROGRAMS_INSTALL = $(INSTALL_PROGRAM)
PROGRAMS = $(bin_PROGRAMS)

View file

@ -0,0 +1,19 @@
$NetBSD: patch-ifp__routines.c,v 1.1 2015/07/09 12:00:14 jperkin Exp $
Use nbcompat.
--- ifp_routines.c.orig 2005-12-03 16:55:06.000000000 +0000
+++ ifp_routines.c
@@ -8,7 +8,12 @@ static const char rcsid[] = "$Id: ifp_ro
#include <sys/stat.h>
#include <sys/wait.h>
#include <errno.h>
+#if defined(HAVE_NBCOMPAT_H)
+#include <nbcompat.h>
+#include <nbcompat/fts.h>
+#else
#include <fts.h>
+#endif
#include <unistd.h>
#include "unicodehack.h"