squid6: update to 6.8

Changes in squid-6.8 (4 Mar 2024)

        - Bug 5344: mgr:config segfaults without logformat
        - Bug 5343: Fix build on GCC 14
        - Fix infinite recursion when parsing malformed HTTP chunks
        - Fix max-stale in default refresh_pattern
        - Fix marking of problematic cached IP addresses
        - Improved portability to MacOS
        - ... and some documentation improvements

Changes in squid-6.7 (4 Feb 2024)

        - Bug 5337: workaround for crash on startup if -a option is used
        - Bug 5274: Successful tunnels logged as TCP_TUNNEL/500
        - Fix crash when NTLM and Negotiate helpers are queried with no HTTP request
        - Fix SslBump memory leak when mimicking certificates with Authority Key Identifier
        - Fix memory leak on SslBump certificates with Authority Key Identifier extension
        - Fix a possible integer overflow in FTP Gateway
        - Extend cache_log_message to Bug 5187 and job invalidation BUGs
        - Remove incorrect beta version warning
        - MS Windows portability improvements
        - ... and some documentation improvements
This commit is contained in:
sborrill 2024-03-06 09:31:23 +00:00
parent 0c339320a1
commit 6213df2327
3 changed files with 6 additions and 32 deletions

View File

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.8 2024/02/21 12:58:50 sborrill Exp $
# $NetBSD: Makefile,v 1.9 2024/03/06 09:31:23 sborrill Exp $
DISTNAME= squid-6.6
PKGREVISION= 1
DISTNAME= squid-6.8
CATEGORIES= www
MASTER_SITES= http://www.squid-cache.org/Versions/v6/
EXTRACT_SUFX= .tar.xz

View File

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.6 2024/02/21 12:58:50 sborrill Exp $
$NetBSD: distinfo,v 1.7 2024/03/06 09:31:23 sborrill Exp $
BLAKE2s (squid-6.6.tar.xz) = 3aa83a70f8f01881e19d872da8f9fd21044d1ed554265f50ab334cfc64ddf447
SHA512 (squid-6.6.tar.xz) = 4ab261ed85ad674288467500aca9d8a48e3918b55f777635c0ba7a2551f248d35536848a5fbf2c946490a818004727f2aed33144f0a3ebab0be36cc4cffb020c
Size (squid-6.6.tar.xz) = 2554824 bytes
BLAKE2s (squid-6.8.tar.xz) = 1ccdd16124e384eff7bc4d79c10e48471b82d1f28b8539356b54a17df8031155
SHA512 (squid-6.8.tar.xz) = 25509662de0b16af763a7aca090937b16c9ae15cb29ae1275634db9091eba511de33e9119ef8552fda936b7a7cfd1b7e51f6082c039c8e9e9f7da64d5efac992
Size (squid-6.8.tar.xz) = 2547796 bytes
SHA1 (patch-compat_compat.h) = 839381a5e1f46e7d9b822bbb53d82a53c996ddc0
SHA1 (patch-configure) = 66bf56c83876452ba12727d5d957619d75f4d1bc
SHA1 (patch-errors_Makefile.in) = e7ba371bb24e40eeb9dd10dc6fe12d208e681d72
@ -10,5 +10,4 @@ SHA1 (patch-src_Makefile.in) = afc5aefd97c46d1ffab43e97aeaeade3a5a8c648
SHA1 (patch-src_acl_external_kerberos__ldap__group_support__resolv.cc) = 0ea41d55e32d689a16e012391a9eea67631daf3a
SHA1 (patch-src_comm_ModKqueue.cc) = d8c5d235f07a48731275101d60fcbf2e22f77b96
SHA1 (patch-src_esi_VarState.cc) = d9418e59cdc390b2d970195167a99bb7ed392c38
SHA1 (patch-src_ipcache.cc) = cc0852ae2f9f08e8706c81e459f8c25f594b87df
SHA1 (patch-tools_Makefile.in) = d098c0c9dc4af577f74e562d99f07ed98be5ae01

View File

@ -1,24 +0,0 @@
$NetBSD: patch-src_ipcache.cc,v 1.1 2024/02/21 12:58:50 sborrill Exp $
https://github.com/squid-cache/squid/pull/1691
Since inception in 2017 commit fd9c47d, Dns::CachedIps::have() always
returned position zero after finding a matching IP address (at zero or
positive position). The bug affected two callers:
* markAsBad() always marked the first stored address (as bad);
* forgetMarking() always cleared the first stored address marking.
Buggy markings led to Squid sometimes not attempting to use a working
address (e.g., IPv4) while using a known problematic one (e.g., IPv6).
--- src/ipcache.cc.orig 2023-12-07 01:36:15.000000000 +0000
+++ src/ipcache.cc 2024-02-21 09:14:05.428281018 +0000
@@ -990,6 +990,7 @@
debugs(14, 7, ip << " at " << pos << " in " << *this);
return true;
}
+ ++pos; // TODO: Replace with std::views::enumerate() after upgrading to C++23
}
// no such address; leave *position as is
debugs(14, 7, " no " << ip << " in " << *this);