Switch to use libnotify07.
Bump PKGREVISION.
This commit is contained in:
parent
e8c9e35b91
commit
6246f012f2
3 changed files with 41 additions and 18 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.29 2013/06/06 12:55:03 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.30 2013/08/12 14:24:35 obache Exp $
|
||||
#
|
||||
|
||||
DISTNAME= gnome-mount-0.8
|
||||
PKGREVISION= 24
|
||||
PKGREVISION= 25
|
||||
CATEGORIES= sysutils gnome
|
||||
MASTER_SITES= http://hal.freedesktop.org/releases/
|
||||
|
||||
|
@ -28,7 +28,7 @@ post-extract:
|
|||
.include "../../security/libgnome-keyring/buildlink3.mk"
|
||||
.include "../../sysutils/dbus-glib/buildlink3.mk"
|
||||
.include "../../sysutils/hal/buildlink3.mk"
|
||||
.include "../../sysutils/libnotify/buildlink3.mk"
|
||||
.include "../../sysutils/libnotify07/buildlink3.mk"
|
||||
.include "../../sysutils/nautilus/buildlink3.mk"
|
||||
.include "../../x11/gtk2/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.3 2009/03/10 05:24:35 dsainty Exp $
|
||||
$NetBSD: distinfo,v 1.4 2013/08/12 14:24:35 obache Exp $
|
||||
|
||||
SHA1 (gnome-mount-0.8.tar.gz) = 846ba178cf9009f3e32c7f55f912b3ca6b9ecedb
|
||||
RMD160 (gnome-mount-0.8.tar.gz) = 003800eda3edb7747714b1002bd1a1b50ea44fe9
|
||||
Size (gnome-mount-0.8.tar.gz) = 505788 bytes
|
||||
SHA1 (patch-aa) = 31479b417cf7c645cef6f3539aa49576d5104795
|
||||
SHA1 (patch-ab) = ca905485a13762e197be6862b04a801f5716ddcd
|
||||
SHA1 (patch-ab) = caf82291c778bb5153ca506dc5357998fd4cfd0c
|
||||
SHA1 (patch-ac) = 026448555bd9710cda343b6573260e3dcaa28b20
|
||||
|
|
|
@ -1,7 +1,12 @@
|
|||
$NetBSD: patch-ab,v 1.3 2009/03/10 05:24:36 dsainty Exp $
|
||||
$NetBSD: patch-ab,v 1.4 2013/08/12 14:24:36 obache Exp $
|
||||
|
||||
--- src/gnome-mount.c.orig 2008-04-17 11:41:32.000000000 +1200
|
||||
+++ src/gnome-mount.c 2009-03-10 17:11:00.000000000 +1300
|
||||
* XXX
|
||||
* gtk/gtk.h is not included from libnotify/notify.h of libnotify-0.7
|
||||
* XXX
|
||||
* libnotify-0.7 API change
|
||||
|
||||
--- src/gnome-mount.c.orig 2008-04-16 23:41:32.000000000 +0000
|
||||
+++ src/gnome-mount.c
|
||||
@@ -30,6 +30,7 @@
|
||||
#include <fcntl.h>
|
||||
#include <string.h>
|
||||
|
@ -10,7 +15,15 @@ $NetBSD: patch-ab,v 1.3 2009/03/10 05:24:36 dsainty Exp $
|
|||
|
||||
#include <dbus/dbus.h>
|
||||
#include <dbus/dbus-glib-lowlevel.h>
|
||||
@@ -51,9 +52,9 @@
|
||||
@@ -39,6 +40,7 @@
|
||||
#include <glib/gi18n.h>
|
||||
#include <gconf/gconf-client.h>
|
||||
#include <gdk/gdkx.h>
|
||||
+#include <gtk/gtk.h>
|
||||
#include "copy-paste/gnome-password-dialog.h"
|
||||
#include <gnome-keyring.h>
|
||||
#include <libnotify/notify.h>
|
||||
@@ -51,9 +53,9 @@
|
||||
#define NOTIFY_EXPIRES_DEFAULT -1
|
||||
#endif
|
||||
|
||||
|
@ -22,7 +35,7 @@ $NetBSD: patch-ab,v 1.3 2009/03/10 05:24:36 dsainty Exp $
|
|||
#include <fstab.h>
|
||||
#include <sys/param.h>
|
||||
#include <sys/ucred.h>
|
||||
@@ -677,15 +678,19 @@
|
||||
@@ -677,15 +679,19 @@ static char *
|
||||
get_mntent_mount_point(const char *device_file)
|
||||
{
|
||||
char *mount_point;
|
||||
|
@ -44,7 +57,7 @@ $NetBSD: patch-ab,v 1.3 2009/03/10 05:24:36 dsainty Exp $
|
|||
#elif defined(sun)
|
||||
FILE *f;
|
||||
struct mnttab mnt;
|
||||
@@ -694,7 +699,7 @@
|
||||
@@ -694,7 +700,7 @@ get_mntent_mount_point(const char *devic
|
||||
|
||||
mount_point = NULL;
|
||||
|
||||
|
@ -53,7 +66,7 @@ $NetBSD: patch-ab,v 1.3 2009/03/10 05:24:36 dsainty Exp $
|
|||
if ((f = setmntent ("/proc/mounts", "r")) != NULL) {
|
||||
|
||||
while ((mnte = getmntent_r (f, &mnt, buf, sizeof(buf))) != NULL) {
|
||||
@@ -717,13 +722,13 @@
|
||||
@@ -717,13 +723,13 @@ get_mntent_mount_point(const char *devic
|
||||
}
|
||||
fclose(f);
|
||||
}
|
||||
|
@ -69,7 +82,7 @@ $NetBSD: patch-ab,v 1.3 2009/03/10 05:24:36 dsainty Exp $
|
|||
|
||||
out:
|
||||
return (mount_point);
|
||||
@@ -862,7 +867,7 @@
|
||||
@@ -862,7 +868,7 @@ out:
|
||||
static gboolean
|
||||
fstab_open (gpointer *handle)
|
||||
{
|
||||
|
@ -78,7 +91,7 @@ $NetBSD: patch-ab,v 1.3 2009/03/10 05:24:36 dsainty Exp $
|
|||
return setfsent () == 1;
|
||||
#else
|
||||
*handle = fopen ("/etc/fstab", "r");
|
||||
@@ -873,7 +878,7 @@
|
||||
@@ -873,7 +879,7 @@ fstab_open (gpointer *handle)
|
||||
static char *
|
||||
fstab_next (gpointer handle, char **mount_point)
|
||||
{
|
||||
|
@ -87,7 +100,7 @@ $NetBSD: patch-ab,v 1.3 2009/03/10 05:24:36 dsainty Exp $
|
|||
struct fstab *fstab;
|
||||
|
||||
fstab = getfsent ();
|
||||
@@ -901,7 +906,7 @@
|
||||
@@ -901,7 +907,7 @@ fstab_next (gpointer handle, char **moun
|
||||
static void
|
||||
fstab_close (gpointer handle)
|
||||
{
|
||||
|
@ -96,7 +109,7 @@ $NetBSD: patch-ab,v 1.3 2009/03/10 05:24:36 dsainty Exp $
|
|||
endfsent ();
|
||||
#else
|
||||
fclose (handle);
|
||||
@@ -1116,7 +1121,7 @@
|
||||
@@ -1116,7 +1122,7 @@ out:
|
||||
return ret;
|
||||
}
|
||||
|
||||
|
@ -105,7 +118,7 @@ $NetBSD: patch-ab,v 1.3 2009/03/10 05:24:36 dsainty Exp $
|
|||
#define MOUNT "/sbin/mount"
|
||||
#define UMOUNT "/sbin/umount"
|
||||
#else
|
||||
@@ -1451,7 +1456,7 @@
|
||||
@@ -1451,7 +1457,7 @@ volume_mount (const char *udi, LibHalVol
|
||||
if (volume == NULL && (mount_options->len == 0)) {
|
||||
/* volume from a non-pollable drive, just set uid.. */
|
||||
|
||||
|
@ -114,7 +127,7 @@ $NetBSD: patch-ab,v 1.3 2009/03/10 05:24:36 dsainty Exp $
|
|||
snprintf (uidbuf, sizeof (uidbuf) - 1, "uid=%u", getuid ());
|
||||
#else
|
||||
snprintf (uidbuf, sizeof (uidbuf) - 1, "-u=%u", getuid ());
|
||||
@@ -1482,7 +1487,7 @@
|
||||
@@ -1482,7 +1488,7 @@ volume_mount (const char *udi, LibHalVol
|
||||
g_debug ("read default option '%s' from gconf strlist key %s", option, key);
|
||||
|
||||
/* special workaround to replace "uid=" with "uid=<actual uid of caller>" */
|
||||
|
@ -123,3 +136,13 @@ $NetBSD: patch-ab,v 1.3 2009/03/10 05:24:36 dsainty Exp $
|
|||
if (strcmp (option, "uid=") == 0) {
|
||||
g_free (option);
|
||||
option = g_strdup_printf ("uid=%u", getuid ());
|
||||
@@ -1577,8 +1583,7 @@ unmount_cache_timeout_func (gpointer dat
|
||||
message = g_strdup_printf (_("There is data that needs to be written to the device %s before it can be removed. Please do not remove the media or disconnect the drive."), unmount_note_drive_name);
|
||||
unmount_note = notify_notification_new (summary,
|
||||
message,
|
||||
- "gnome-dev-harddisk", /* TODO: use appropriate icon */
|
||||
- NULL);
|
||||
+ "gnome-dev-harddisk");
|
||||
if (unmount_note == NULL) {
|
||||
g_warning ("Cannot create note for unmount cache sync");
|
||||
} else {
|
||||
|
|
Loading…
Reference in a new issue