void main

This commit is contained in:
dholland 2011-09-14 07:11:33 +00:00
parent e29f884497
commit 62524c736d
2 changed files with 25 additions and 6 deletions

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.5 2005/09/28 18:59:41 rillig Exp $
$NetBSD: distinfo,v 1.6 2011/09/14 07:11:33 dholland Exp $
SHA1 (hint_unix_serial.tar) = b590c036638050c116b12d09a80ed910f68af271
RMD160 (hint_unix_serial.tar) = ca58d34cc3ab2c7effeec19106f1c01153f4a593
Size (hint_unix_serial.tar) = 71680 bytes
SHA1 (patch-ab) = 7ac0dd017bbc25c6573b8d60f08f85785baed8f5
SHA1 (patch-ab) = b773cbb855181c43c28d28308239fe6fdddaf509
SHA1 (patch-ac) = aca05bc3024cd42dbb8b6dc9006c771948b04838

View file

@ -1,8 +1,27 @@
$NetBSD: patch-ab,v 1.3 2005/09/28 18:59:41 rillig Exp $
$NetBSD: patch-ab,v 1.4 2011/09/14 07:11:33 dholland Exp $
--- hint.c.orig Sun May 31 22:34:52 1998
+++ hint.c Wed Sep 28 20:52:04 2005
@@ -90,7 +90,7 @@ void main(int argc, char *argv[])
- fix void main
- fix bad printf format
- not sure what the last change is about (XXX)
--- hint.c.orig 1998-05-31 20:34:52.000000000 +0000
+++ hint.c
@@ -19,7 +19,7 @@
/* Refer to hint.h and typedefs.h for all-capitalized definitions. */
#include "hint.h"
-void main(int argc, char *argv[])
+int main(int argc, char *argv[])
{
FILE *curv; /* Output file for QUIPS curve */
char filnm[80]; /* Output file name */
@@ -85,12 +85,12 @@ void main(int argc, char *argv[])
printf("Please send results and questions to: hint@scl.ameslab.gov\n");
printf("When sending results please follow the form in README\n");
printf("________________________________________________________\n");
- printf("RECT is %d bytes\n",sizeof(RECT));
+ printf("RECT is %zd bytes\n",sizeof(RECT));
#ifdef DEBUG
curv = stdout;
#else