Only a few architectures can handle native code. For all the others,
generating byte-code only must suffice. Patch provided in PR 36049 by Jaap Boender.
This commit is contained in:
parent
4c3c864e51
commit
626d94c7e0
6 changed files with 47 additions and 5 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.3 2007/01/18 09:59:59 tonio Exp $
|
||||
# $NetBSD: Makefile,v 1.4 2007/06/09 11:05:00 rillig Exp $
|
||||
#
|
||||
|
||||
DISTNAME= pcre-ocaml-5.11.2
|
||||
|
@ -11,7 +11,16 @@ HOMEPAGE= http://www.ocaml.info/ocaml_sources/
|
|||
COMMENT= Perl compatible regular expressions for OCaml
|
||||
|
||||
DEPENDS+= ocaml-findlib-[0-9]*:../../devel/ocaml-findlib
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
USE_TOOLS+= gmake
|
||||
.if (${MACHINE_ARCH} == "i386") || (${MACHINE_ARCH} == "powerpc") || \
|
||||
(${MACHINE_ARCH} == "sparc") || (${MACHINE_ARCH} == "x86_64")
|
||||
PLIST_SRC= PLIST PLIST.opt
|
||||
.else
|
||||
BUILD_TARGET= byte
|
||||
.endif
|
||||
|
||||
EGDIR= ${PREFIX}/share/examples/pcre-ocaml
|
||||
INSTALLATION_DIRS= ${EGDIR}
|
||||
|
|
|
@ -1,11 +1,9 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2006/05/20 14:22:04 rillig Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 2007/06/09 11:05:00 rillig Exp $
|
||||
lib/ocaml/site-lib/pcre/META
|
||||
lib/ocaml/site-lib/pcre/dllpcre_stubs.so
|
||||
lib/ocaml/site-lib/pcre/libpcre_stubs.a
|
||||
lib/ocaml/site-lib/pcre/pcre.a
|
||||
lib/ocaml/site-lib/pcre/pcre.cma
|
||||
lib/ocaml/site-lib/pcre/pcre.cmi
|
||||
lib/ocaml/site-lib/pcre/pcre.cmxa
|
||||
lib/ocaml/site-lib/pcre/pcre.mli
|
||||
share/examples/pcre-ocaml/cloc/Makefile
|
||||
share/examples/pcre-ocaml/cloc/README
|
||||
|
|
3
devel/pcre-ocaml/PLIST.opt
Normal file
3
devel/pcre-ocaml/PLIST.opt
Normal file
|
@ -0,0 +1,3 @@
|
|||
@comment $NetBSD: PLIST.opt,v 1.1 2007/06/09 11:05:00 rillig Exp $
|
||||
lib/ocaml/site-lib/pcre/pcre.a
|
||||
lib/ocaml/site-lib/pcre/pcre.cmxa
|
|
@ -1,5 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.2 2007/01/18 09:59:59 tonio Exp $
|
||||
$NetBSD: distinfo,v 1.3 2007/06/09 11:05:00 rillig Exp $
|
||||
|
||||
SHA1 (pcre-ocaml-5.11.2.tar.bz2) = 2a9f44165670a4fc81d9a13f4f7192ebc5a96b71
|
||||
RMD160 (pcre-ocaml-5.11.2.tar.bz2) = 6a7d690d49f86fa36845b8e064248677faa9ad98
|
||||
Size (pcre-ocaml-5.11.2.tar.bz2) = 46651 bytes
|
||||
SHA1 (patch-aa) = ff7aaec3c2fb06b1c9ab410257b64c8d5d29dcf6
|
||||
SHA1 (patch-ab) = 1a4de1d021cc9ebafdab8f470750fe097d80905e
|
||||
|
|
20
devel/pcre-ocaml/patches/patch-aa
Normal file
20
devel/pcre-ocaml/patches/patch-aa
Normal file
|
@ -0,0 +1,20 @@
|
|||
$NetBSD: patch-aa,v 1.1 2007/06/09 11:05:00 rillig Exp $
|
||||
|
||||
--- Makefile.orig 2006-11-22 18:25:59.000000000 +0100
|
||||
+++ Makefile 2007-03-21 11:19:18.000000000 +0100
|
||||
@@ -2,9 +2,12 @@
|
||||
|
||||
EXAMPLES = $(filter-out examples/CVS, $(wildcard examples/*))
|
||||
|
||||
-.PHONY: all
|
||||
-all:
|
||||
- @cd lib && $(MAKE) byte-code-library native-code-library
|
||||
+.PHONY: all byte
|
||||
+all: byte
|
||||
+ @cd lib && $(MAKE) native-code-library
|
||||
+
|
||||
+byte:
|
||||
+ @cd lib && $(MAKE) byte-code-library
|
||||
|
||||
.PHONY: examples
|
||||
examples:
|
10
devel/pcre-ocaml/patches/patch-ab
Normal file
10
devel/pcre-ocaml/patches/patch-ab
Normal file
|
@ -0,0 +1,10 @@
|
|||
$NetBSD: patch-ab,v 1.1 2007/06/09 11:05:00 rillig Exp $
|
||||
|
||||
--- lib/Makefile.orig 2007-03-21 11:30:21.000000000 +0100
|
||||
+++ lib/Makefile 2007-03-21 11:30:33.000000000 +0100
|
||||
@@ -1,4 +1,5 @@
|
||||
OCAMLMAKEFILE = ../OCamlMakefile
|
||||
+OCAMLFIND_INSTFLAGS = -optional
|
||||
|
||||
SOURCES = pcre.mli pcre.ml pcre_stubs.c
|
||||
CFLAGS = -O2
|
Loading…
Reference in a new issue