py-magic-wormhole-transit-relay: convert to wheel.mk

Fix build with Python 3.12.

Bump PKGREVISION.
This commit is contained in:
wiz 2023-11-05 22:43:07 +00:00
parent fe9190a28d
commit 62748a7b75
4 changed files with 32 additions and 12 deletions

View File

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.3 2023/10/23 06:37:50 wiz Exp $
# $NetBSD: Makefile,v 1.4 2023/11/05 22:43:07 wiz Exp $
DISTNAME= magic-wormhole-transit-relay-0.2.1
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
PKGREVISION= 2
PKGREVISION= 3
CATEGORIES= net python
MASTER_SITES= ${MASTER_SITE_PYPI:=m/magic-wormhole-transit-relay/}
@ -11,13 +11,14 @@ HOMEPAGE= https://github.com/magic-wormhole/magic-wormhole-transit-relay
COMMENT= Transit Relay server for Magic-Wormhole
LICENSE= mit
PYTHON_VERSIONS_INCOMPATIBLE= 27
TOOL_DEPENDS+= ${PYPKGPREFIX}-wheel-[0-9]*:../../devel/py-wheel
DEPENDS+= ${PYPKGPREFIX}-twisted>=17.5.0:../../net/py-twisted
TEST_DEPENDS+= ${PYPKGPREFIX}-mock-[0-9]*:../../devel/py-mock
USE_LANGUAGES= # none
PYTHON_VERSIONS_INCOMPATIBLE= 27
.include "../../lang/python/batteries-included.mk"
.include "../../lang/python/egg.mk"
.include "../../lang/python/wheel.mk"
.include "../../mk/bsd.pkg.mk"

View File

@ -1,9 +1,9 @@
@comment $NetBSD: PLIST,v 1.1 2021/06/27 16:25:23 wiz Exp $
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/requires.txt
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
@comment $NetBSD: PLIST,v 1.2 2023/11/05 22:43:07 wiz Exp $
${PYSITELIB}/${WHEEL_INFODIR}/LICENSE
${PYSITELIB}/${WHEEL_INFODIR}/METADATA
${PYSITELIB}/${WHEEL_INFODIR}/RECORD
${PYSITELIB}/${WHEEL_INFODIR}/WHEEL
${PYSITELIB}/${WHEEL_INFODIR}/top_level.txt
${PYSITELIB}/twisted/plugins/magic_wormhole_transit_relay.py
${PYSITELIB}/twisted/plugins/magic_wormhole_transit_relay.pyc
${PYSITELIB}/twisted/plugins/magic_wormhole_transit_relay.pyo

View File

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.3 2021/10/26 11:06:39 nia Exp $
$NetBSD: distinfo,v 1.4 2023/11/05 22:43:07 wiz Exp $
BLAKE2s (magic-wormhole-transit-relay-0.2.1.tar.gz) = a5f39eb301552ae98fe462c5d7fb4d6384c42e46abeae1bc800aa7c05ac070a0
SHA512 (magic-wormhole-transit-relay-0.2.1.tar.gz) = 07eccfe4b5224d66cf31990adabf92e7057b186c509d454896073b3939508f7a3959979f9f1fe6d7423c95612e3bc472ff87995caf6df73b533bbeabc4313955
Size (magic-wormhole-transit-relay-0.2.1.tar.gz) = 39621 bytes
SHA1 (patch-versioneer.py) = de9fbb5b1ca5340ec119f130e9de9f1713f62aa1

View File

@ -0,0 +1,18 @@
$NetBSD: patch-versioneer.py,v 1.1 2023/11/05 22:43:07 wiz Exp $
Fix build with Python 3.12.
--- versioneer.py.orig 2017-09-13 19:30:37.000000000 +0000
+++ versioneer.py
@@ -339,9 +339,9 @@ def get_config_from_root(root):
# configparser.NoOptionError (if it lacks "VCS="). See the docstring at
# the top of versioneer.py for instructions on writing your setup.cfg .
setup_cfg = os.path.join(root, "setup.cfg")
- parser = configparser.SafeConfigParser()
+ parser = configparser.ConfigParser()
with open(setup_cfg, "r") as f:
- parser.readfp(f)
+ parser.read_file(f)
VCS = parser.get("versioneer", "VCS") # mandatory
def get(parser, name):