Update mail/courier-auth* packages to 0.44.2 from the courier-0.44.2
source distribution. Changes from version 0.37.1 include fixing minor bugs, plugging memory leaks, and improving documentation. The authentication daemons also have improved behaviour when idling.
This commit is contained in:
parent
7844fee7eb
commit
627daeab62
16 changed files with 185 additions and 135 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: CHANGES,v 1.4940 2004/02/21 13:09:32 jmmv Exp $
|
||||
$NetBSD: CHANGES,v 1.4941 2004/02/21 14:43:18 jlam Exp $
|
||||
|
||||
Changes to the packages collection and infrastructure in 2004:
|
||||
|
||||
|
@ -955,3 +955,7 @@ Changes to the packages collection and infrastructure in 2004:
|
|||
Updated gqview to 1.4.0 [snj 2004-02-21]
|
||||
Removed gqview-devel [snj 2004-02-21]
|
||||
Updated pkg_comp to 1.17 [jmmv 2004-02-21]
|
||||
Updated courier-auth to 0.44.2 [jlam 2004-02-21]
|
||||
Updated courier-authldap to 0.44.2 [jlam 2004-02-21]
|
||||
Updated courier-authmysql to 0.44.2 [jlam 2004-02-21]
|
||||
Updated courier-authpgsql to 0.44.2 [jlam 2004-02-21]
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.11 2003/08/30 22:51:19 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.12 2004/02/21 14:43:15 jlam Exp $
|
||||
|
||||
PKGNAME= courier-auth-${BASE_VERS}
|
||||
PKGREVISION?= 1
|
||||
CATEGORIES= security
|
||||
COMMENT= Authentication modules for Courier mail packages
|
||||
|
||||
|
@ -10,19 +9,22 @@ CONFLICTS+= courier-imap-ldap-*
|
|||
|
||||
USE_PERL5= yes
|
||||
REPLACE_PERL= sysconftool
|
||||
|
||||
USE_PKGINSTALL= yes
|
||||
DEINSTALL_EXTRA_TMPL+= ${.CURDIR}/DEINSTALL
|
||||
INSTALL_EXTRA_TMPL+= ${.CURDIR}/INSTALL
|
||||
|
||||
.include "../../mail/courier-auth/Makefile.authdaemond"
|
||||
.include "../courier-auth/Makefile.authdaemond"
|
||||
|
||||
.if defined(_STRIPFLAG_INSTALL) && !empty(_STRIPFLAG_INSTALL:M-s)
|
||||
INSTALL_TARGET= install-strip
|
||||
.endif
|
||||
INSTALL_DIRS= ${WRKSRC}/makedat ${WRKSRC}/userdb ${WRKSRC}/authlib
|
||||
|
||||
GEN_FILES= authdaemonrc
|
||||
OWN_DIRS_PERMS= /var/authdaemon ${ROOT_USER} ${ROOT_GROUP} 700
|
||||
FILES_SUBST+= GEN_FILES=${GEN_FILES:Q}
|
||||
|
||||
OWN_DIRS_PERMS= /var/authdaemon ${ROOT_USER} ${ROOT_GROUP} 700
|
||||
CONF_FILES_PERMS= # empty
|
||||
.for FILE in ${GEN_FILES}
|
||||
CONF_FILES_PERMS+= ${EGDIR}/${FILE}.dist ${PKG_SYSCONFDIR}/${FILE} \
|
||||
|
@ -30,14 +32,10 @@ CONF_FILES_PERMS+= ${EGDIR}/${FILE}.dist ${PKG_SYSCONFDIR}/${FILE} \
|
|||
.endfor
|
||||
RCD_SCRIPTS= authdaemond
|
||||
|
||||
FILES_SUBST+= GEN_FILES=${GEN_FILES:Q}
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${EGDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/authlib/authdaemonrc \
|
||||
${EGDIR}/authdaemonrc.dist
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/sysconftool ${SYSCONFTOOL}
|
||||
for file in authdaemonrc.dist; do \
|
||||
${INSTALL_DATA} ${PKG_SYSCONFDIR}/$${file} ${EGDIR}; \
|
||||
${RM} -f ${PKG_SYSCONFDIR}/$${file}; \
|
||||
done
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,16 +1,31 @@
|
|||
# $NetBSD: Makefile.authdaemond,v 1.6 2004/02/10 02:22:50 jlam Exp $
|
||||
# $NetBSD: Makefile.authdaemond,v 1.7 2004/02/21 14:43:15 jlam Exp $
|
||||
|
||||
.include "../../mail/courier-auth/Makefile.common"
|
||||
.include "../courier-auth/Makefile.common"
|
||||
|
||||
PERL5_REQD+= 5.6.0
|
||||
USE_PERL5?= build
|
||||
|
||||
# These are files needed by the configure scripts or are needed by the
|
||||
# build process.
|
||||
#
|
||||
WRKSRC_FILES= config.guess config.sub configure \
|
||||
install-sh mkinstalldirs
|
||||
WRKSRC_FILES+= dbobj.h.in dbobj.config.in sysconftool
|
||||
install-sh mkinstalldirs \
|
||||
depcomp missing sysconftool
|
||||
|
||||
# These are the inputs for the files generated by the top-level configure
|
||||
# script.
|
||||
#
|
||||
WRKSRC_FILES+= Makefile.in courier.spec.in courier.sysvinit.in \
|
||||
dbobj.h.in dbobj.config.in courier/courier.c
|
||||
|
||||
# These are subdirectories of courier that build auxiliary libraries
|
||||
# used by the authentication daemon.
|
||||
#
|
||||
WRKSRC_SUBDIRS= afx bdbobj gdbmobj numlib soxwrap md5 sha1 \
|
||||
libhmac random128 unicode rfc822 rfc1035 \
|
||||
rfc2045 liblock
|
||||
|
||||
# These are the parts of courier that we will be building and installing.
|
||||
WRKSRC_SUBDIRS+= makedat userdb authlib
|
||||
|
||||
EXTRACT_ELEMENTS= ${WRKSRC_FILES:S/^/${DISTNAME}\//}
|
||||
|
@ -19,16 +34,21 @@ EXTRACT_ELEMENTS+= ${WRKSRC_SUBDIRS:S/^/${DISTNAME}\//}
|
|||
REPLACE_PERL= sysconftool
|
||||
SYSCONFTOOL= ${PREFIX}/sbin/authdaemon.sysconftool
|
||||
|
||||
DISTINFO_FILE= ${.CURDIR}/../../mail/courier-auth/distinfo
|
||||
PATCHDIR= ${.CURDIR}/../../mail/courier-auth/patches
|
||||
DISTINFO_FILE= ${.CURDIR}/../courier-auth/distinfo
|
||||
PATCHDIR= ${.CURDIR}/../courier-auth/patches
|
||||
|
||||
# The top-level configure script will call all of the other configure
|
||||
# scripts in the subdirectories, so we don't need to set CONFIGURE_DIRS.
|
||||
# However, we need to build in each subdirectory on our own.
|
||||
#
|
||||
BUILD_DIRS= ${WRKSRC_SUBDIRS:S/^/${WRKSRC}\//}
|
||||
|
||||
FILES_SUBST+= SYSCONFTOOL=${SYSCONFTOOL:Q}
|
||||
|
||||
.if ${OPSYS} == "SunOS"
|
||||
. include "../../databases/db/buildlink3.mk"
|
||||
.endif
|
||||
.if defined(USE_PAM)
|
||||
BUILD_DEFS+= USE_PAM
|
||||
. include "../../security/PAM/buildlink2.mk"
|
||||
. include "../../security/PAM/buildlink3.mk"
|
||||
.endif
|
||||
|
||||
pre-configure: configure-init
|
||||
|
|
|
@ -1,8 +1,9 @@
|
|||
# $NetBSD: Makefile.common,v 1.7 2004/01/24 13:55:30 grant Exp $
|
||||
# $NetBSD: Makefile.common,v 1.8 2004/02/21 14:43:15 jlam Exp $
|
||||
|
||||
DISTNAME?= courier-${DIST_VERS}
|
||||
CATEGORIES+= mail
|
||||
MASTER_SITES?= ${MASTER_SITE_SOURCEFORGE:=courier/}
|
||||
EXTRACT_SUFX?= .tar.bz2
|
||||
|
||||
MAINTAINER?= jlam@NetBSD.org
|
||||
HOMEPAGE?= http://www.courier-mta.org/
|
||||
|
@ -12,7 +13,7 @@ HOMEPAGE?= http://www.courier-mta.org/
|
|||
# DIST_VERS version number on the distfile
|
||||
# BASE_BERS pkgsrc-manged version number
|
||||
#
|
||||
DIST_VERS= 0.37.1
|
||||
DIST_VERS= 0.44.2
|
||||
BASE_VERS= ${DIST_VERS}
|
||||
|
||||
USE_GNU_TOOLS+= make
|
||||
|
@ -26,7 +27,8 @@ EGDIR= ${PREFIX}/share/examples/courier
|
|||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
USE_BUILDLINK2= yes
|
||||
USE_BUILDLINK3= yes
|
||||
USE_LANGUAGES= c c++
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --datadir=${DATADIR}
|
||||
CONFIGURE_ARGS+= --libexecdir=${LIBEXECDIR}
|
||||
|
@ -51,13 +53,5 @@ CONFIGURE_ARGS+= --without-authldap
|
|||
CONFIGURE_ARGS+= --without-authmysql
|
||||
CONFIGURE_ARGS+= --without-authpgsql
|
||||
|
||||
CONFIGURE_ENV+= EXPECT="${LOCALBASE}/bin/expect"
|
||||
|
||||
.if ${OPSYS} == "SunOS"
|
||||
. include "../../databases/db/buildlink2.mk"
|
||||
CPPFLAGS+= ${BUILDLINK_CPPFLAGS.db}
|
||||
.endif
|
||||
|
||||
configure-init:
|
||||
${MKDIR} ${WRKSRC}/courier
|
||||
${TOUCH} ${TOUCH_ARGS} ${WRKSRC}/courier/courier.c
|
||||
CONFIGURE_ENV+= EXPECT=${LOCALBASE}/bin/expect
|
||||
CONFIGURE_ENV+= PERL=${PERL5}
|
||||
|
|
|
@ -1,11 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.3 2002/01/27 23:45:27 jlam Exp $
|
||||
$NetBSD: distinfo,v 1.4 2004/02/21 14:43:15 jlam Exp $
|
||||
|
||||
SHA1 (courier-0.37.1.tar.gz) = d1649ef994e43484e9cd966d988c1493bfefde9e
|
||||
Size (courier-0.37.1.tar.gz) = 3225792 bytes
|
||||
SHA1 (patch-aa) = 74431dced835cbfb77b53fe611d5959b0a254040
|
||||
SHA1 (patch-ab) = 6a827912b852b094820d3d9625e3c56c6c253b31
|
||||
SHA1 (patch-ac) = b079eeca4116f3711dbcf17f46787fa1c80cfd02
|
||||
SHA1 (patch-ad) = 380713f0b934c5365c538a6f3be035ea7d3187ff
|
||||
SHA1 (patch-ae) = f65a59aeac7790e4fe76eab8bf4950f0dddc3cfb
|
||||
SHA1 (patch-af) = 40dd3a78214a28c455ffcc24ab437fffd099b9a0
|
||||
SHA1 (courier-0.44.2.tar.bz2) = 8ea25894c5b2cfe841171b47da8e33b24cdca56d
|
||||
Size (courier-0.44.2.tar.bz2) = 4001993 bytes
|
||||
SHA1 (patch-aa) = 5311880803120adac1f26166ab92ff5586efa2dc
|
||||
SHA1 (patch-ab) = 66f10721534bcbb147545ba05ab69d5c4e573b85
|
||||
SHA1 (patch-ac) = 630bf5f151607bb39e2e1db9b1c7660ce2b37d8f
|
||||
SHA1 (patch-ae) = 50fc5bbfda430c28171ab2527233f7d922536f8a
|
||||
SHA1 (patch-af) = 9606816c7035dde2db87634f678f6eb281555c61
|
||||
SHA1 (patch-ag) = b628ca5f8287e50db4e9f4131d67cb48e7a70697
|
||||
|
|
|
@ -1,14 +1,13 @@
|
|||
#!@RCD_SCRIPTS_SHELL@
|
||||
#
|
||||
# $NetBSD: authdaemond.sh,v 1.6 2002/09/20 02:01:56 grant Exp $
|
||||
# $NetBSD: authdaemond.sh,v 1.7 2004/02/21 14:43:15 jlam Exp $
|
||||
#
|
||||
# Courier user authentication daemon
|
||||
#
|
||||
# PROVIDE: authdaemond
|
||||
# REQUIRE: LOGIN
|
||||
|
||||
if [ -f /etc/rc.subr ]
|
||||
then
|
||||
if [ -f /etc/rc.subr ]; then
|
||||
. /etc/rc.subr
|
||||
fi
|
||||
|
||||
|
@ -27,8 +26,7 @@ stop_cmd="courier_doit stop"
|
|||
# We read the config file in a subprocess to protect against shell
|
||||
# environment pollution.
|
||||
#
|
||||
if [ -f @PKG_SYSCONFDIR@/authdaemonrc ]
|
||||
then
|
||||
if [ -f @PKG_SYSCONFDIR@/authdaemonrc ]; then
|
||||
command=`
|
||||
. @PKG_SYSCONFDIR@/authdaemonrc
|
||||
if [ -n "${version}" ]
|
||||
|
@ -51,11 +49,10 @@ courier_doit()
|
|||
@SETENV@ -i ${daemon} ${action}
|
||||
}
|
||||
|
||||
if [ -f /etc/rc.subr ]
|
||||
then
|
||||
if [ -f /etc/rc.subr ]; then
|
||||
load_rc_config $name
|
||||
run_rc_command "$1"
|
||||
else
|
||||
echo -n " ${name}"
|
||||
@ECHO@ -n " ${name}"
|
||||
${start_cmd}
|
||||
fi
|
||||
|
|
|
@ -1,12 +1,35 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2002/01/22 22:00:22 jlam Exp $
|
||||
$NetBSD: patch-aa,v 1.2 2004/02/21 14:43:16 jlam Exp $
|
||||
|
||||
--- authlib/Makefile.in.orig Fri Jan 18 22:04:42 2002
|
||||
--- authlib/Makefile.in.orig Sat Nov 15 12:54:45 2003
|
||||
+++ authlib/Makefile.in
|
||||
@@ -1823,6 +1823,30 @@
|
||||
$(MAKE) $(AM_MAKEFLAGS) all-recursive
|
||||
@@ -54,7 +54,7 @@ AUTHUSERDB = @AUTHUSERDB@
|
||||
AUTOCONF = @AUTOCONF@
|
||||
AUTOHEADER = @AUTOHEADER@
|
||||
|
||||
install-exec-am:
|
||||
+ for d in $(sbindir) $(libexecdir) $(libexecdir)/authlib; do $(mkinstalldirs) $(DESTDIR)$$d || exit 1; done
|
||||
-AUTOMAKE = srcdir=${srcdir} @SHELL@ ${srcdir}/../automake.fix @AUTOMAKE@
|
||||
+AUTOMAKE = @AUTOMAKE@
|
||||
AWK = @AWK@
|
||||
CC = @CC@
|
||||
CCDEPMODE = @CCDEPMODE@
|
||||
@@ -1281,7 +1281,7 @@ info-am:
|
||||
|
||||
install-data-am: install-data-local
|
||||
|
||||
-install-exec-am:
|
||||
+install-exec-am: install-exec-local
|
||||
|
||||
install-info: install-info-am
|
||||
|
||||
@@ -1489,9 +1489,36 @@ authinfodaemondlist.c: authdaemondstatic
|
||||
authdaemondstaticlist.c: config.status
|
||||
@SHELL@ $(srcdir)/mkmodulelist.sh @DAEMON_STATIC_LIST@ >authdaemondstaticlist.c
|
||||
|
||||
+# This target installs the authlib daemons and password programs and is
|
||||
+# largely copied from the install-exec-hook target in ../courier/Makefile.in.
|
||||
+#
|
||||
+install-exec-local:
|
||||
+ for d in $(sbindir) $(libexecdir) $(libexecdir)/authlib ; do \
|
||||
+ $(mkinstalldirs) $(DESTDIR)$$d || exit 1; done
|
||||
+ for f in `cat ../authlib/installlist`; do test -z "$$f" && continue; \
|
||||
+ test -f ../authlib/$$f || continue; \
|
||||
+ $(INSTALL_PROGRAM) $(INSTALL_STRIP_FLAG) ../authlib/$$f \
|
||||
|
@ -15,8 +38,6 @@ $NetBSD: patch-aa,v 1.1.1.1 2002/01/22 22:00:22 jlam Exp $
|
|||
+ test -f ../authlib/$$f || continue; \
|
||||
+ $(INSTALL_SCRIPT) ../authlib/$$f \
|
||||
+ $(DESTDIR)$(libexecdir)/authlib/$$f ; done
|
||||
+ for f in makeuserdb userdb pw2userdb vchkpw2userdb ; do rm -f $(DESTDIR)$(sbindir)/$$f ; \
|
||||
+ $(LN_S) $(datadir)/$$f $(DESTDIR)$(sbindir)/$$f ; done
|
||||
+ $(mkinstalldirs) $(DESTDIR)@authchangepwdir@
|
||||
+ . ../authlib/authpwdprogs ; for f in `echo $$PWPROGS dummy` ; do \
|
||||
+ test "$$f" = "dummy" && continue ; \
|
||||
|
@ -30,10 +51,14 @@ $NetBSD: patch-aa,v 1.1.1.1 2002/01/22 22:00:22 jlam Exp $
|
|||
+ $(LN_S) $(datadir)/$$f \
|
||||
+ $(DESTDIR)@authchangepwdir@/$$f ; done
|
||||
+
|
||||
install-exec: install-exec-am
|
||||
# automake still a bit stupid...
|
||||
|
||||
install-data-am: install-man install-data-local
|
||||
@@ -2068,7 +2092,6 @@
|
||||
-install-data-local: install-authldaprc install-authdaemonrc install-authmysqlrc install-authpgsqlrc
|
||||
+install-data-local: install-authldaprc install-authmysqlrc install-authpgsqlrc
|
||||
test "$(man_LINKS)" = "" && exit 0; \
|
||||
$(mkinstalldirs) $(DESTDIR)$(man7dir) ; \
|
||||
for f in $(man_MANS) "" ; do \
|
||||
@@ -1501,7 +1528,6 @@ install-data-local: install-authldaprc i
|
||||
for f in $(man_LINKS) "" ; do \
|
||||
test "$$f" = "" && continue ; \
|
||||
rm -f $$f; $(LN_S) authlib.7 $$f ; \
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ab,v 1.2 2002/01/27 23:45:28 jlam Exp $
|
||||
$NetBSD: patch-ab,v 1.3 2004/02/21 14:43:16 jlam Exp $
|
||||
|
||||
--- authlib/configure.in.orig Thu Dec 27 17:26:43 2001
|
||||
--- authlib/configure.in.orig Sat Oct 25 06:25:28 2003
|
||||
+++ authlib/configure.in
|
||||
@@ -411,8 +411,6 @@
|
||||
@@ -415,8 +415,6 @@ then
|
||||
STATIC_LIST="authldap_info $STATIC_LIST"
|
||||
LIBAUTH="$LIBAUTH libauth-authldap.a"
|
||||
echo authldaprc.dist >>authconfiglist
|
||||
|
@ -11,7 +11,7 @@ $NetBSD: patch-ab,v 1.2 2002/01/27 23:45:28 jlam Exp $
|
|||
fi
|
||||
AC_SUBST(LDAPLIBS)
|
||||
|
||||
@@ -670,7 +668,7 @@
|
||||
@@ -699,7 +697,7 @@ AC_PATH_PROGS(MYSQL_CONFIG, mysql_config
|
||||
if test -x "$MYSQL_CONFIG"
|
||||
then
|
||||
MYSQL_CFLAGS="`$MYSQL_CONFIG --cflags`"
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ac,v 1.2 2002/01/27 23:45:28 jlam Exp $
|
||||
$NetBSD: patch-ac,v 1.3 2004/02/21 14:43:16 jlam Exp $
|
||||
|
||||
--- authlib/configure.orig Thu Dec 27 17:27:05 2001
|
||||
--- authlib/configure.orig Sat Nov 15 12:13:24 2003
|
||||
+++ authlib/configure
|
||||
@@ -2689,8 +2689,6 @@
|
||||
@@ -5539,8 +5539,6 @@ then
|
||||
STATIC_LIST="authldap_info $STATIC_LIST"
|
||||
LIBAUTH="$LIBAUTH libauth-authldap.a"
|
||||
echo authldaprc.dist >>authconfiglist
|
||||
|
@ -11,7 +11,7 @@ $NetBSD: patch-ac,v 1.2 2002/01/27 23:45:28 jlam Exp $
|
|||
fi
|
||||
|
||||
|
||||
@@ -3560,7 +3558,7 @@
|
||||
@@ -6793,7 +6791,7 @@ test -n "$MYSQL_CONFIG" || MYSQL_CONFIG=
|
||||
if test -x "$MYSQL_CONFIG"
|
||||
then
|
||||
MYSQL_CFLAGS="`$MYSQL_CONFIG --cflags`"
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.1.1.1 2002/01/22 22:00:22 jlam Exp $
|
||||
|
||||
--- authlib/cryptpassword.c.orig Wed Jun 20 21:44:30 2001
|
||||
+++ authlib/cryptpassword.c
|
||||
@@ -6,6 +6,7 @@
|
||||
#if HAVE_CONFIG_H
|
||||
#include "config.h"
|
||||
#endif
|
||||
+#include <stdlib.h>
|
||||
#include <string.h>
|
||||
#if HAVE_UNISTD_H
|
||||
#include <unistd.h>
|
|
@ -1,15 +1,25 @@
|
|||
$NetBSD: patch-ae,v 1.1.1.1 2002/01/22 22:00:22 jlam Exp $
|
||||
$NetBSD: patch-ae,v 1.2 2004/02/21 14:43:16 jlam Exp $
|
||||
|
||||
--- makedat/Makefile.in.orig Fri Jan 18 22:04:44 2002
|
||||
--- makedat/Makefile.in.orig Sat Nov 15 12:54:52 2003
|
||||
+++ makedat/Makefile.in
|
||||
@@ -281,6 +281,10 @@
|
||||
$(MAKE) $(AM_MAKEFLAGS) all-recursive
|
||||
@@ -413,6 +413,11 @@ uninstall: uninstall-am
|
||||
install-am: all-am
|
||||
@$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
|
||||
|
||||
install-exec-am:
|
||||
+ $(mkinstalldirs) $(DESTDIR)$(libexecdir)
|
||||
+ rm -f $(DESTDIR)$(libexecdir)/makedatprog
|
||||
+ $(INSTALL_PROGRAM) makedatprog $(DESTDIR)$(libexecdir)/makedatprog
|
||||
+install-exec-local:
|
||||
+ $(mkinstalldirs) $(DESTDIR)`dirname $(makedatprogpath)`
|
||||
+ rm -f $(DESTDIR)$(makedatprogpath)
|
||||
+ $(INSTALL_PROGRAM) makedatprog $(DESTDIR)$(makedatprogpath)
|
||||
+
|
||||
install-exec: install-exec-am
|
||||
installcheck: installcheck-am
|
||||
install-strip:
|
||||
$(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
|
||||
@@ -450,7 +455,7 @@ info-am:
|
||||
|
||||
install-data-am:
|
||||
|
||||
-install-exec-am:
|
||||
+install-exec-am: install-exec-local
|
||||
|
||||
install-info: install-info-am
|
||||
|
||||
|
|
|
@ -1,26 +1,25 @@
|
|||
$NetBSD: patch-af,v 1.1.1.1 2002/01/22 22:00:22 jlam Exp $
|
||||
$NetBSD: patch-af,v 1.2 2004/02/21 14:43:16 jlam Exp $
|
||||
|
||||
--- userdb/Makefile.in.orig Fri Jan 18 22:04:41 2002
|
||||
--- userdb/Makefile.in.orig Sat Nov 15 12:54:43 2003
|
||||
+++ userdb/Makefile.in
|
||||
@@ -332,9 +332,31 @@
|
||||
$(MAKE) $(AM_MAKEFLAGS) all-recursive
|
||||
@@ -462,6 +462,30 @@ uninstall: uninstall-am
|
||||
install-am: all-am
|
||||
@$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
|
||||
|
||||
install-exec-am:
|
||||
+install-exec-local:
|
||||
+ $(mkinstalldirs) $(DESTDIR)$(sbindir)
|
||||
+ $(INSTALL_PROGRAM) userdbpw $(DESTDIR)$(sbindir)/userdbpw
|
||||
+ $(mkinstalldirs) $(DESTDIR)$(datadir)
|
||||
+ cp userdb.pl userdb
|
||||
+ for f in makeuserdb userdb pw2userdb vchkpw2userdb; do \
|
||||
+ $(INSTALL_SCRIPT) $$f $(DESTDIR)$(datadir)/$$f; \
|
||||
+ rm -f $(DESTDIR)$(sbindir)/$$f; \
|
||||
+ $(LN_S) $(datadir)/$$f $(DESTDIR)$(sbindir)/$$f; \
|
||||
+ $(INSTALL_SCRIPT) $$f $(DESTDIR)$(datadir)/$$f; \
|
||||
+ rm -f $(DESTDIR)$(sbindir)/$$f; \
|
||||
+ $(LN_S) $(datadir)/$$f $(DESTDIR)$(sbindir)/$$f; \
|
||||
+ done
|
||||
+
|
||||
install-exec: install-exec-am
|
||||
|
||||
+man8dir = @mandir@/man8
|
||||
+man8dir=@mandir@/man8
|
||||
+
|
||||
install-data-am:
|
||||
+install-data-local:
|
||||
+ $(mkinstalldirs) $(DESTDIR)$(man8dir)
|
||||
+ for i in $(man8); do \
|
||||
+ echo " $(INSTALL_DATA) $$i $(DESTDIR)$(man8dir)/$$i"; \
|
||||
|
@ -29,8 +28,20 @@ $NetBSD: patch-af,v 1.1.1.1 2002/01/22 22:00:22 jlam Exp $
|
|||
+ cd $(DESTDIR)$(man8dir) ; \
|
||||
+ rm -f pw2userdb.8 vchkpw2userdb.8; \
|
||||
+ $(LN_S) makeuserdb.8 pw2userdb.8 ; \
|
||||
+ $(LN_S) makeuserdb.8 vchkpw2userdb.8 ; \
|
||||
+ $(LN_S) makeuserdb.8 vchkpw2userdb.8
|
||||
+
|
||||
install-data: install-data-am
|
||||
installcheck: installcheck-am
|
||||
install-strip:
|
||||
$(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
|
||||
@@ -500,9 +524,9 @@ info: info-am
|
||||
|
||||
info-am:
|
||||
|
||||
-install-data-am:
|
||||
+install-data-am: install-data-local
|
||||
|
||||
-install-exec-am:
|
||||
+install-exec-am: install-exec-local
|
||||
|
||||
install-info: install-info-am
|
||||
|
||||
install-am: all-am
|
||||
|
|
|
@ -1,32 +1,34 @@
|
|||
# $NetBSD: Makefile,v 1.7 2003/05/05 16:39:18 jmmv Exp $
|
||||
# $NetBSD: Makefile,v 1.8 2004/02/21 14:43:16 jlam Exp $
|
||||
|
||||
PKGNAME= courier-authldap-${BASE_VERS}
|
||||
PKGREVISION?= 1
|
||||
COMMENT= Courier LDAP authentication module
|
||||
PKGNAME= courier-authldap-${BASE_VERS}
|
||||
COMMENT= Courier LDAP authentication module
|
||||
|
||||
CONFLICTS= courier-imap-ldap-[0-9]*
|
||||
CONFLICTS= courier-imap-ldap-[0-9]*
|
||||
|
||||
DEPENDS+= courier-auth>=${BASE_VERS}:../../mail/courier-auth
|
||||
DEPENDS+= courier-auth-${BASE_VERS}{,nb*}:../../mail/courier-auth
|
||||
|
||||
.include "../../mail/courier-auth/Makefile.authdaemond"
|
||||
.include "../courier-auth/Makefile.authdaemond"
|
||||
|
||||
USE_PKGINSTALL= yes
|
||||
INSTALL_EXTRA_TMPL= ${.CURDIR}/../../mail/courier-auth/INSTALL
|
||||
|
||||
CONFIGURE_ARGS+= --with-authldap
|
||||
|
||||
GEN_FILES= authldaprc
|
||||
FILES_SUBST+= GEN_FILES=${GEN_FILES:Q}
|
||||
|
||||
CONF_FILES_PERMS= # empty
|
||||
.for FILE in ${GEN_FILES}
|
||||
CONF_FILES_PERMS+= ${EGDIR}/${FILE}.dist ${PKG_SYSCONFDIR}/${FILE} \
|
||||
${ROOT_USER} ${ROOT_GROUP} 0600
|
||||
.endfor
|
||||
|
||||
FILES_SUBST+= GEN_FILES=${GEN_FILES:Q}
|
||||
INSTALL_EXTRA_TMPL= ${.CURDIR}/../../mail/courier-auth/INSTALL
|
||||
.include "../../databases/openldap/buildlink3.mk"
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/authlib/authdaemond.ldap ${AUTHLIBDIR}
|
||||
${INSTALL_MAN} ${WRKSRC}/authlib/README.ldap ${DOCDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/authlib/authldap.schema ${EGDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/authlib/authldaprc ${EGDIR}/authldaprc.dist
|
||||
|
||||
.include "../../databases/openldap/buildlink2.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,4 +1,5 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2002/01/27 20:52:20 jlam Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2004/02/21 14:43:16 jlam Exp $
|
||||
libexec/courier/authlib/authdaemond.ldap
|
||||
share/doc/courier/README.ldap
|
||||
share/examples/courier/authldap.schema
|
||||
share/examples/courier/authldaprc.dist
|
||||
|
|
|
@ -1,26 +1,27 @@
|
|||
# $NetBSD: Makefile,v 1.4 2003/01/28 22:03:29 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.5 2004/02/21 14:43:16 jlam Exp $
|
||||
|
||||
PKGNAME= courier-authmysql-${BASE_VERS}
|
||||
PKGREVISION?= # empty
|
||||
COMMENT= Courier MySQL authentication module
|
||||
PKGNAME= courier-authmysql-${BASE_VERS}
|
||||
COMMENT= Courier MySQL authentication module
|
||||
|
||||
DEPENDS+= courier-auth>=${BASE_VERS}:../../mail/courier-auth
|
||||
DEPENDS+= courier-auth-${BASE_VERS}{,nb*}:../../mail/courier-auth
|
||||
|
||||
.include "../../mail/courier-auth/Makefile.authdaemond"
|
||||
.include "../courier-auth/Makefile.authdaemond"
|
||||
|
||||
USE_PKGINSTALL= yes
|
||||
INSTALL_EXTRA_TMPL= ${.CURDIR}/../courier-auth/INSTALL
|
||||
|
||||
CONFIGURE_ARGS+= --with-authmysql
|
||||
LDFLAGS+= ${BUILDLINK_LDFLAGS.mysql-client}
|
||||
|
||||
GEN_FILES= authmysqlrc
|
||||
FILES_SUBST+= GEN_FILES=${GEN_FILES:Q}
|
||||
|
||||
CONF_FILES_PERMS= # empty
|
||||
.for FILE in ${GEN_FILES}
|
||||
CONF_FILES_PERMS+= ${EGDIR}/${FILE}.dist ${PKG_SYSCONFDIR}/${FILE} \
|
||||
${ROOT_USER} ${ROOT_GROUP} 0600
|
||||
.endfor
|
||||
|
||||
INSTALL_EXTRA_TMPL= ${.CURDIR}/../../mail/courier-auth/INSTALL
|
||||
FILES_SUBST+= GEN_FILES=${GEN_FILES:Q}
|
||||
.include "../../databases/mysql-client/buildlink3.mk"
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/authlib/authdaemond.mysql ${AUTHLIBDIR}
|
||||
|
@ -29,5 +30,4 @@ do-install:
|
|||
${INSTALL_DATA} ${WRKSRC}/authlib/README.authmysql.html \
|
||||
${PREFIX}/share/doc/html/courier
|
||||
|
||||
.include "../../databases/mysql-client/buildlink2.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,27 +1,29 @@
|
|||
# $NetBSD: Makefile,v 1.5 2003/01/28 22:03:29 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.6 2004/02/21 14:43:16 jlam Exp $
|
||||
|
||||
PKGNAME= courier-authpgsql-${BASE_VERS}
|
||||
PKGREVISION= 1
|
||||
COMMENT= Courier PostgreSQL authentication module
|
||||
PKGNAME= courier-authpgsql-${BASE_VERS}
|
||||
COMMENT= Courier PostgreSQL authentication module
|
||||
|
||||
DEPENDS+= courier-auth>=${BASE_VERS}:../../mail/courier-auth
|
||||
DEPENDS+= courier-auth-${BASE_VERS}{,nb*}:../../mail/courier-auth
|
||||
|
||||
.include "../../mail/courier-auth/Makefile.authdaemond"
|
||||
.include "../courier-auth/Makefile.authdaemond"
|
||||
|
||||
USE_PKGINSTALL= yes
|
||||
INSTALL_EXTRA_TMPL= ${.CURDIR}/../courier-auth/INSTALL
|
||||
|
||||
CONFIGURE_ARGS+= --with-authpgsql
|
||||
CONFIGURE_ARGS+= --with-pgsql-includes=${BUILDLINK_PREFIX.postgresql-lib}/include/postgresql
|
||||
CONFIGURE_ARGS+= --with-pgsql-libs=${BUILDLINK_PREFIX.postgresql-lib}/lib
|
||||
|
||||
GEN_FILES= authpgsqlrc
|
||||
FILES_SUBST+= GEN_FILES=${GEN_FILES:Q}
|
||||
|
||||
CONF_FILES_PERMS= # empty
|
||||
.for FILE in ${GEN_FILES}
|
||||
CONF_FILES_PERMS+= ${EGDIR}/${FILE}.dist ${PKG_SYSCONFDIR}/${FILE} \
|
||||
${ROOT_USER} ${ROOT_GROUP} 0600
|
||||
.endfor
|
||||
|
||||
INSTALL_EXTRA_TMPL= ${.CURDIR}/../../mail/courier-auth/INSTALL
|
||||
FILES_SUBST+= GEN_FILES=${GEN_FILES:Q}
|
||||
.include "../../databases/postgresql-lib/buildlink3.mk"
|
||||
|
||||
post-build:
|
||||
cd ${WRKSRC}/authlib; \
|
||||
|
@ -37,5 +39,4 @@ do-install:
|
|||
${INSTALL_DATA} ${WRKSRC}/authlib/README.authpgsql.html \
|
||||
${PREFIX}/share/doc/html/courier
|
||||
|
||||
.include "../../databases/postgresql-lib/buildlink2.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
Loading…
Reference in a new issue