Update py-flask-flatpages to 0.6.

Version 0.6
~~~~~~~~~~~

Released on 2015-02-09

* Python 3 support.
* Allow multiple file extensions for FlatPages.
* The renderer function now optionally takes a third argument, namely
  the :class:`Page` instance.
* It is now possible to instantiate multiple instances of :class:`FlatPages`
  with different configurations. This is done by specifying an additional
  parameter ``name`` to the initializer and adding the same name in uppercase
  to the respective Flask configuration settings.
This commit is contained in:
kleink 2015-03-02 13:37:17 +00:00
parent 07c6b34f5c
commit 62bc7166fc
4 changed files with 22 additions and 34 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.4 2014/12/31 13:57:32 wiz Exp $
# $NetBSD: Makefile,v 1.5 2015/03/02 13:37:17 kleink Exp $
DISTNAME= Flask-FlatPages-0.5
DISTNAME= Flask-FlatPages-0.6
PKGNAME= ${PYPKGPREFIX}-${DISTNAME:tl}
CATEGORIES= www python
MASTER_SITES= http://pypi.python.org/packages/source/F/Flask-FlatPages/

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.2 2013/04/01 16:52:47 kleink Exp $
@comment $NetBSD: PLIST,v 1.3 2015/03/02 13:37:17 kleink Exp $
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
@ -8,14 +8,18 @@ ${PYSITELIB}/${EGG_INFODIR}/top_level.txt
${PYSITELIB}/flask_flatpages/__init__.py
${PYSITELIB}/flask_flatpages/__init__.pyc
${PYSITELIB}/flask_flatpages/__init__.pyo
${PYSITELIB}/flask_flatpages/pages/foo.html
${PYSITELIB}/flask_flatpages/pages/foo/42/not_a_page.txt
${PYSITELIB}/flask_flatpages/pages/foo/bar.html
${PYSITELIB}/flask_flatpages/pages/foo/lorem/ipsum.html
${PYSITELIB}/flask_flatpages/pages/headerid.html
${PYSITELIB}/flask_flatpages/pages/hello.html
${PYSITELIB}/flask_flatpages/pages/not_a_page.txt
${PYSITELIB}/flask_flatpages/pages_shift_jis/hello.html
${PYSITELIB}/flask_flatpages/tests.py
${PYSITELIB}/flask_flatpages/tests.pyc
${PYSITELIB}/flask_flatpages/tests.pyo
${PYSITELIB}/flask_flatpages/compat.py
${PYSITELIB}/flask_flatpages/compat.pyc
${PYSITELIB}/flask_flatpages/compat.pyo
${PYSITELIB}/flask_flatpages/flatpages.py
${PYSITELIB}/flask_flatpages/flatpages.pyc
${PYSITELIB}/flask_flatpages/flatpages.pyo
${PYSITELIB}/flask_flatpages/imports.py
${PYSITELIB}/flask_flatpages/imports.pyc
${PYSITELIB}/flask_flatpages/imports.pyo
${PYSITELIB}/flask_flatpages/page.py
${PYSITELIB}/flask_flatpages/page.pyc
${PYSITELIB}/flask_flatpages/page.pyo
${PYSITELIB}/flask_flatpages/utils.py
${PYSITELIB}/flask_flatpages/utils.pyc
${PYSITELIB}/flask_flatpages/utils.pyo

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.4 2014/01/19 17:42:04 wiz Exp $
$NetBSD: distinfo,v 1.5 2015/03/02 13:37:17 kleink Exp $
SHA1 (Flask-FlatPages-0.5.tar.gz) = 08f05c88841fd1f682906a47760b40a798283c21
RMD160 (Flask-FlatPages-0.5.tar.gz) = 1ec36be8a08c7c97f473a623d2b5926f308b6927
Size (Flask-FlatPages-0.5.tar.gz) = 20949 bytes
SHA1 (patch-flask__flatpages_____init____.py) = 31209f4274ee6baf92e66829ba178f925f520541
SHA1 (Flask-FlatPages-0.6.tar.gz) = 68e6d00d094a4009804d43c77b16cd2546d9018e
RMD160 (Flask-FlatPages-0.6.tar.gz) = 73c9d210d72f8542c236f937ef63587321965521
Size (Flask-FlatPages-0.6.tar.gz) = 22536 bytes

View file

@ -1,15 +0,0 @@
$NetBSD: patch-flask__flatpages_____init____.py,v 1.1 2014/01/19 17:42:05 wiz Exp $
Remove undefined characters; fixes build with python-3.3.
--- flask_flatpages/__init__.py.orig 2013-04-02 09:52:15.000000000 +0000
+++ flask_flatpages/__init__.py
@@ -4,7 +4,7 @@
~~~~~~~~~~~~~~~
Flask-FlatPages provides a collections of pages to your Flask application.
- Pages are built from flat text files as opposed to a relational database.
+ Pages are built from flat text files as opposed to a relational database.
:copyright: (c) 2010 by Simon Sapin.
:license: BSD, see LICENSE for more details.