Initial import of ubs-0.17 from pkgsrc-wip.
The Uninterrupted Broadcasting System (UBS) is a program designed to run the operations of a radio station when a DJ isn't in house. This includes playing station ID's, public service announcements, and songs. This program is similar in function (but not design nor implementation) to DRS 2006. The UBS was not intended to be used for webcasting, but it could presumably be adapted for this purpose. The intented audience of the UBS is smaller college/high school/commercial radio stations which wish to do unattended broadcasting via a stable and reliable computer daemon.
This commit is contained in:
parent
13f258f4bf
commit
62c22f34a3
7 changed files with 148 additions and 0 deletions
9
audio/ubs/DESCR
Normal file
9
audio/ubs/DESCR
Normal file
|
@ -0,0 +1,9 @@
|
|||
The Uninterrupted Broadcasting System (UBS) is a program designed to run the
|
||||
operations of a radio station when a DJ isn't in house. This includes playing
|
||||
station ID's, public service announcements, and songs. This program is
|
||||
similar in function (but not design nor implementation) to DRS 2006.
|
||||
|
||||
The UBS was not intended to be used for webcasting, but it could presumably
|
||||
be adapted for this purpose. The intented audience of the UBS is smaller
|
||||
college/high school/commercial radio stations which wish to do unattended
|
||||
broadcasting via a stable and reliable computer daemon.
|
52
audio/ubs/Makefile
Normal file
52
audio/ubs/Makefile
Normal file
|
@ -0,0 +1,52 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2004/04/05 11:46:11 xtraeme Exp $
|
||||
#
|
||||
|
||||
DISTNAME= ubs-0.17
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://aboleo.net/software/ubs/downloads/
|
||||
|
||||
MAINTAINER= xtraeme@NetBSD.org
|
||||
HOMEPAGE= http://aboleo.net/software/ubs/
|
||||
COMMENT= Uninterrupted Broadcasting System
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_BUILDLINK3= yes
|
||||
USE_PKGINSTALL= yes
|
||||
|
||||
RCD_SCRIPTS= ubs
|
||||
PKG_SYSCONFSUBDIR= ubs
|
||||
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR}
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
BUILD_DEFS+= UBS_BASEDIR UBS_USER UBS_GROUP
|
||||
|
||||
UBS_BASEDIR?= /var/spool/ubs
|
||||
UBS_USER?= ubs
|
||||
UBS_GROUP?= ubs
|
||||
|
||||
PKG_GROUPS= ${UBS_GROUP}
|
||||
PKG_USERS= ${UBS_USER}:${UBS_GROUP}
|
||||
FILES_SUBST+= PREFIX="${PREFIX}"
|
||||
FILES_SUBST+= UBS_USER="${UBS_USER}"
|
||||
FILES_SUBST+= UBS_GROUP="${UBS_GROUP}"
|
||||
|
||||
OWN_DIRS_PERMS= ${UBS_BASEDIR} ${UBS_USER} ${UBS_GROUP} 0750
|
||||
OWN_DIRS_PERMS+= ${UBS_BASEDIR}/var ${UBS_USER} ${UBS_GROUP} 0750
|
||||
OWN_DIRS_PERMS+= ${UBS_BASEDIR}/log ${UBS_USER} ${UBS_GROUP} 0750
|
||||
|
||||
EGDIR= ${PREFIX}/share/examples/ubs
|
||||
CONF_FILES= ${EGDIR}/help.conf ${PKG_SYSCONFDIR}/help.conf
|
||||
CONF_FILES+= ${EGDIR}/ubs.conf.default ${PKG_SYSCONFDIR}/ubs.conf
|
||||
|
||||
post-extract:
|
||||
@${MV} ${WRKSRC}/config/ubs.conf.default \
|
||||
${WRKSRC}/config/ubs.conf.default.in
|
||||
|
||||
pre-configure:
|
||||
@${SED} -e "s,@UBS_BASEDIR@,${UBS_BASEDIR},g" \
|
||||
${WRKSRC}/config/ubs.conf.default.in > \
|
||||
${WRKSRC}/config/ubs.conf.default
|
||||
|
||||
.include "../../audio/libvorbis/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
15
audio/ubs/PLIST
Normal file
15
audio/ubs/PLIST
Normal file
|
@ -0,0 +1,15 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2004/04/05 11:46:11 xtraeme Exp $
|
||||
bin/ubs
|
||||
bin/ubs-event
|
||||
bin/ubs-play
|
||||
bin/ubs-sched
|
||||
include/defaults.h
|
||||
include/ubs-event.h
|
||||
include/ubs-main.h
|
||||
include/ubs-play.h
|
||||
include/ubs-sched.h
|
||||
include/ubs.h
|
||||
lib/libubs.a
|
||||
share/examples/ubs/help.conf
|
||||
share/examples/ubs/ubs.conf.default
|
||||
@dirrm share/examples/ubs
|
6
audio/ubs/distinfo
Normal file
6
audio/ubs/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2004/04/05 11:46:11 xtraeme Exp $
|
||||
|
||||
SHA1 (ubs-0.17.tar.gz) = f0f67d437e4c5c7026b2f05d1aaff53688eb3253
|
||||
Size (ubs-0.17.tar.gz) = 372222 bytes
|
||||
SHA1 (patch-aa) = 4a5690fa3e7a8dc1dc50329bf844199575a09319
|
||||
SHA1 (patch-ab) = 88d06fca850e7bf2d38ad587021e4352c96cc89b
|
19
audio/ubs/files/ubs.sh
Executable file
19
audio/ubs/files/ubs.sh
Executable file
|
@ -0,0 +1,19 @@
|
|||
#!@RCD_SCRIPTS_SHELL@
|
||||
#
|
||||
# $NetBSD: ubs.sh,v 1.1.1.1 2004/04/05 11:46:11 xtraeme Exp $
|
||||
#
|
||||
|
||||
# PROVIDE: ubs
|
||||
# REQUIRE: DAEMON LOGIN
|
||||
|
||||
. /etc/rc.subr
|
||||
|
||||
name="ubs"
|
||||
rcvar=$name
|
||||
command="@PREFIX@/bin/${name}"
|
||||
required_files="@PKG_SYSCONFDIR@/ubs.conf"
|
||||
ubs_user="@UBS_USER@"
|
||||
ubs_group="@UBS_GROUP@"
|
||||
|
||||
load_rc_config $name
|
||||
run_rc_command "$1"
|
22
audio/ubs/patches/patch-aa
Normal file
22
audio/ubs/patches/patch-aa
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2004/04/05 11:46:11 xtraeme Exp $
|
||||
|
||||
--- Makefile.in.orig 2003-10-31 05:49:58.000000000 +0100
|
||||
+++ Makefile.in 2003-10-31 05:50:52.000000000 +0100
|
||||
@@ -517,14 +517,11 @@
|
||||
|
||||
|
||||
install-data-local:
|
||||
- $(mkinstalldirs) $(prefix)/etc
|
||||
$(mkinstalldirs) $(prefix)/include
|
||||
- $(mkinstalldirs) $(prefix)/log
|
||||
- $(mkinstalldirs) $(prefix)/tmp
|
||||
- $(mkinstalldirs) $(prefix)/var
|
||||
+ $(mkinstalldirs) $(datadir)/examples/ubs
|
||||
|
||||
- $(INSTALL_DATA) config/help.conf $(prefix)/etc
|
||||
- $(INSTALL_DATA) config/ubs.conf.default $(prefix)/etc
|
||||
+ $(INSTALL_DATA) config/help.conf $(datadir)/examples/ubs
|
||||
+ $(INSTALL_DATA) config/ubs.conf.default $(datadir)/examples/ubs
|
||||
|
||||
$(INSTALL_DATA) include/*.h $(prefix)/include
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
25
audio/ubs/patches/patch-ab
Normal file
25
audio/ubs/patches/patch-ab
Normal file
|
@ -0,0 +1,25 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2004/04/05 11:46:11 xtraeme Exp $
|
||||
|
||||
--- config/ubs.conf.default.in.orig 2003-10-31 06:22:19.000000000 +0100
|
||||
+++ config/ubs.conf.default.in 2003-10-31 06:22:44.000000000 +0100
|
||||
@@ -22,16 +22,16 @@
|
||||
## These settings are parsed by all UBS daemons
|
||||
|
||||
# Where the UBS filetree is located
|
||||
-# global.prefix = "/usr/local/ubs"
|
||||
+global.prefix = "@UBS_BASEDIR@"
|
||||
|
||||
# The default location to queue to
|
||||
-# global.queue = "var/queue"
|
||||
+global.queue = "var/queue"
|
||||
|
||||
# Location of the error log
|
||||
-# global.errorlog = "log/error.log"
|
||||
+global.errorlog = "log/error.log"
|
||||
|
||||
# Location of the playlist log
|
||||
-# global.songlog = "log/playlist.log"
|
||||
+global.songlog = "log/playlist.log"
|
||||
|
||||
# Amount of information to put in the UBS logs. The scale is:
|
||||
# 0 -> Emergency information only
|
Loading…
Reference in a new issue