Testing for a working C++ compiler is more likely to succeed, if the

test program is valid C++.
This commit is contained in:
joerg 2012-05-04 16:12:30 +00:00
parent 39d27527e7
commit 62d67c9b75
3 changed files with 29 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.8 2006/06/17 18:17:29 rillig Exp $
$NetBSD: distinfo,v 1.9 2012/05/04 16:12:30 joerg Exp $
SHA1 (abuse_pd.tgz) = 52a703abea31d6f00937d4cc0160af7a454e6630
RMD160 (abuse_pd.tgz) = 0f69cc38d422fcbf72a36d42433221701a120dfb
@ -8,6 +8,7 @@ RMD160 (abuse_data.tar.gz) = af33d0423b596ae4bb07b5a844fe352aec09b4a0
Size (abuse_data.tar.gz) = 1593160 bytes
SHA1 (patch-aa) = d60ffe9f3039c82093e0208a2f592e436a9aee8a
SHA1 (patch-ab) = 11a75d6265df1ee167ea72e6d3c4202da8615928
SHA1 (patch-abuse_configure) = 22292157b36c26820dd38a13e4458517c1b72889
SHA1 (patch-ac) = b30031db9a89d7bf7c025674e549b08d637a89ff
SHA1 (patch-ad) = 9003fe5ddd04be69c1d40b96ba995f453429ccb8
SHA1 (patch-ae) = 3720352c2b73ed62e943d3c271a8e6c1f7f896d1
@ -21,3 +22,4 @@ SHA1 (patch-al) = 657bb4544d5cabd8df3c2af1943bc72a855566f3
SHA1 (patch-am) = 6520c422349f3c0d2bad4d861dc391abda734ae2
SHA1 (patch-an) = 35c22e102679e7fa6742762a4acc1a33c877be8d
SHA1 (patch-ao) = 5227d54b5d1b431265e57469c80f4269ca167b8e
SHA1 (patch-imlib_configure) = 89549c1f7dbb81c9eb8dca0ae920f6e73408f982

View file

@ -0,0 +1,13 @@
$NetBSD: patch-abuse_configure,v 1.1 2012/05/04 16:12:30 joerg Exp $
--- abuse/configure.orig 2012-05-04 14:21:54.000000000 +0000
+++ abuse/configure
@@ -1036,7 +1036,7 @@ cross_compiling=$ac_cv_prog_cxx_cross
cat > conftest.$ac_ext <<EOF
#line 1038 "configure"
#include "confdefs.h"
-main(){return(0);}
+int main(){return(0);}
EOF
if { (eval echo configure:1042: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest; then
ac_cv_prog_cxx_works=yes

View file

@ -0,0 +1,13 @@
$NetBSD: patch-imlib_configure,v 1.1 2012/05/04 16:12:30 joerg Exp $
--- imlib/configure.orig 2012-05-04 14:23:56.000000000 +0000
+++ imlib/configure
@@ -1036,7 +1036,7 @@ cross_compiling=$ac_cv_prog_cxx_cross
cat > conftest.$ac_ext <<EOF
#line 1038 "configure"
#include "confdefs.h"
-main(){return(0);}
+int main(){return(0);}
EOF
if { (eval echo configure:1042: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest; then
ac_cv_prog_cxx_works=yes