Changes 4.0:
* Partially rewritten ntop processing engine to address reliability and performance * Several bugs and stability issues fixed * Added better support for IPFIX and NetFlow v9, as well as ntop PEN (Private Enterprise Number) * Added support for Cisco ASA firewalls * Added ntop engine scriptability via the python programming language * Added RRDalarm plugin for generating alerts based on thresholds * Improved google maps integration * Enhanced sFlow support
This commit is contained in:
parent
639fa84a11
commit
6345ae8ce1
6 changed files with 104 additions and 91 deletions
|
@ -1,7 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.59 2010/06/13 22:45:12 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.60 2010/07/22 21:10:52 adam Exp $
|
||||
|
||||
DISTNAME= ntop-3.3.10
|
||||
PKGREVISION= 3
|
||||
DISTNAME= ntop-4.0
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=ntop/}
|
||||
|
||||
|
@ -23,9 +22,6 @@ CONFIGURE_ARGS+= --with-gdbm-root=${BUILDLINK_PREFIX.gdbm}
|
|||
CONFIGURE_ARGS+= --with-ossl-root=${BUILDLINK_PREFIX.openssl}
|
||||
CONFIGURE_ARGS+= --with-pcap-root=${BUILDLINK_PREFIX.libpcap}
|
||||
CONFIGURE_ARGS+= --with-zlib-root=${BUILDLINK_PREFIX.zlib}
|
||||
# ntop-3.x crashes with IPv6
|
||||
CONFIGURE_ARGS+= --disable-ipv6
|
||||
CONFIGURE_ARGS+= --disable-snmp
|
||||
|
||||
BUILDLINK_API_DEPENDS.libpcap+= libpcap>=0.8.3
|
||||
|
||||
|
@ -37,7 +33,7 @@ CONFIGURE_ARGS+= --disable-mt
|
|||
.if ${OPSYS} == "Darwin"
|
||||
# This package uses "-flat_namespace -undefined suppress" and exports
|
||||
# symbols from the executable that get stripped unless we set this:
|
||||
INSTALL_UNSTRIPPED= YES
|
||||
INSTALL_UNSTRIPPED= yes
|
||||
.endif
|
||||
|
||||
.if (${OPSYS} == "NetBSD" && !empty(OS_VERSION:M[0-4].*))
|
||||
|
@ -51,10 +47,10 @@ pre-configure:
|
|||
|
||||
.include "../../databases/gdbm/buildlink3.mk"
|
||||
.include "../../databases/rrdtool/buildlink3.mk"
|
||||
.include "../../devel/libevent/buildlink3.mk"
|
||||
.include "../../devel/pcre/buildlink3.mk"
|
||||
.include "../../lang/lua/buildlink3.mk"
|
||||
.include "../../lang/python/application.mk"
|
||||
.include "../../net/GeoIP/buildlink3.mk"
|
||||
.include "../../net/libpcap/buildlink3.mk"
|
||||
.include "../../devel/libevent/buildlink3.mk"
|
||||
.include "../../security/openssl/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,11 +1,9 @@
|
|||
@comment $NetBSD: PLIST,v 1.11 2010/01/01 13:50:09 tron Exp $
|
||||
@comment $NetBSD: PLIST,v 1.12 2010/07/22 21:10:52 adam Exp $
|
||||
bin/ntop
|
||||
lib/libcpacketPlugin-${PKGVERSION}.so
|
||||
lib/libcpacketPlugin.so
|
||||
lib/libicmpPlugin-${PKGVERSION}.so
|
||||
lib/libicmpPlugin.so
|
||||
lib/liblastSeenPlugin-${PKGVERSION}.so
|
||||
lib/liblastSeenPlugin.so
|
||||
lib/libnetflowPlugin-${PKGVERSION}.so
|
||||
lib/libnetflowPlugin.so
|
||||
lib/libntop.la
|
||||
|
@ -16,7 +14,6 @@ lib/libsflowPlugin-${PKGVERSION}.so
|
|||
lib/libsflowPlugin.so
|
||||
lib/ntop/plugins/cpacketPlugin.so
|
||||
lib/ntop/plugins/icmpPlugin.so
|
||||
lib/ntop/plugins/lastSeenPlugin.so
|
||||
lib/ntop/plugins/netflowPlugin.so
|
||||
lib/ntop/plugins/rrdPlugin.so
|
||||
lib/ntop/plugins/sflowPlugin.so
|
||||
|
@ -27,13 +24,18 @@ share/ntop/html/MochiKit/Base.js
|
|||
share/ntop/html/MochiKit/Color.js
|
||||
share/ntop/html/MochiKit/DOM.js
|
||||
share/ntop/html/MochiKit/DateTime.js
|
||||
share/ntop/html/MochiKit/DragAndDrop.js
|
||||
share/ntop/html/MochiKit/Format.js
|
||||
share/ntop/html/MochiKit/Iter.js
|
||||
share/ntop/html/MochiKit/Logging.js
|
||||
share/ntop/html/MochiKit/LoggingPane.js
|
||||
share/ntop/html/MochiKit/MochiKit.js
|
||||
share/ntop/html/MochiKit/MockDOM.js
|
||||
share/ntop/html/MochiKit/Position.js
|
||||
share/ntop/html/MochiKit/Selector.js
|
||||
share/ntop/html/MochiKit/Signal.js
|
||||
share/ntop/html/MochiKit/Sortable.js
|
||||
share/ntop/html/MochiKit/Style.js
|
||||
share/ntop/html/MochiKit/Test.js
|
||||
share/ntop/html/MochiKit/Visual.js
|
||||
share/ntop/html/MochiKit/__package__.js
|
||||
|
@ -101,10 +103,13 @@ share/ntop/html/gaugeR.jpg
|
|||
share/ntop/html/gaugeS.jpg
|
||||
share/ntop/html/graph.gif
|
||||
share/ntop/html/graph_zoom.gif
|
||||
share/ntop/html/graph_zoomDOWN.gif
|
||||
share/ntop/html/graph_zoomUP.gif
|
||||
share/ntop/html/gray_bg.gif
|
||||
share/ntop/html/help.html
|
||||
share/ntop/html/help.png
|
||||
share/ntop/html/hostSortNote.html
|
||||
share/ntop/html/icon_python.png
|
||||
share/ntop/html/img_inquisitor/as_pointer.gif
|
||||
share/ntop/html/img_inquisitor/hl_corner_bl.gif
|
||||
share/ntop/html/img_inquisitor/hl_corner_br.gif
|
||||
|
@ -120,6 +125,7 @@ share/ntop/html/jscalendar/calendar-load.js
|
|||
share/ntop/html/jscalendar/calendar-setup.js
|
||||
share/ntop/html/jscalendar/calendar.js
|
||||
share/ntop/html/jscalendar/lang/calendar-en.js
|
||||
share/ntop/html/json2.js
|
||||
share/ntop/html/line-bottom.png
|
||||
share/ntop/html/lock.png
|
||||
share/ntop/html/mail.gif
|
||||
|
@ -141,9 +147,13 @@ share/ntop/html/phone.gif
|
|||
share/ntop/html/printer.gif
|
||||
share/ntop/html/privacyNotice.html
|
||||
share/ntop/html/question.gif
|
||||
share/ntop/html/reflection.js
|
||||
share/ntop/html/router.gif
|
||||
share/ntop/html/rrdAlarmConfig.js
|
||||
share/ntop/html/seagate.gif
|
||||
share/ntop/html/skype.gif
|
||||
share/ntop/html/sorterScript.js
|
||||
share/ntop/html/sorterStyle.css
|
||||
share/ntop/html/spacer.gif
|
||||
share/ntop/html/statsicons/flags/ad.gif
|
||||
share/ntop/html/statsicons/flags/ae.gif
|
||||
|
@ -399,7 +409,36 @@ share/ntop/html/zoom.js
|
|||
share/ntop/ntop/ntop-cert.pem
|
||||
share/ntop/ntop/oui.txt.gz
|
||||
share/ntop/ntop/specialMAC.txt.gz
|
||||
share/ntop/perl/report.pl
|
||||
share/ntop/perl/report/basic.xml
|
||||
share/ntop/perl/test.pl
|
||||
share/ntop/python/GeoPacketVisualizer.py
|
||||
share/ntop/python/docs/Makefile
|
||||
share/ntop/python/docs/epydoc.conf
|
||||
share/ntop/python/docs/src/fastbit.py
|
||||
share/ntop/python/docs/src/host.py
|
||||
share/ntop/python/docs/src/interface.py
|
||||
share/ntop/python/docs/src/ntop.py
|
||||
share/ntop/python/fastbit.py
|
||||
share/ntop/python/hello_world.py
|
||||
share/ntop/python/ipPortQuery.py
|
||||
share/ntop/python/json/info.py
|
||||
share/ntop/python/json/interfaces.py
|
||||
share/ntop/python/json/iphone/clientcheck.py
|
||||
share/ntop/python/json/iphone/hostinfo.py
|
||||
share/ntop/python/json/iphone/ifdata.py
|
||||
share/ntop/python/json/iphone/iflist.py
|
||||
share/ntop/python/json/iphone/iftophosts.py
|
||||
share/ntop/python/json/iphone/instance.py
|
||||
share/ntop/python/json/iphone/interfaces.py
|
||||
share/ntop/python/rrdalarm/config.py
|
||||
share/ntop/python/rrdalarm/crontab.rrdalarm
|
||||
share/ntop/python/rrdalarm/save.py
|
||||
share/ntop/python/rrdalarm/scripts/savelog.py
|
||||
share/ntop/python/rrdalarm/scripts/sendmail.py
|
||||
share/ntop/python/rrdalarm/start.py
|
||||
share/ntop/python/templates/GeoPacketVisualizer.tmpl
|
||||
share/ntop/python/templates/fastbit.tmpl
|
||||
share/ntop/python/templates/ipPortQuery.tmpl
|
||||
share/ntop/python/templates/queryResults.tmpl
|
||||
share/ntop/python/templates/rrdAlarmConfigurator.tmpl
|
||||
share/ntop/python/templates/rrdAlarmConfiguratorHelp.tmpl
|
||||
share/ntop/python/templates/rrdAlarmStart.tmpl
|
||||
@pkgdir lib/plugins
|
||||
|
|
|
@ -1,7 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.15 2009/07/29 08:12:18 hasso Exp $
|
||||
$NetBSD: distinfo,v 1.16 2010/07/22 21:10:52 adam Exp $
|
||||
|
||||
SHA1 (ntop-3.3.10.tar.gz) = 8c6b5024a99e73241abd1c831f5ea241b67d0dbf
|
||||
RMD160 (ntop-3.3.10.tar.gz) = 85e73de0d7db041d12ae8d77a832b6ed199b6f4b
|
||||
Size (ntop-3.3.10.tar.gz) = 3235500 bytes
|
||||
SHA1 (patch-aa) = 64b2d4cda050cd9b8981b29b0e10d900469d4b7d
|
||||
SHA1 (patch-ab) = b24c71437a6bda424ff2e60f677d37ee9a12978a
|
||||
SHA1 (ntop-4.0.tar.gz) = 1f47ce024a7e72a35d86abdae6d1d4aa2c68e2c5
|
||||
RMD160 (ntop-4.0.tar.gz) = 7c17f330a4d9a46df49369182f015042527585f4
|
||||
Size (ntop-4.0.tar.gz) = 39252530 bytes
|
||||
SHA1 (patch-aa) = e04050a3ca4364898f3d0bf892290f90cc23b092
|
||||
SHA1 (patch-ab) = 1c178b8d80e39a24880706e76d114624899cf348
|
||||
SHA1 (patch-ac) = f947853ed8f4f77f55f75adedacf16b179513202
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-aa,v 1.12 2009/04/24 10:18:03 adam Exp $
|
||||
$NetBSD: patch-aa,v 1.13 2010/07/22 21:10:52 adam Exp $
|
||||
|
||||
--- Makefile.am.orig 2008-12-03 23:00:22.000000000 +0100
|
||||
--- Makefile.am.orig 2010-04-25 12:52:28.000000000 +0000
|
||||
+++ Makefile.am
|
||||
@@ -76,9 +76,7 @@ ETTER_PASSIVE_DOWNLOAD_PARMS = "rev=HEAD
|
||||
@@ -74,9 +74,7 @@ ETTER_PASSIVE_DOWNLOAD_PARMS = "rev=HEAD
|
||||
NTOPDATA = ntop-cert.pem \
|
||||
$(ETTER_PASSIVE) \
|
||||
oui.txt.gz \
|
||||
|
@ -13,7 +13,7 @@ $NetBSD: patch-aa,v 1.12 2009/04/24 10:18:03 adam Exp $
|
|||
|
||||
NTOPHTML = html html/*.js html/*.html html/*.gif html/*.jpg html/*.ico html/*.png \
|
||||
html/*.css html/*.dtd \
|
||||
@@ -159,8 +157,6 @@ man_MANS = ntop.8
|
||||
@@ -157,8 +155,6 @@ man_MANS = ntop.8
|
||||
.PHONY: snapshot
|
||||
|
||||
|
||||
|
@ -22,11 +22,12 @@ $NetBSD: patch-aa,v 1.12 2009/04/24 10:18:03 adam Exp $
|
|||
|
||||
CLEANLIST = `ls -l $(DESTDIR)$(libdir)/*ntop*.so $(DESTDIR)$(libdir)/*Plugin*.so | \
|
||||
grep -v $(VERSION) | \
|
||||
@@ -270,7 +266,6 @@ libclean:
|
||||
|
||||
install: install-recursive
|
||||
|
||||
- cd @GEO_DIR@; make install
|
||||
|
||||
@mkdir -p $(DESTDIR)/$(CFG_DBFILE_DIR)
|
||||
@@ -336,7 +332,7 @@ install: install-recursive
|
||||
install-selinux-policy:
|
||||
chcon -t textrel_shlib_t $(DESTDIR)$(libdir)/*ntop*.so
|
||||
|
||||
-install-data-local: ntop.txt ntop.html faq.html dnetter
|
||||
+install-data-local: ntop.txt ntop.html faq.html
|
||||
@$(top_srcdir)/mkinstalldirs $(DESTDIR)/$(libdir)/plugins;
|
||||
@if ! test -d $(DESTDIR)/$(datadir)/ntop; then \
|
||||
$(top_srcdir)/mkinstalldirs $(DESTDIR)/$(datadir)/ntop; \
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ab,v 1.17 2009/07/21 19:17:53 hasso Exp $
|
||||
$NetBSD: patch-ab,v 1.18 2010/07/22 21:10:52 adam Exp $
|
||||
|
||||
--- configure.in.orig 2009-05-06 17:55:22 +0300
|
||||
+++ configure.in 2009-07-21 21:19:57 +0300
|
||||
@@ -431,6 +431,19 @@ case "${target}:${CC}" in
|
||||
--- configure.in.orig 2010-07-19 16:50:08.000000000 +0000
|
||||
+++ configure.in
|
||||
@@ -423,6 +423,19 @@ case "${target}:${CC}" in
|
||||
echo "* This appears to be ${DEFINEOS} (release not checked)"
|
||||
;;
|
||||
|
||||
|
@ -22,7 +22,7 @@ $NetBSD: patch-ab,v 1.17 2009/07/21 19:17:53 hasso Exp $
|
|||
* )
|
||||
echo "* ${target} is an unknown/unsupported OS"
|
||||
echo "*"
|
||||
@@ -621,8 +634,8 @@ if test ".${PCAPRING_DIR}" != .; then
|
||||
@@ -582,8 +595,8 @@ if test ".${PCAPRING_DIR}" != .; then
|
||||
else
|
||||
if test ".${PCAP_ROOT}" != .; then
|
||||
if test -d $PCAP_ROOT &&
|
||||
|
@ -33,62 +33,25 @@ $NetBSD: patch-ab,v 1.17 2009/07/21 19:17:53 hasso Exp $
|
|||
PCAP_ROOT=`cd ${PCAP_ROOT} && pwd`
|
||||
CORELIBS="${CORELIBS} -L$PCAP_ROOT -lpcap"
|
||||
INCS="${INCS} -I$PCAP_ROOT"
|
||||
@@ -1656,18 +1669,10 @@ LUA_VERSION=lua-5.1.4
|
||||
if test -f "$LUA_VERSION.tar.gz"; then
|
||||
echo "Lua already present on this machine"
|
||||
else
|
||||
- wget http://www.lua.org/ftp/$LUA_VERSION.tar.gz
|
||||
fi
|
||||
|
||||
-tar xvfz $LUA_VERSION.tar.gz
|
||||
-cat $LUA_VERSION/src/Makefile | sed -e s,'MYCFLAGS=-DLUA_USE_POSIX',' MYCFLAGS="-fPIC -DLUA_USE_POSIX"',g > /tmp/lua.temp
|
||||
-cat /tmp/lua.temp > $LUA_VERSION/src/Makefile
|
||||
-#rm -f /tmp/lua.temp
|
||||
-cd $LUA_VERSION; make posix; cd ..
|
||||
@@ -1816,10 +1829,7 @@ else
|
||||
if test -f "3rd_party/GeoLiteCity.dat.gz"; then
|
||||
cp 3rd_party/GeoLiteCity.dat.gz .
|
||||
else
|
||||
- wget http://www.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz
|
||||
fi
|
||||
-
|
||||
-LUA_LIB_DIR=$PWD/$LUA_VERSION"/src"
|
||||
-LIBS="-L${LUA_LIB_DIR} -llua ${LIBS} "
|
||||
-INCS="${INCS} -I${LUA_LIB_DIR}"
|
||||
+
|
||||
+LIBS="-llua ${LIBS} "
|
||||
AC_DEFINE_UNQUOTED(HAVE_LUA, 1, [LUA is supported])
|
||||
|
||||
dnl>
|
||||
@@ -1966,36 +1971,20 @@ dnl> GeoIP (http://www.maxmind.com/)
|
||||
if test -f "GeoIP.tar.gz"; then
|
||||
echo "GeoIP already present on this machine"
|
||||
else
|
||||
- wget http://www.maxmind.com/download/geoip/api/c/GeoIP.tar.gz
|
||||
-fi
|
||||
-tar xvfz GeoIP.tar.gz
|
||||
-GEO_DIR=`find $PWD -type d -name "GeoIP-*"`
|
||||
-cd $GEO_DIR; ./configure --prefix=${prefix}; make; cd ..
|
||||
-# OSX Fix
|
||||
-GEO_DYLIB="$GEO_DIR/libGeoIP/.libs/libGeoIP.dylib"
|
||||
-if test -f $GEO_DYLIB; then
|
||||
- ln -s $GEO_DYLIB .
|
||||
fi
|
||||
|
||||
if test -f "GeoLiteCity.dat"; then
|
||||
echo "GeoLiteCity.dat already present"
|
||||
else
|
||||
- wget http://www.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz
|
||||
- gunzip GeoLiteCity.dat.gz
|
||||
fi
|
||||
|
||||
if test -f "GeoIPASNum.dat"; then
|
||||
echo "GeoIPASNum.dat already present"
|
||||
else
|
||||
- wget http://www.maxmind.com/download/geoip/database/asnum/GeoIPASNum.dat.gz
|
||||
dnl> --------
|
||||
@@ -1830,10 +1840,8 @@ else
|
||||
if test -f "3rd_party/GeoIPASNum.dat.gz"; then
|
||||
cp 3rd_party/GeoIPASNum.dat.gz .
|
||||
else
|
||||
- wget http://www.maxmind.com/download/geoip/database/asnum/GeoIPASNum.dat.gz
|
||||
fi
|
||||
|
||||
- gunzip GeoIPASNum.dat.gz
|
||||
fi
|
||||
|
||||
|
||||
-GEO_DIR=`find $PWD -type d -name "GeoIP-*"`
|
||||
-GEO_IP="$GEO_DIR/libGeoIP/"
|
||||
-CFLAGS="$CFLAGS -I$GEO_IP"
|
||||
-LDFLAGS="-L$GEO_IP.libs/ -lGeoIP $LDFLAGS"
|
||||
+LDFLAGS="-lGeoIP $LDFLAGS"
|
||||
|
||||
dnl> NTOPCONFIGDEBUG_SETTINGS([precet])
|
||||
|
||||
else
|
||||
AC_MSG_RESULT(Please install GeoIP (http://www.maxmind.com/))
|
||||
|
|
13
net/ntop/patches/patch-ac
Normal file
13
net/ntop/patches/patch-ac
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ac,v 1.8 2010/07/22 21:10:52 adam Exp $
|
||||
|
||||
--- initialize.c.orig 2010-07-20 20:46:07.000000000 +0000
|
||||
+++ initialize.c
|
||||
@@ -365,7 +365,7 @@ void initCounters(void) {
|
||||
|
||||
setDomainName();
|
||||
|
||||
-#ifdef INET6
|
||||
+#if 0
|
||||
_in6addr_linklocal_allnodes.s6_addr[0] = 0xff;
|
||||
_in6addr_linklocal_allnodes.s6_addr[1] = 0x02;
|
||||
_in6addr_linklocal_allnodes.s6_addr[2] = 0x00;
|
Loading…
Reference in a new issue