Update to version 0.7.1.

Changes:

- use bzip2 distribution tarball

0.7.1:
======
- KaxClusterPosition is already in use and therefore a v1 element
- various cosmetic changes to Makefile and build system itself
This commit is contained in:
salo 2004-07-27 04:14:56 +00:00
parent d7e2a24d91
commit 63496419ba
5 changed files with 27 additions and 48 deletions

View file

@ -1,10 +1,10 @@
# $NetBSD: Makefile,v 1.6 2004/07/20 23:53:12 salo Exp $
# $NetBSD: Makefile,v 1.7 2004/07/27 04:14:56 salo Exp $
#
DISTNAME= libmatroska-0.7.0
PKGREVISION= 1
DISTNAME= libmatroska-0.7.1
CATEGORIES= multimedia devel
MASTER_SITES= http://dl.matroska.org/downloads/libmatroska/
EXTRACT_SUFX= .tar.bz2
MAINTAINER= salo@NetBSD.org
HOMEPAGE= http://www.matroska.org/

View file

@ -1,4 +1,4 @@
# $NetBSD: buildlink3.mk,v 1.3 2004/07/20 23:53:12 salo Exp $
# $NetBSD: buildlink3.mk,v 1.4 2004/07/27 04:14:56 salo Exp $
#
# This Makefile fragment is included by packages that use libmatroska.
#
@ -16,7 +16,7 @@ BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Nlibmatroska}
BUILDLINK_PACKAGES+= libmatroska
.if !empty(LIBMATROSKA_BUILDLINK3_MK:M+)
BUILDLINK_DEPENDS.libmatroska+= libmatroska>=0.7.0nb1
BUILDLINK_DEPENDS.libmatroska+= libmatroska>=0.7.1
BUILDLINK_PKGSRCDIR.libmatroska?= ../../multimedia/libmatroska
.endif # LIBMATROSKA_BUILDLINK3_MK

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.5 2004/07/20 23:53:12 salo Exp $
$NetBSD: distinfo,v 1.6 2004/07/27 04:14:56 salo Exp $
SHA1 (libmatroska-0.7.0.tar.gz) = 51997ad2834a08a86e2e163c037aa841aa1cb0bb
Size (libmatroska-0.7.0.tar.gz) = 100316 bytes
SHA1 (patch-aa) = 1b39f10c5d50091d7875d5e60c3e9b09d187a7a1
SHA1 (patch-ac) = 57cc8044b8ea8b4f1fc639734f18f6b91e978dc7
SHA1 (libmatroska-0.7.1.tar.bz2) = 8da497c0cd2dc6044489e8fdbae129254f7988f2
Size (libmatroska-0.7.1.tar.bz2) = 78830 bytes
SHA1 (patch-aa) = 673a3043692df4fc0f7babc4be13f92fdf1fda62
SHA1 (patch-ac) = 59225b6e89c6563e7245a94b46c798c2c44bd259

View file

@ -1,31 +1,31 @@
$NetBSD: patch-aa,v 1.1.1.1 2004/04/07 12:52:16 salo Exp $
$NetBSD: patch-aa,v 1.2 2004/07/27 04:14:56 salo Exp $
--- test/mux/test8.cpp.orig 2004-01-17 19:33:21.000000000 +0300
+++ test/mux/test8.cpp
@@ -276,7 +276,7 @@ int main(int argc, char **argv)
--- test/mux/test8.cpp.orig 2004-07-09 23:05:36.000000000 +0200
+++ test/mux/test8.cpp 2004-07-27 05:57:12.000000000 +0200
@@ -273,7 +273,7 @@
} else if (EbmlId(*ElementLevel2) == KaxMuxingApp::ClassInfos.GlobalId) {
KaxMuxingApp *pApp = static_cast<KaxMuxingApp*>(ElementLevel2);
pApp->ReadData(aStream.I_O());
-#if !defined(__CYGWIN__) && !defined(__APPLE__)
+#if !defined(__CYGWIN__) && !defined(__APPLE__) && !defined(__NetBSD__)
-#if !defined(__CYGWIN__) && !defined(__APPLE__) && !defined(__BEOS__)
+#if !defined(__CYGWIN__) && !defined(__APPLE__) && !defined(__BEOS__) && !defined(__NetBSD__)
wprintf(L"Muxing App : %ls\n", UTFstring(*pApp).c_str());
#else
printf("Muxing App : %s\n", UTFstring(*pApp).c_str());
@@ -284,7 +284,7 @@ int main(int argc, char **argv)
@@ -281,7 +281,7 @@
} else if (EbmlId(*ElementLevel2) == KaxWritingApp::ClassInfos.GlobalId) {
KaxWritingApp *pApp = static_cast<KaxWritingApp*>(ElementLevel2);
pApp->ReadData(aStream.I_O());
-#if !defined(__CYGWIN__) && !defined(__APPLE__)
+#if !defined(__CYGWIN__) && !defined(__APPLE__) && !defined(__NetBSD__)
-#if !defined(__CYGWIN__) && !defined(__APPLE__) && !defined(__BEOS__)
+#if !defined(__CYGWIN__) && !defined(__APPLE__) && !defined(__BEOS__) && !defined(__NetBSD__)
wprintf(L"Writing App : %ls (éàôï)\n", UTFstring(*pApp).c_str());
#else
printf("Writing App : %s (éàôï)\n", UTFstring(*pApp).c_str());
@@ -603,7 +603,7 @@ int main(int argc, char **argv)
@@ -600,7 +600,7 @@
unsigned int Index4;
for (Index4 = 0; Index4<aDisplay.ListSize() ;Index4++) {
if (aDisplay[Index4]->Generic().GlobalId == KaxChapterString::ClassInfos.GlobalId) {
-#if !defined(__CYGWIN__) && !defined(__APPLE__)
+#if !defined(__CYGWIN__) && !defined(__APPLE__) && !defined(__NetBSD__)
-#if !defined(__CYGWIN__) && !defined(__APPLE__) && !defined(__BEOS__)
+#if !defined(__CYGWIN__) && !defined(__APPLE__) && !defined(__BEOS__) && !defined(__NetBSD__)
wprintf(L" Display \"%s\"\n", UTFstring(*static_cast<EbmlUnicodeString *>(aDisplay[Index4])).c_str() );
#else
printf(" Display \"%s\"\n", UTFstring(*static_cast<EbmlUnicodeString *>(aDisplay[Index4])).c_str() );

View file

@ -1,15 +1,14 @@
$NetBSD: patch-ac,v 1.3 2004/07/20 23:53:12 salo Exp $
$NetBSD: patch-ac,v 1.4 2004/07/27 04:14:56 salo Exp $
--- make/linux/Makefile.orig 2004-01-05 12:28:43.000000000 +0100
+++ make/linux/Makefile 2004-07-21 00:21:56.000000000 +0200
@@ -15,13 +15,13 @@
--- make/linux/Makefile.orig 2004-07-19 18:43:44.000000000 +0200
+++ make/linux/Makefile 2004-07-27 05:51:07.000000000 +0200
@@ -20,13 +20,13 @@
includedir=$(prefix)/include/matroska
# Programs
-CXX=g++
-LD=g++
+#CXX=g++
+LD=$(CXX)
LD=$(CXX)
DEP=$(CXX) -MM
DEPEND = makedepend
-AR = ar rcvu
@ -21,23 +20,3 @@ $NetBSD: patch-ac,v 1.3 2004/07/20 23:53:12 salo Exp $
INSTALL_OPTS = -m 644
INSTALL_OPTS_LIB = -m 644
INSTALL_DIR_OPTS = -m 755
@@ -36,8 +36,8 @@
ifeq (yes,$(DEBUG))
DEBUGFLAGS=-g -DDEBUG
endif
-CXXFLAGS=$(DEBUGFLAGS) -Wall -Wno-unknown-pragmas -ansi -fno-gnu-keywords -D_GNU_SOURCE -Wshadow
-LDFLAGS=-L. -L$(LIBEBML_LIB_DIR)
+CXXFLAGS+= $(DEBUGFLAGS) -Wall -Wno-unknown-pragmas -ansi -fno-gnu-keywords -D_GNU_SOURCE -Wshadow
+LDFLAGS+= -L. -L$(LIBEBML_LIB_DIR)
SRC_DIR=$(CWD)/../../src/
INCLUDE_DIR=$(CWD)/../../matroska
@@ -66,7 +66,7 @@
DEPENDFLAGS = ${CXXFLAGS} ${INCLUDE}
-all: $(LIBRARY) test
+all: $(LIBRARY)
lib library: $(LIBRARY)