"!=" and "|=" are different operators. Use the correct enum.

Selectively disable a few warnings for clang.
This commit is contained in:
joerg 2013-03-02 18:19:10 +00:00
parent d1da720c88
commit 638ed7caa0
4 changed files with 44 additions and 2 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.28 2013/02/06 23:21:49 jperkin Exp $
# $NetBSD: Makefile,v 1.29 2013/03/02 18:19:10 joerg Exp $
#
DISTNAME= telepathy-gabble-0.11.10
@ -18,6 +18,11 @@ USE_LIBTOOL= yes
USE_TOOLS+= gmake pkg-config
CONFIGURE_ENV+= UUID_CFLAGS=" " UUID_LIBS=" "
.include "../../mk/compiler.mk"
.if !empty(PKGSRC_COMPILER:Mclang)
CFLAGS+= -Wno-error=deprecated-declarations -Wno-error=tautological-constant-out-of-range-compare
.endif
# see pkgsrc/security/mozilla-rootcerts
CONFIGURE_ARGS+= --with-ca-certificates=/etc/ssl/certs/ca-certificates.crt

View file

@ -1,12 +1,14 @@
$NetBSD: distinfo,v 1.15 2012/05/09 03:57:45 dholland Exp $
$NetBSD: distinfo,v 1.16 2013/03/02 18:19:10 joerg Exp $
SHA1 (telepathy-gabble-0.11.10.tar.gz) = 26ca4e8a98b01b78007f88caea56b08ae5070fdd
RMD160 (telepathy-gabble-0.11.10.tar.gz) = b4906a01b8cc6e6630e1707e97250bcdefeac9c4
Size (telepathy-gabble-0.11.10.tar.gz) = 3443486 bytes
SHA1 (patch-lib_ext_wocky_examples_connect.c) = 4f22cadb5e39f68630c3d09671aaef4e6a480394
SHA1 (patch-lib_ext_wocky_tests_test-resolver_h) = 4fc2950543c9ea9b902c1608082e60c644659a91
SHA1 (patch-lib_ext_wocky_tests_wocky-connector-test.c) = 9e5b06621583229b0fd05d057dce778698ea223f
SHA1 (patch-lib_ext_wocky_tests_wocky-test-sasl-auth-server.c) = f53a0b3247df5a5dcf90809a9495966ff26c6c3f
SHA1 (patch-lib_ext_wocky_wocky_wocky-heartbeat-source_c) = d8f0192f7f34e6fb98150283f5ff05de6313ee4a
SHA1 (patch-lib_ext_wocky_wocky_wocky-muc.c) = 769dae27f20fd7e1c196d65a4753ccf65a77926b
SHA1 (patch-lib_ext_wocky_wocky_wocky-openssl.c) = 21dd4df0c50e766bab0d3d1cbaa9fbe2feef7a17
SHA1 (patch-src_bytestream-socks5.c) = d6f72478bef2b2502f3955e50dc11b51f0e2b502
SHA1 (patch-src_ft-manager.c) = d660079ff74dd6f275ab8022ad0f7f5cd9b37897

View file

@ -0,0 +1,22 @@
$NetBSD: patch-lib_ext_wocky_tests_wocky-connector-test.c,v 1.1 2013/03/02 18:19:10 joerg Exp $
--- lib/ext/wocky/tests/wocky-connector-test.c.orig 2013-03-01 14:38:21.000000000 +0000
+++ lib/ext/wocky/tests/wocky-connector-test.c
@@ -3428,7 +3428,7 @@ run_test (gpointer data)
g_object_get (wcon, "identity", &identity, "features", &feat, NULL);
g_assert (identity != NULL);
- g_assert (*identity |= '\0');
+ g_assert (*identity != '\0');
g_assert (feat != NULL);
g_assert (G_OBJECT_TYPE (feat) == WOCKY_TYPE_STANZA);
g_free (identity);
@@ -3442,7 +3442,7 @@ run_test (gpointer data)
g_object_get (wcon, "resource", &identity, NULL);
g_assert (identity != NULL);
- g_assert (*identity |= '\0');
+ g_assert (*identity != '\0');
g_free (identity);
g_object_get (wcon, "legacy", &jabber, "old-ssl", &oldssl, NULL);

View file

@ -0,0 +1,13 @@
$NetBSD: patch-lib_ext_wocky_wocky_wocky-muc.c,v 1.1 2013/03/02 18:19:10 joerg Exp $
--- lib/ext/wocky/wocky/wocky-muc.c.orig 2013-03-01 14:32:26.000000000 +0000
+++ lib/ext/wocky/wocky/wocky-muc.c
@@ -1480,7 +1480,7 @@ extract_chat_state (WockyNode *msg)
if (child == NULL ||
!wocky_enum_from_nick (WOCKY_TYPE_MUC_MSG_STATE, child->name, &mstate))
- mstate = WOCKY_MUC_MSG_NONE;
+ mstate = WOCKY_MUC_MSG_STATE_NONE;
return mstate;
}