Update to O'Caml 3.12.1

Changes in Objective Caml 3.12.1:

Features:
- added '-ml-synonym' and '-mli-synonym' options to ocamldep
- added '-ocamldoc' option to ocamlbuild
- added possibility to add options to ocamlbuild
- added access to current camlp4 parsers and printers
- improved instruction selection for float operations on amd64
- stdlib: added a 'usage_string' function to Arg
- allow with constraints to add a type equation to a datatype definition
- ocamldoc: allow to merge '@before' tags like other ones
- ocamlbuild: allow dependency on file "_oasis"

Other changes:
- Changed default minor heap size from 32k to 256k words.
- Added new operation 'compare_ext' to custom blocks, called when
  comparing a custom block value with an unboxed integer.

Multiple bug fixes.
This commit is contained in:
asau 2012-03-04 09:06:46 +00:00
parent 65908bb2cf
commit 63b9b029bd
8 changed files with 61 additions and 147 deletions

View file

@ -1,11 +1,9 @@
# $NetBSD: Makefile,v 1.75 2011/12/06 00:19:07 sbd Exp $
# $NetBSD: Makefile,v 1.76 2012/03/04 09:06:46 asau Exp $
PKG_DESTDIR_SUPPORT= user-destdir
.include "Makefile.common"
PKGREVISION= 5
CONFIGURE_ARGS+= -no-tk
CONFIGURE_ARGS+= -cc ${CC}
CONFIGURE_ENV+= disable_x11=yes

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile.common,v 1.31 2011/08/08 07:31:52 obache Exp $
# $NetBSD: Makefile.common,v 1.32 2012/03/04 09:06:46 asau Exp $
# used by x11/labltk/Makefile
# used by x11/ocaml-graphics/Makefile
DISTNAME= ocaml-3.12.0
DISTNAME= ocaml-3.12.1
CATEGORIES= lang
MASTER_SITES= http://caml.inria.fr/pub/distrib/ocaml-3.12/
EXTRACT_SUFX= .tar.bz2

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.59 2011/11/27 19:46:00 joerg Exp $
$NetBSD: distinfo,v 1.60 2012/03/04 09:06:46 asau Exp $
SHA1 (ocaml-3.12.0.tar.bz2) = 33ebbfb1115806f117808f37e40d206c8994943d
RMD160 (ocaml-3.12.0.tar.bz2) = 3d10d5f7431d8200688fa74122e7ed528126a0fa
Size (ocaml-3.12.0.tar.bz2) = 2639049 bytes
SHA1 (patch-aa) = 1bedb77b12c457966b2a8b86f756535bfef9c496
SHA1 (ocaml-3.12.1.tar.bz2) = 29b44117b116b1a5bc54a8b4514af483793a769f
RMD160 (ocaml-3.12.1.tar.bz2) = 61d38c0785491c8790ac02ab78fb2f26ea490fc1
Size (ocaml-3.12.1.tar.bz2) = 2949124 bytes
SHA1 (patch-aa) = 288f8aa1c0a4c080e69e1d2b552250da98304597
SHA1 (patch-ab) = e91cbb94c0897ffd02daebc19835a24c257dccd9
SHA1 (patch-ac) = efe8290b394f40d6675fc9d57557c49ddafdb239
SHA1 (patch-ad) = f2c1dcc3c31db31e2484fdea1076692a63252a87
@ -11,11 +11,10 @@ SHA1 (patch-ag) = f1b751098d3693b92feb26cda87970426bffcaf1
SHA1 (patch-ah) = 3165bbcdb98d09f5161912e51a3131486aa0b488
SHA1 (patch-aj) = 6fd989f1e5dd1263890c14459dd4ab85d75e86cd
SHA1 (patch-an) = 8fb8efecd2b3f0ec6f913a0840f4cfebcbb6161e
SHA1 (patch-asmcomp_amd64_emit.mlp) = 72854ca013303155573417c6c694d03f9f802ac9
SHA1 (patch-at) = c0a806229548fc12948b7b1cab18a3869e10bc02
SHA1 (patch-at) = aebd0637ace414cc4504ef0c46486343e89728dd
SHA1 (patch-au) = 1e36bcdf39d40e781273ea51df213db05ff46c89
SHA1 (patch-av) = f56c8924b81a620602bc5a67b0c4459b721701d2
SHA1 (patch-aw) = ce7b09f19f9f086b65b5036b6684c5243e990b8c
SHA1 (patch-aw) = cf66a2296cb86adfc0945e0009a6ed2805b57eed
SHA1 (patch-ax) = d46667e6874aa8aa656f6fb15ddcedc493d7bdf1
SHA1 (patch-ay) = 702dd7d24ac94851bbb0f2c3f22e2141345ee8ea
SHA1 (patch-az) = 9b9e1cfa8972e6bea9563d4d12866d567fdce668
@ -31,7 +30,7 @@ SHA1 (patch-bo) = 318b5c023c692a3d6fb05b3276e755fae642d6b0
SHA1 (patch-bp) = 45038c5900aefdb8d21b8c3d3b8798b45014bae2
SHA1 (patch-bq) = 2ac3b7c1cdf9bdf1e6dcd5905e54291169d069c6
SHA1 (patch-br) = f9dacbd8742a9cdc9ae0232f297898f0df62a95b
SHA1 (patch-bs) = 24788a31a5bdfe502e9586002574fdc077455536
SHA1 (patch-bs) = d169c3196d9f9c3f36764174c52e5db2512a3942
SHA1 (patch-bt) = 400ac1c2935690bd204da116272017ec167f4b0d
SHA1 (patch-bu) = 0b3bbe273142ebed3a24e7e92d4cfd9f30a032b6
SHA1 (patch-bv) = 595641bb079174f393e420bdf5c48fe8ca1912cf

View file

@ -1,7 +1,4 @@
$NetBSD: patch-aa,v 1.9 2011/08/15 21:19:33 wiz Exp $
Second chunk: fix build with binutils-2.21.
http://caml.inria.fr/mantis/view.php?id=5237
$NetBSD: patch-aa,v 1.10 2012/03/04 09:06:46 asau Exp $
--- asmcomp/i386/emit.mlp.orig 2010-01-20 16:26:46 +0000
+++ asmcomp/i386/emit.mlp
@ -14,19 +11,3 @@ http://caml.inria.fr/mantis/view.php?id=5237
` popl %edx\n`;
` popl %ecx\n`;
` popl %eax\n`
@@ -905,12 +905,12 @@ let fundecl fundecl =
emit_all true fundecl.fun_body;
List.iter emit_call_gc !call_gc_sites;
emit_call_bound_errors ();
- List.iter emit_float_constant !float_constants;
- match Config.system with
+ begin match Config.system with
"linux_elf" | "bsd_elf" | "gnu" ->
` .type {emit_symbol fundecl.fun_name},@function\n`;
` .size {emit_symbol fundecl.fun_name},.-{emit_symbol fundecl.fun_name}\n`
- | _ -> ()
+ | _ -> () end;
+ List.iter emit_float_constant !float_constants
(* Emission of data *)

View file

@ -1,32 +0,0 @@
$NetBSD: patch-asmcomp_amd64_emit.mlp,v 1.1 2011/08/15 21:19:33 wiz Exp $
Fix build with binutils-2.21.
http://caml.inria.fr/mantis/view.php?id=5237
--- asmcomp/amd64/emit.mlp.orig 2010-06-02 08:55:35 +0000
+++ asmcomp/amd64/emit.mlp
@@ -688,17 +688,18 @@ let fundecl fundecl =
emit_all true fundecl.fun_body;
List.iter emit_call_gc !call_gc_sites;
emit_call_bound_errors ();
+ begin match Config.system with
+ "linux" | "gnu" ->
+ ` .type {emit_symbol fundecl.fun_name},@function\n`;
+ ` .size {emit_symbol fundecl.fun_name},.-{emit_symbol fundecl.fun_name}\n`
+ | _ -> ()
+ end;
if !float_constants <> [] then begin
if macosx
then ` .literal8\n`
else ` .section .rodata.cst8,\"a\",@progbits\n`;
List.iter emit_float_constant !float_constants
- end;
- match Config.system with
- "linux" | "gnu" ->
- ` .type {emit_symbol fundecl.fun_name},@function\n`;
- ` .size {emit_symbol fundecl.fun_name},.-{emit_symbol fundecl.fun_name}\n`
- | _ -> ()
+ end
(* Emission of data *)

View file

@ -1,4 +1,4 @@
$NetBSD: patch-at,v 1.24 2011/11/27 19:11:59 marino Exp $
$NetBSD: patch-at,v 1.25 2012/03/04 09:06:46 asau Exp $
. Include CFLAGS in bytecccompopts and LDFLAGS in bytecclinkopts.
. Add cases for dragonfly support.
@ -15,9 +15,9 @@ $NetBSD: patch-at,v 1.24 2011/11/27 19:11:59 marino Exp $
. Enable profiling and native dynamic loading for all DragonFly platforms
. Add pkgsrc X11 checks in case X11 support is enabled in the future
--- configure.orig 2010-07-28 13:18:22.000000000 +0000
+++ configure
@@ -328,6 +328,8 @@ case "$bytecc,$host" in
--- configure.orig 2011-07-05 01:15:01.000000000 +0400
+++ configure 2012-03-04 07:07:17.000000000 +0400
@@ -328,6 +328,8 @@
gcc*)
bytecccompopts="-fno-defer-pop $gcc_warnings";;
esac
@ -26,7 +26,7 @@ $NetBSD: patch-at,v 1.24 2011/11/27 19:11:59 marino Exp $
# Configure compiler to use in further tests
@@ -520,7 +522,7 @@ if test $withsharedlibs = "yes"; then
@@ -521,7 +523,7 @@
mksharedlib="$flexlink"
mkmaindll="$flexlink -maindll"
shared_libraries_supported=true;;
@ -35,7 +35,7 @@ $NetBSD: patch-at,v 1.24 2011/11/27 19:11:59 marino Exp $
sharedcccompopts="-fPIC"
mksharedlib="$bytecc -shared"
bytecclinkopts="$bytecclinkopts -Wl,-E"
@@ -620,7 +622,7 @@ if test $withsharedlibs = "yes"; then
@@ -621,7 +623,7 @@
i[3456]86-*-linux*) natdynlink=true;;
x86_64-*-linux*) natdynlink=true;;
i[3456]86-*-darwin10.*)
@ -44,18 +44,16 @@ $NetBSD: patch-at,v 1.24 2011/11/27 19:11:59 marino Exp $
natdynlink=true
fi;;
i[3456]86-*-darwin[89]*) natdynlink=true;;
@@ -629,6 +631,10 @@ if test $withsharedlibs = "yes"; then
i686-*-kfreebsd*) natdynlink=true;;
x86_64-*-kfreebsd*) natdynlink=true;;
i386-*-gnu0.3) natdynlink=true;;
+ i[3456]86-*-netbsdelf) natdynlink=true;;
@@ -635,6 +637,8 @@
x86_64-*-openbsd*) natdynlink=true;;
i[345]86-*-netbsd*) natdynlink=true;;
x86_64-*-netbsd*) natdynlink=true;;
+ i[3456]86-*-dragonfly) natdynlink=true;;
+ x86_64-*-netbsd) natdynlink=true;;
+ x86_64-*-dragonfly) natdynlink=true;;
i386-*-gnu0.3) natdynlink=true;;
esac
fi
@@ -653,12 +659,13 @@ case "$host" in
@@ -660,12 +664,13 @@
alpha*-*-netbsd*) arch=alpha; system=netbsd;;
alpha*-*-openbsd*) arch=alpha; system=openbsd;;
sparc*-*-sunos4.*) arch=sparc; system=sunos;;
@ -70,7 +68,7 @@ $NetBSD: patch-at,v 1.24 2011/11/27 19:11:59 marino Exp $
i[3456]86-*-nextstep*) arch=i386; system=nextstep;;
i[3456]86-*-solaris*) if $arch64; then
arch=amd64; system=solaris
@@ -667,6 +674,7 @@ case "$host" in
@@ -674,6 +679,7 @@
fi;;
i[3456]86-*-beos*) arch=i386; system=beos;;
i[3456]86-*-cygwin*) arch=i386; system=cygwin;;
@ -78,7 +76,7 @@ $NetBSD: patch-at,v 1.24 2011/11/27 19:11:59 marino Exp $
i[3456]86-*-darwin*) if $arch64; then
arch=amd64; system=macosx
else
@@ -683,17 +691,21 @@ case "$host" in
@@ -690,17 +696,21 @@
powerpc-*-rhapsody*) arch=power; model=ppc; system=rhapsody;;
powerpc-*-darwin*) arch=power; system=rhapsody
if $arch64; then model=ppc64; else model=ppc; fi;;
@ -100,7 +98,7 @@ $NetBSD: patch-at,v 1.24 2011/11/27 19:11:59 marino Exp $
esac
# Some platforms exist both in 32-bit and 64-bit variants, not distinguished
@@ -794,6 +806,8 @@ case "$arch,$model,$system" in
@@ -801,6 +811,8 @@
case "$nativecc" in gcc*) ;; *) cc_profile='-xpg';; esac;;
amd64,*,linux) profiling='prof';;
amd64,*,gnu) profiling='prof';;
@ -109,7 +107,7 @@ $NetBSD: patch-at,v 1.24 2011/11/27 19:11:59 marino Exp $
*) profiling='noprof';;
esac
@@ -1198,6 +1212,8 @@ if test "$pthread_wanted" = "yes"; then
@@ -1205,6 +1217,8 @@
pthread_caml_link="-cclib -lpthread -cclib -lposix4";;
*-*-freebsd*) pthread_link="-pthread"
pthread_caml_link="-cclib -pthread";;
@ -118,7 +116,7 @@ $NetBSD: patch-at,v 1.24 2011/11/27 19:11:59 marino Exp $
*-*-openbsd*) pthread_link="-pthread"
pthread_caml_link="-cclib -pthread";;
*) pthread_link="-lpthread"
@@ -1249,6 +1265,7 @@ fi
@@ -1256,6 +1270,7 @@
x11_include="not found"
x11_link="not found"
@ -126,7 +124,7 @@ $NetBSD: patch-at,v 1.24 2011/11/27 19:11:59 marino Exp $
for dir in \
$x11_include_dir \
\
@@ -1287,6 +1304,7 @@ for dir in \
@@ -1294,6 +1309,7 @@
/usr/XFree86/include/X11 \
\
/usr/include \
@ -134,7 +132,7 @@ $NetBSD: patch-at,v 1.24 2011/11/27 19:11:59 marino Exp $
/usr/local/include \
/usr/unsupported/include \
/usr/athena/include \
@@ -1301,6 +1319,7 @@ do
@@ -1308,6 +1324,7 @@
break
fi
done
@ -142,7 +140,7 @@ $NetBSD: patch-at,v 1.24 2011/11/27 19:11:59 marino Exp $
if test "$x11_include" = "not found"; then
x11_try_lib_dir=''
@@ -1343,6 +1362,7 @@ for dir in \
@@ -1350,6 +1367,7 @@
\
/usr/lib64 \
/usr/lib \
@ -150,7 +148,7 @@ $NetBSD: patch-at,v 1.24 2011/11/27 19:11:59 marino Exp $
/usr/local/lib \
/usr/unsupported/lib \
/usr/athena/lib \
@@ -1395,31 +1415,8 @@ dbm_include="not found"
@@ -1402,31 +1420,8 @@
dbm_link="not found"
use_gdbm_ndbm=no
@ -184,7 +182,7 @@ $NetBSD: patch-at,v 1.24 2011/11/27 19:11:59 marino Exp $
if test "$dbm_include" = "not found" || test "$dbm_link" = "not found"; then
echo "NDBM not found, the \"dbm\" library will not be supported."
else
@@ -1429,8 +1426,8 @@ else
@@ -1436,8 +1431,8 @@
else
dbm_include="-I$dbm_include"
fi

View file

@ -1,32 +1,8 @@
$NetBSD: patch-aw,v 1.8 2010/11/28 08:41:33 is Exp $
$NetBSD: patch-aw,v 1.9 2012/03/04 09:06:46 asau Exp $
--- ocamldoc/Makefile.orig 2010-06-16 11:38:22.000000000 +0000
+++ ocamldoc/Makefile
@@ -31,7 +31,7 @@ OCAMLPP=-pp './remove_DEBUG'
MKDIR=mkdir -p
CP=cp -f
OCAMLDOC=ocamldoc
-OCAMLDOC_RUN=./ocamldoc.opt #sh ./runocamldoc $(SUPPORTS_SHARED_LIBRARIES)
+OCAMLDOC_RUN=sh ./runocamldoc $(SUPPORTS_SHARED_LIBRARIES)
OCAMLDOC_OPT=$(OCAMLDOC).opt
OCAMLDOC_LIBCMA=odoc_info.cma
OCAMLDOC_LIBCMI=odoc_info.cmi
@@ -189,12 +189,13 @@ STDLIB_MLIS=../stdlib/*.mli \
../otherlibs/num/num.mli
all: exe lib
+ $(MAKE) manpages
exe: $(OCAMLDOC)
lib: $(OCAMLDOC_LIBCMA) $(OCAMLDOC_LIBCMI) $(ODOC_TEST)
opt.opt: exeopt libopt
- $(MAKE) manpages
+
exeopt: $(OCAMLDOC_OPT)
libopt: $(OCAMLDOC_LIBCMXA) $(OCAMLDOC_LIBCMI)
debug:
@@ -259,24 +260,24 @@ odoc_see_lexer.ml: odoc_see_lexer.mll
--- ocamldoc/Makefile.orig 2011-05-02 17:14:14.000000000 +0400
+++ ocamldoc/Makefile 2012-03-04 07:19:46.000000000 +0400
@@ -258,24 +258,24 @@
# Installation targets
######################
install: dummy
@ -36,15 +12,16 @@ $NetBSD: patch-aw,v 1.8 2010/11/28 08:41:33 is Exp $
- $(CP) $(OCAMLDOC) $(INSTALL_BINDIR)/$(OCAMLDOC)$(EXE)
- $(CP) ocamldoc.hva *.cmi $(OCAMLDOC_LIBCMA) $(INSTALL_LIBDIR)
- $(CP) $(INSTALL_MLIS) $(INSTALL_CMIS) $(INSTALL_LIBDIR)
+ if test -d $(INSTALL_BINDIR); then : ; else ${BSD_INSTALL_PROGRAM_DIR} $(INSTALL_BINDIR); fi
+ if test -d $(INSTALL_LIBDIR); then : ; else ${BSD_INSTALL_DATA_DIR} $(INSTALL_LIBDIR); fi
+ if test -d $(INSTALL_CUSTOMDIR); then : ; else ${BSD_INSTALL_DATA_DIR} $(INSTALL_CUSTOMDIR); fi
+ ${BSD_INSTALL_SCRIPT} $(OCAMLDOC) $(INSTALL_BINDIR)/$(OCAMLDOC)$(EXE)
+ ${BSD_INSTALL_DATA} ocamldoc.hva *.cmi $(OCAMLDOC_LIBCMA) $(INSTALL_LIBDIR)
+ ${BSD_INSTALL_DATA} $(INSTALL_MLIS) $(INSTALL_CMIS) $(INSTALL_LIBDIR)
if test -d $(INSTALL_MANODIR); then : ; else $(MKDIR) $(INSTALL_MANODIR); fi
- if test -d $(INSTALL_MANODIR); then : ; else $(MKDIR) $(INSTALL_MANODIR); fi
- if test -d stdlib_man; then $(CP) stdlib_man/* $(INSTALL_MANODIR); else : ; fi
+ ${BSD_INSTALL_MAN} stdlib_man/* $(INSTALL_MANODIR)
+ if test -d $(INSTALL_BINDIR); then : ; else $(BSD_INSTALL_PROGRAM_DIR) $(INSTALL_BINDIR); fi
+ if test -d $(INSTALL_LIBDIR); then : ; else $(BSD_INSTALL_DATA_DIR) $(INSTALL_LIBDIR); fi
+ if test -d $(INSTALL_CUSTOMDIR); then : ; else $(BSD_INSTALL_DATA_DIR) $(INSTALL_CUSTOMDIR); fi
+ $(BSD_INSTALL_SCRIPT) $(OCAMLDOC) $(INSTALL_BINDIR)/$(OCAMLDOC)$(EXE)
+ $(BSD_INSTALL_DATA) ocamldoc.hva *.cmi $(OCAMLDOC_LIBCMA) $(INSTALL_LIBDIR)
+ $(BSD_INSTALL_DATA) $(INSTALL_MLIS) $(INSTALL_CMIS) $(INSTALL_LIBDIR)
+ if test -d $(INSTALL_MANODIR); then : ; else $(BSD_INSTALL_DATA_DIR) $(INSTALL_MANODIR); fi
+ if test -d stdlib_man; then $(BSD_INSTALL_DATA) stdlib_man/* $(INSTALL_MANODIR); else : ; fi
installopt:
if test -f $(OCAMLDOC_OPT) ; then $(MAKE) installopt_really ; fi
@ -55,11 +32,11 @@ $NetBSD: patch-aw,v 1.8 2010/11/28 08:41:33 is Exp $
- $(CP) $(OCAMLDOC_OPT) $(INSTALL_BINDIR)/$(OCAMLDOC_OPT)$(EXE)
- $(CP) ocamldoc.hva $(OCAMLDOC_LIBA) $(OCAMLDOC_LIBCMXA) $(INSTALL_LIBDIR)
- $(CP) $(INSTALL_MLIS) $(INSTALL_CMIS) $(INSTALL_LIBDIR)
+ if test -d $(INSTALL_BINDIR); then : ; else ${BSD_INSTALL_PROGRAM_DIR} $(INSTALL_BINDIR); fi
+ if test -d $(INSTALL_LIBDIR); then : ; else ${BSD_INSTALL_DATA_DIR} $(INSTALL_LIBDIR); fi
+ ${BSD_INSTALL_PROGRAM} $(OCAMLDOC_OPT) $(INSTALL_BINDIR)/$(OCAMLDOC_OPT)$(EXE)
+ ${BSD_INSTALL_DATA} ocamldoc.hva $(OCAMLDOC_LIBA) $(OCAMLDOC_LIBCMXA) $(INSTALL_LIBDIR)
+ ${BSD_INSTALL_DATA} $(INSTALL_MLIS) $(INSTALL_CMIS) $(INSTALL_LIBDIR)
+ if test -d $(INSTALL_BINDIR); then : ; else $(BSD_INSTALL_PROGRAM_DIR) $(INSTALL_BINDIR); fi
+ if test -d $(INSTALL_LIBDIR); then : ; else $(BSD_INSTALL_DATA_DIR) $(INSTALL_LIBDIR); fi
+ $(BSD_INSTALL_PROGRAM) $(OCAMLDOC_OPT) $(INSTALL_BINDIR)/$(OCAMLDOC_OPT)$(EXE)
+ $(BSD_INSTALL_DATA) ocamldoc.hva $(OCAMLDOC_LIBA) $(OCAMLDOC_LIBCMXA) $(INSTALL_LIBDIR)
+ $(BSD_INSTALL_DATA) $(INSTALL_MLIS) $(INSTALL_CMIS) $(INSTALL_LIBDIR)
# Testing :
###########

View file

@ -1,7 +1,7 @@
$NetBSD: patch-bs,v 1.7 2010/08/19 08:06:53 asau Exp $
$NetBSD: patch-bs,v 1.8 2012/03/04 09:06:46 asau Exp $
--- tools/Makefile.shared.orig 2010-06-07 10:58:41.000000000 +0400
+++ tools/Makefile.shared 2010-08-12 14:44:51.000000000 +0400
--- tools/Makefile.shared.orig 2010-10-15 19:36:55.000000000 +0400
+++ tools/Makefile.shared 2012-03-04 07:13:54.000000000 +0400
@@ -52,9 +52,9 @@
rm -f ocamldep.opt
@ -14,7 +14,7 @@ $NetBSD: patch-bs,v 1.7 2010/08/19 08:06:53 asau Exp $
# The profiler
@@ -70,15 +70,15 @@
@@ -70,9 +70,9 @@
$(CAMLC) $(LINKFLAGS) -o ocamlcp warnings.cmo main_args.cmo ocamlcp.cmo
install::
@ -27,14 +27,7 @@ $NetBSD: patch-bs,v 1.7 2010/08/19 08:06:53 asau Exp $
clean::
rm -f ocamlprof ocamlcp
install::
- cp ocamlmktop $(BINDIR)/ocamlmktop$(EXE)
+ $(BSD_INSTALL_SCRIPT) ocamlmktop $(BINDIR)/ocamlmktop$(EXE)
clean::
rm -f ocamlmktop
@@ -98,7 +98,7 @@
@@ -93,7 +93,7 @@
cp ../myocamlbuild_config.ml .
install::
@ -43,16 +36,16 @@ $NetBSD: patch-bs,v 1.7 2010/08/19 08:06:53 asau Exp $
clean::
rm -f ocamlmklib
@@ -122,7 +122,7 @@
@@ -117,7 +117,7 @@
# To make custom toplevels (see Makefile/Makefile.nt)
install::
- cp ocamlmktop $(BINDIR)/ocamlmktop$(EXE)
+ $(BSD_INSTALL_SCRIPT) ocamlmktop $(BINDIR)/ocamlmktop$(EXE)
- cp ocamlmktop $(BINDIR)/ # no $(EXE) here, ocamlmktop is a script
+ $(BSD_INSTALL_SCRIPT) ocamlmktop $(BINDIR)/ # no $(EXE) here, ocamlmktop is a script
clean::
rm -f ocamlmktop
@@ -239,8 +239,8 @@
@@ -234,8 +234,8 @@
$(CAMLC) -o objinfo $(OBJINFO)
install::