Add wm/mcwm.
mcwm is a minimalist window manager for the X Window System written from scratch in C directly on top of XCB. It is a traditional floating window manager with a lot of features but without the bloat. In mcwm all functions, including move and resize, are available from the keyboard but a pointing device can be used for move, resize and raise/lower.
This commit is contained in:
parent
66eef91442
commit
63cd621d98
6 changed files with 66 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.157 2020/12/11 15:12:35 nia Exp $
|
||||
# $NetBSD: Makefile,v 1.158 2021/01/04 14:52:58 nia Exp $
|
||||
#
|
||||
|
||||
COMMENT= X11 window managers, configuration tools, and themes
|
||||
|
@ -59,6 +59,7 @@ SUBDIR+= lwm
|
|||
SUBDIR+= marco
|
||||
SUBDIR+= matchbox-wm
|
||||
SUBDIR+= mate-netbook
|
||||
SUBDIR+= mcwm
|
||||
SUBDIR+= mlvwm
|
||||
SUBDIR+= musca
|
||||
SUBDIR+= mutter
|
||||
|
|
6
wm/mcwm/DESCR
Normal file
6
wm/mcwm/DESCR
Normal file
|
@ -0,0 +1,6 @@
|
|||
mcwm is a minimalist window manager for the X Window System written from
|
||||
scratch in C directly on top of XCB. It is a traditional floating window
|
||||
manager with a lot of features but without the bloat.
|
||||
|
||||
In mcwm all functions, including move and resize, are available from the
|
||||
keyboard but a pointing device can be used for move, resize and raise/lower.
|
29
wm/mcwm/Makefile
Normal file
29
wm/mcwm/Makefile
Normal file
|
@ -0,0 +1,29 @@
|
|||
# $NetBSD: Makefile,v 1.1 2021/01/04 14:52:58 nia Exp $
|
||||
|
||||
DISTNAME= mcwm-20130209-2
|
||||
PKGNAME= mcwm-20130209.2
|
||||
CATEGORIES= wm x11
|
||||
MASTER_SITES= https://hack.org/mc/hacks/mcwm/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= https://hack.org/mc/hacks/mcwm/
|
||||
COMMENT= Minimalist stacking X window manager based on XCB
|
||||
LICENSE= isc
|
||||
|
||||
INSTALLATION_DIRS+= bin
|
||||
INSTALLATION_DIRS+= ${PKGMANDIR}/man1
|
||||
|
||||
do-install:
|
||||
.for prog in mcwm hidden
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${prog} \
|
||||
${DESTDIR}${PREFIX}/bin/${prog}
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${prog}.man \
|
||||
${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/${prog}.1
|
||||
.endfor
|
||||
|
||||
.include "../../x11/libxcb/buildlink3.mk"
|
||||
.include "../../x11/xcb-util/buildlink3.mk"
|
||||
.include "../../x11/xcb-util-wm/buildlink3.mk"
|
||||
.include "../../x11/xcb-util-keysyms/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
5
wm/mcwm/PLIST
Normal file
5
wm/mcwm/PLIST
Normal file
|
@ -0,0 +1,5 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2021/01/04 14:52:58 nia Exp $
|
||||
bin/hidden
|
||||
bin/mcwm
|
||||
man/man1/hidden.1
|
||||
man/man1/mcwm.1
|
7
wm/mcwm/distinfo
Normal file
7
wm/mcwm/distinfo
Normal file
|
@ -0,0 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1 2021/01/04 14:52:58 nia Exp $
|
||||
|
||||
SHA1 (mcwm-20130209-2.tar.bz2) = af00a533132d3bd4bf81107ef28496bd8e91a6ed
|
||||
RMD160 (mcwm-20130209-2.tar.bz2) = 0c861a4439fd28e64a3c727592eded7849b680db
|
||||
SHA512 (mcwm-20130209-2.tar.bz2) = 0cc37b6eb12ec83078f20d9e174a7489dc72cec0f5486235271d955b9a6456945ebe363cb980e22ed96598e4362e9b6183686b3a17ea15a9152694b62ce87026
|
||||
Size (mcwm-20130209-2.tar.bz2) = 31948 bytes
|
||||
SHA1 (patch-Makefile) = a4b05c2a3eed7d561843e338b181cca8686934f4
|
17
wm/mcwm/patches/patch-Makefile
Normal file
17
wm/mcwm/patches/patch-Makefile
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-Makefile,v 1.1 2021/01/04 14:52:58 nia Exp $
|
||||
|
||||
Remove -g and default library paths from compilation flags.
|
||||
|
||||
--- Makefile.orig 2013-02-09 20:15:09.000000000 +0000
|
||||
+++ Makefile
|
||||
@@ -3,8 +3,8 @@ DIST=mcwm-$(VERSION)
|
||||
SRC=mcwm.c list.c config.h events.h list.h hidden.c
|
||||
DISTFILES=LICENSE Makefile NEWS README TODO WISHLIST mcwm.man hidden.man scripts $(SRC)
|
||||
|
||||
-CFLAGS+=-g -std=c99 -Wall -Wextra -I/usr/local/include #-DDEBUG #-DDMALLOC
|
||||
-LDFLAGS+=-L/usr/local/lib -lxcb -lxcb-randr -lxcb-keysyms -lxcb-icccm \
|
||||
+CFLAGS+=-std=c99 -Wall -Wextra -I/usr/local/include #-DDEBUG #-DDMALLOC
|
||||
+LDFLAGS+=-lxcb -lxcb-randr -lxcb-keysyms -lxcb-icccm \
|
||||
-lxcb-util #-ldmalloc
|
||||
|
||||
RM=/bin/rm
|
Loading…
Reference in a new issue