Update to nullmailer-100RC7.
Changes for pkgsrc: * Added an rc.d/nullmailer script * Added brief instructions on how to set up nullmailer in MESSAGE. * Changed spool directory from /var/nullmailer to /var/spool/nullmailer Changes in nullmailer itself: Changes in version 1.00RC7 - Fixed typo in smtp protocol module that caused HELO to be sent without a hostname. - Added a one-shot mode to nullmailer-send, triggered by setting the pausetime to zero. Note: If no further bugs are found, this will become the official version 1.00 release. Changes in version 1.00RC6 - Protocol modules now report all failure and success messages. - Removed the whole gethostname/getdomainname mess and replaced it with code to read the hostname from the "me" control file, and the default domain name from the "defaultdomain" control file. - Fixed a bug that would cause lines starting with a period to have that period stripped when it was sent via SMTP. - Added some missing includes to fix compilation failures in various sources. - Fixed a bug in the setenv function in sendmail.cc. NOTE! Make sure to set up the new "me" control file before using this version. The RPM install does this automatically.
This commit is contained in:
parent
f86c8ec1b5
commit
63cdf68f7c
8 changed files with 159 additions and 75 deletions
39
mail/nullmailer/MESSAGE
Normal file
39
mail/nullmailer/MESSAGE
Normal file
|
@ -0,0 +1,39 @@
|
||||||
|
===========================================================================
|
||||||
|
$NetBSD: MESSAGE,v 1.1 2003/02/17 01:45:31 jtb Exp $
|
||||||
|
|
||||||
|
To use nullmailer, you will need to perform the following steps:
|
||||||
|
|
||||||
|
1. Create a ${PKG_SYSCONFDIR}/nullmailer/remotes file. The file should
|
||||||
|
contain a line with the name of your relay host and the
|
||||||
|
relay protocol to be used, eg.
|
||||||
|
|
||||||
|
smtp.relayhost.domain smtp
|
||||||
|
|
||||||
|
2. Back up /etc/mailer.conf and create a new mailer.conf with the
|
||||||
|
following lines
|
||||||
|
|
||||||
|
# Use "nullmailer" as replacement for "sendmail".
|
||||||
|
sendmail ${PREFIX}/libexec/nullmailer/sendmail
|
||||||
|
send-mail ${PREFIX}/libexec/nullmailer/sendmail
|
||||||
|
mailq ${PREFIX}/libexec/nullmailer/mailq
|
||||||
|
|
||||||
|
3. Copy ${PKG_SYSCONFDIR}/rc.d/nullmailer to /etc/rc.d/nullmailer
|
||||||
|
and add
|
||||||
|
|
||||||
|
nullmailer=YES
|
||||||
|
|
||||||
|
to /etc/rc.conf. Other MTA's, (eg. sendmail, exim), should be set
|
||||||
|
to NO.
|
||||||
|
|
||||||
|
4. Stop any other running MTA. Now start nullmailer by issuing the
|
||||||
|
command
|
||||||
|
|
||||||
|
/etc/rc.d/nullmailer start
|
||||||
|
|
||||||
|
5. You may need to add further configuration files to the directory
|
||||||
|
${PKG_SYSCONFDIR}/nullmailer. These include the `adminaddr',
|
||||||
|
`defaultdomain', `defaulthost', `idhost', `me', and `pausetime'
|
||||||
|
files. This will depend on your local setup. See the
|
||||||
|
nullmailer(7), nullmailer-queue(8), and nullmailer-send(8) manual
|
||||||
|
pages for details.
|
||||||
|
===========================================================================
|
|
@ -1,6 +1,6 @@
|
||||||
# $NetBSD: Makefile,v 1.4 2003/01/28 22:03:35 jlam Exp $
|
# $NetBSD: Makefile,v 1.5 2003/02/17 01:45:31 jtb Exp $
|
||||||
|
|
||||||
DISTNAME= nullmailer-1.00RC5
|
DISTNAME= nullmailer-1.00RC7
|
||||||
CATEGORIES= mail
|
CATEGORIES= mail
|
||||||
MASTER_SITES= http://untroubled.org/nullmailer/
|
MASTER_SITES= http://untroubled.org/nullmailer/
|
||||||
|
|
||||||
|
@ -8,9 +8,10 @@ MAINTAINER= packages@netbsd.org
|
||||||
HOMEPAGE= http://untroubled.org/nullmailer/
|
HOMEPAGE= http://untroubled.org/nullmailer/
|
||||||
COMMENT= Simple relay-only mail transport agent
|
COMMENT= Simple relay-only mail transport agent
|
||||||
|
|
||||||
USE_PKGINSTALL= yes
|
|
||||||
GNU_CONFIGURE= yes
|
GNU_CONFIGURE= yes
|
||||||
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR} --localstatedir=/var
|
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR} --localstatedir=/var/spool
|
||||||
|
CONFIGURE_ARGS+= --bindir=${PREFIX}/libexec/nullmailer
|
||||||
|
CONFIGURE_ARGS+= --sbindir=${PREFIX}/libexec/nullmailer
|
||||||
|
|
||||||
INSTALL_TARGET= install install-data-local install-root
|
INSTALL_TARGET= install install-data-local install-root
|
||||||
|
|
||||||
|
@ -24,8 +25,7 @@ PKG_USERS?= ${NULLMAILER_USER}:${NULLMAILER_GROUP}
|
||||||
MAKE_ENV+= NULLMAILER_GROUP=${NULLMAILER_GROUP}
|
MAKE_ENV+= NULLMAILER_GROUP=${NULLMAILER_GROUP}
|
||||||
MAKE_ENV+= NULLMAILER_USER=${NULLMAILER_USER}
|
MAKE_ENV+= NULLMAILER_USER=${NULLMAILER_USER}
|
||||||
|
|
||||||
PLIST_SUBST+= PKG_SYSCONFDIR=${PKG_SYSCONFDIR} \
|
PLIST_SUBST+= NULLMAILER_GROUP=${NULLMAILER_GROUP} \
|
||||||
NULLMAILER_GROUP=${NULLMAILER_GROUP} \
|
|
||||||
NULLMAILER_USER=${NULLMAILER_USER}
|
NULLMAILER_USER=${NULLMAILER_USER}
|
||||||
|
|
||||||
pre-configure:
|
pre-configure:
|
||||||
|
@ -39,5 +39,7 @@ post-install:
|
||||||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/nullmailer
|
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/nullmailer
|
||||||
cd ${WRKSRC} && ${INSTALL_DATA} AUTHORS BUGS COPYING ChangeLog \
|
cd ${WRKSRC} && ${INSTALL_DATA} AUTHORS BUGS COPYING ChangeLog \
|
||||||
HOWTO NEWS README TODO ${PREFIX}/share/doc/nullmailer
|
HOWTO NEWS README TODO ${PREFIX}/share/doc/nullmailer
|
||||||
|
${INSTALL_DATA} ${FILESDIR}/nullmailer ${PKG_SYSCONFDIR}/rc.d
|
||||||
|
|
||||||
|
.include "../../mk/bsd.pkg.install.mk"
|
||||||
.include "../../mk/bsd.pkg.mk"
|
.include "../../mk/bsd.pkg.mk"
|
||||||
|
|
|
@ -1,18 +1,20 @@
|
||||||
@comment $NetBSD: PLIST,v 1.3 2002/12/09 16:01:32 tron Exp $
|
@comment $NetBSD: PLIST,v 1.4 2003/02/17 01:45:31 jtb Exp $
|
||||||
bin/mailq
|
libexec/nullmailer/mailq
|
||||||
@exec ${CHMOD} u+s %D/bin/mailq
|
@exec ${CHMOD} u+s %D/libexec/nullmailer/mailq
|
||||||
@exec ${CHOWN} ${NULLMAILER_USER}:${NULLMAILER_GROUP} %D/bin/mailq
|
@exec ${CHOWN} ${NULLMAILER_USER}:${NULLMAILER_GROUP} %D/libexec/nullmailer/mailq
|
||||||
bin/nullmailer-inject
|
libexec/nullmailer/nullmailer-inject
|
||||||
|
libexec/nullmailer/nullmailer-queue
|
||||||
|
@exec ${CHMOD} u+s %D/libexec/nullmailer/nullmailer-queue
|
||||||
|
@exec ${CHOWN} ${NULLMAILER_USER}:${NULLMAILER_GROUP} %D/libexec/nullmailer/nullmailer-queue
|
||||||
|
libexec/nullmailer/nullmailer-send
|
||||||
libexec/nullmailer/qmqp
|
libexec/nullmailer/qmqp
|
||||||
|
libexec/nullmailer/sendmail
|
||||||
libexec/nullmailer/smtp
|
libexec/nullmailer/smtp
|
||||||
man/man1/nullmailer-inject.1
|
man/man1/nullmailer-inject.1
|
||||||
man/man1/sendmail.1
|
man/man1/sendmail.1
|
||||||
man/man7/nullmailer.7
|
man/man7/nullmailer.7
|
||||||
sbin/nullmailer-queue
|
man/man8/nullmailer-queue.8
|
||||||
@exec ${CHMOD} u+s %D/sbin/nullmailer-queue
|
man/man8/nullmailer-send.8
|
||||||
@exec ${CHOWN} ${NULLMAILER_USER}:${NULLMAILER_GROUP} %D/sbin/nullmailer-queue
|
|
||||||
sbin/nullmailer-send
|
|
||||||
sbin/sendmail
|
|
||||||
share/doc/nullmailer/AUTHORS
|
share/doc/nullmailer/AUTHORS
|
||||||
share/doc/nullmailer/BUGS
|
share/doc/nullmailer/BUGS
|
||||||
share/doc/nullmailer/COPYING
|
share/doc/nullmailer/COPYING
|
||||||
|
@ -21,16 +23,16 @@ share/doc/nullmailer/HOWTO
|
||||||
share/doc/nullmailer/NEWS
|
share/doc/nullmailer/NEWS
|
||||||
share/doc/nullmailer/README
|
share/doc/nullmailer/README
|
||||||
share/doc/nullmailer/TODO
|
share/doc/nullmailer/TODO
|
||||||
@exec ${MKDIR} /var/nullmailer
|
@exec ${MKDIR} /var/spool/nullmailer
|
||||||
@exec ${MKDIR} /var/nullmailer/queue
|
@exec ${MKDIR} /var/spool/nullmailer/queue
|
||||||
@exec ${MKDIR} /var/nullmailer/tmp
|
@exec ${MKDIR} /var/spool/nullmailer/tmp
|
||||||
@exec mkfifo /var/nullmailer/trigger
|
@exec mkfifo /var/spool/nullmailer/trigger
|
||||||
@exec ${CHMOD} 600 /var/nullmailer/trigger
|
@exec ${CHMOD} 600 /var/spool/nullmailer/trigger
|
||||||
@exec ${CHOWN} -R ${NULLMAILER_USER}:${NULLMAILER_GROUP} /var/nullmailer/*
|
@exec ${CHOWN} -R ${NULLMAILER_USER}:${NULLMAILER_GROUP} /var/spool/nullmailer/*
|
||||||
@dirrm libexec/nullmailer
|
@dirrm libexec/nullmailer
|
||||||
@dirrm share/doc/nullmailer
|
@dirrm share/doc/nullmailer
|
||||||
@unexec ${RMDIR} ${PKG_SYSCONFDIR}/nullmailer 2>/dev/null || ${TRUE}
|
@unexec ${RMDIR} ${PKG_SYSCONFDIR}/nullmailer 2>/dev/null || ${TRUE}
|
||||||
@unexec ${RMDIR} /var/nullmailer/queue 2>/dev/null || ${TRUE}
|
@unexec ${RMDIR} /var/spool/nullmailer/queue 2>/dev/null || ${TRUE}
|
||||||
@unexec ${RMDIR} /var/nullmailer/tmp 2>/dev/null || ${TRUE}
|
@unexec ${RMDIR} /var/spool/nullmailer/tmp 2>/dev/null || ${TRUE}
|
||||||
@unexec ${RM} -f /var/nullmailer/trigger 2>/dev/null || ${TRUE}
|
@unexec ${RM} -f /var/spool/nullmailer/trigger 2>/dev/null || ${TRUE}
|
||||||
@unexec ${RMDIR} /var/nullmailer 2>/dev/null || ${TRUE}
|
@unexec ${RMDIR} /var/spool/nullmailer 2>/dev/null || ${TRUE}
|
||||||
|
|
|
@ -1,7 +1,7 @@
|
||||||
$NetBSD: distinfo,v 1.3 2002/07/02 12:58:15 wiz Exp $
|
$NetBSD: distinfo,v 1.4 2003/02/17 01:45:31 jtb Exp $
|
||||||
|
|
||||||
SHA1 (nullmailer-1.00RC5.tar.gz) = 5d47098fc5cdbf2db3b40ef2c81e83867e7a7410
|
SHA1 (nullmailer-1.00RC7.tar.gz) = 9e9babbba203eb353cb581c17e097c8489992b41
|
||||||
Size (nullmailer-1.00RC5.tar.gz) = 111691 bytes
|
Size (nullmailer-1.00RC7.tar.gz) = 115253 bytes
|
||||||
SHA1 (patch-aa) = d7ceeca053ca504232c4a50037e4985315b4ebf5
|
SHA1 (patch-aa) = cc5ee1356d9759c53579e1115d409a0af0d80a3e
|
||||||
SHA1 (patch-ab) = cc5ee1356d9759c53579e1115d409a0af0d80a3e
|
SHA1 (patch-ab) = b730da62ec28d1210d826d13cc49eb431ae2fb04
|
||||||
SHA1 (patch-ac) = f8c8b1df4fe97ca2ab4780a58be707fe79e83e55
|
SHA1 (patch-ac) = 7bc58b34b5a1d341dd91d2ce86a11dc962282a6e
|
||||||
|
|
25
mail/nullmailer/files/nullmailer
Executable file
25
mail/nullmailer/files/nullmailer
Executable file
|
@ -0,0 +1,25 @@
|
||||||
|
#!/bin/sh
|
||||||
|
#
|
||||||
|
# $NetBSD: nullmailer,v 1.1 2003/02/17 01:45:32 jtb Exp $
|
||||||
|
#
|
||||||
|
# PROVIDE: mail
|
||||||
|
# REQUIRE: LOGIN
|
||||||
|
|
||||||
|
if [ -f /etc/rc.subr ]; then
|
||||||
|
. /etc/rc.subr
|
||||||
|
fi
|
||||||
|
|
||||||
|
name="nullmailer"
|
||||||
|
rcvar=$name
|
||||||
|
|
||||||
|
nullmailer_user="nullmail"
|
||||||
|
nullmailer_group="nullmail"
|
||||||
|
|
||||||
|
command="/usr/pkg/libexec/nullmailer/nullmailer-send"
|
||||||
|
command_args=" > /dev/null 2>&1 &"
|
||||||
|
|
||||||
|
required_files="/usr/pkg/etc/nullmailer/remotes /var/spool/nullmailer/trigger"
|
||||||
|
required_dirs="/var/spool/nullmailer/queue /var/spool/nullmailer/tmp"
|
||||||
|
|
||||||
|
load_rc_config $name
|
||||||
|
run_rc_command "$1"
|
|
@ -1,13 +1,18 @@
|
||||||
$NetBSD: patch-aa,v 1.1.1.1 2002/05/04 01:15:25 jtb Exp $
|
$NetBSD: patch-aa,v 1.2 2003/02/17 01:45:32 jtb Exp $
|
||||||
|
|
||||||
--- lib/mergelib.sh.orig Thu May 2 09:42:12 2002
|
--- Makefile.in.orig Mon May 13 17:39:12 2002
|
||||||
+++ lib/mergelib.sh Thu May 2 09:44:41 2002
|
+++ Makefile.in Mon May 13 17:38:58 2002
|
||||||
@@ -4,7 +4,7 @@
|
@@ -365,10 +365,10 @@
|
||||||
tmpdir=".libmerge.$archive.$$.$RANDOM.$USER"
|
chmod 600 $(DESTDIR)$(localstatedir)/trigger
|
||||||
mkdir "$tmpdir"
|
|
||||||
cd "$tmpdir"
|
install-root:
|
||||||
-trap 'cd ..; rm -rf "$tmpdir"' EXIT
|
- chown nullmail $(DESTDIR)$(localstatedir)/*
|
||||||
+trap 'cd ..; rm -rf "$tmpdir"'
|
- chown nullmail $(DESTDIR)$(sbindir)/nullmailer-queue
|
||||||
for input in "$@"; do
|
+ chown ${NULLMAILER_USER}:${NULLMAILER_GROUP} $(DESTDIR)$(localstatedir)/*
|
||||||
dir="`basename "$input"`"
|
+ chown ${NULLMAILER_USER}:${NULLMAILER_GROUP} $(DESTDIR)$(sbindir)/nullmailer-queue
|
||||||
mkdir "$dir"
|
chmod u+s $(DESTDIR)$(sbindir)/nullmailer-queue
|
||||||
|
- chown nullmail $(DESTDIR)$(bindir)/mailq
|
||||||
|
+ chown ${NULLMAILER_USER}:${NULLMAILER_GROUP} $(DESTDIR)$(bindir)/mailq
|
||||||
|
chmod u+s $(DESTDIR)$(bindir)/mailq
|
||||||
|
|
||||||
|
dist-hook:
|
||||||
|
|
|
@ -1,18 +1,25 @@
|
||||||
$NetBSD: patch-ab,v 1.1 2002/05/14 00:35:24 jtb Exp $
|
$NetBSD: patch-ab,v 1.2 2003/02/17 01:45:32 jtb Exp $
|
||||||
|
|
||||||
--- Makefile.in.orig Mon May 13 17:39:12 2002
|
--- doc/nullmailer-send.8.orig Fri Jan 3 20:50:07 2003
|
||||||
+++ Makefile.in Mon May 13 17:38:58 2002
|
+++ doc/nullmailer-send.8
|
||||||
@@ -365,10 +365,10 @@
|
@@ -66,16 +66,16 @@ For example, to connect to port 2525 on
|
||||||
chmod 600 $(DESTDIR)$(localstatedir)/trigger
|
Blank lines and lines starting with a pound are ignored.
|
||||||
|
.SH FILES
|
||||||
install-root:
|
.TP
|
||||||
- chown nullmail $(DESTDIR)$(localstatedir)/*
|
-.B /var/nullmailer/queue
|
||||||
- chown nullmail $(DESTDIR)$(sbindir)/nullmailer-queue
|
+.B /var/spool/nullmailer/queue
|
||||||
+ chown ${NULLMAILER_USER}:${NULLMAILER_GROUP} $(DESTDIR)$(localstatedir)/*
|
The message queue.
|
||||||
+ chown ${NULLMAILER_USER}:${NULLMAILER_GROUP} $(DESTDIR)$(sbindir)/nullmailer-queue
|
.TP
|
||||||
chmod u+s $(DESTDIR)$(sbindir)/nullmailer-queue
|
-.B /var/nullmailer/trigger
|
||||||
- chown nullmail $(DESTDIR)$(bindir)/mailq
|
+.B /var/spool/nullmailer/trigger
|
||||||
+ chown ${NULLMAILER_USER}:${NULLMAILER_GROUP} $(DESTDIR)$(bindir)/mailq
|
A trigger file to cause immediate delivery.
|
||||||
chmod u+s $(DESTDIR)$(bindir)/mailq
|
.TP
|
||||||
|
-.B /usr/local/etc/nullmailer
|
||||||
dist-hook:
|
+.B @PKG_SYSCONFDIR@/nullmailer
|
||||||
|
The configuration directory.
|
||||||
|
.TP
|
||||||
|
-.B /usr/local/libexec/nullmailer
|
||||||
|
+.B @PREFIX@/libexec/nullmailer
|
||||||
|
The protocol program directory.
|
||||||
|
.SH SEE ALSO
|
||||||
|
nullmailer-queue(8),
|
||||||
|
|
|
@ -1,17 +1,21 @@
|
||||||
$NetBSD: patch-ac,v 1.1 2002/05/14 00:35:24 jtb Exp $
|
$NetBSD: patch-ac,v 1.2 2003/02/17 01:45:32 jtb Exp $
|
||||||
|
|
||||||
--- doc/nullmailer-send.8.orig Tue May 14 01:33:23 2002
|
--- doc/nullmailer-queue.8.orig Mon Dec 23 17:29:20 2002
|
||||||
+++ doc/nullmailer-send.8 Tue May 14 01:33:55 2002
|
+++ doc/nullmailer-queue.8
|
||||||
@@ -61,10 +61,10 @@
|
@@ -30,13 +30,13 @@ This is provided to allow local daemons
|
||||||
.B /var/nullmailer/trigger
|
being bounced by your relay host.
|
||||||
A trigger file to cause immediate delivery.
|
.SH OTHER FILES
|
||||||
.TP
|
.TP
|
||||||
-.B /usr/local/etc/nullmailer
|
-.B /var/nullmailer/queue
|
||||||
+.B @PKG_SYSCONFDIR@/nullmailer
|
+.B /var/spool/nullmailer/queue
|
||||||
The configuration directory.
|
The directory into which the completed messages are moved.
|
||||||
.TP
|
.TP
|
||||||
-.B /usr/local/libexec/nullmailer
|
-.B /var/nullmailer/tmp
|
||||||
+.B @PREFIX@/libexec/nullmailer
|
+.B /var/spool/nullmailer/tmp
|
||||||
The protocol program directory.
|
The directory in which messages are formed temporarily.
|
||||||
.SH SEE ALSO
|
.TP
|
||||||
nullmailer-queue(8),
|
-.B /var/nullmailer/trigger
|
||||||
|
+.B /var/spool/nullmailer/trigger
|
||||||
|
A pipe used to trigger
|
||||||
|
.BR nullmailer-send
|
||||||
|
to immediately start sending the message from the queue.
|
||||||
|
|
Loading…
Reference in a new issue