include <QPainterPath> to fix build with current version of Qt.

This commit is contained in:
bouyer 2020-08-21 11:31:28 +00:00
parent ad7aebbb58
commit 63d40c0bbb
2 changed files with 16 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.4 2019/12/10 13:55:44 nros Exp $
$NetBSD: distinfo,v 1.5 2020/08/21 11:31:28 bouyer Exp $
SHA1 (XyGrib-1.1.1/XyGrib-1.2.6.1.tar.gz) = 8e3431ed6a5ef114d77ac57029129a26a381f696
RMD160 (XyGrib-1.1.1/XyGrib-1.2.6.1.tar.gz) = 876e8a53b492b2e2ea0572e5b0cd31a2c04f505a
@ -14,3 +14,4 @@ SHA512 (XyGrib-1.1.1/XyGrib___cities_files.tar.gz) = 6bb9362c87fec7633b0ad1fd3b8
Size (XyGrib-1.1.1/XyGrib___cities_files.tar.gz) = 2487518 bytes
SHA1 (patch-CMakeLists.txt) = f12e4cc04e94919a8ed5824df859b0573612ab02
SHA1 (patch-src_CMakeLists.txt) = 3a06026a033e2dbe93ea9d08c48d87f51186918a
SHA1 (patch-src_SkewT.h) = 71f5d89e04aa4faa8e4812cca82186a834e5786f

View file

@ -0,0 +1,14 @@
$NetBSD: patch-src_SkewT.h,v 1.1 2020/08/21 11:31:28 bouyer Exp $
Fix undeclared class QPainterPath
--- src/SkewT.h.orig 2020-08-21 13:09:55.133572321 +0200
+++ src/SkewT.h 2020-08-21 13:10:05.207772962 +0200
@@ -16,6 +16,7 @@
#include <QMainWindow>
#include <QFrame>
#include <QPainter>
+#include <QPainterPath>
#include <QLayout>
#include <QKeyEvent>
#include <QPrintDialog>