x11/compton: Switch upstream to the same fork as Arch Linux, update to 4.0.
Take maintainership. Notable changes (no changelog is available): * [pkgsrc] Some dependencies made into options. * The paint-on-overlay configuration option was removed, and is now enabled by default. * The xrender-sync and xrender-sync-fence options were removed. * Moved most of the X functions (XShape, XComposite, Xrender, Xinerama, etc.) to xcb. * Moved from server side region (Xfixes) to client side (pixman). * Use libev for I/O and timeout events.
This commit is contained in:
parent
f0c30f5307
commit
640b1110a7
4 changed files with 76 additions and 22 deletions
|
@ -1,23 +1,23 @@
|
|||
# $NetBSD: Makefile,v 1.3 2016/03/12 21:53:39 tnn Exp $
|
||||
# $NetBSD: Makefile,v 1.4 2018/12/01 13:23:51 nia Exp $
|
||||
|
||||
GITHUB_PROJECT= compton
|
||||
GITHUB_TAG= d7f95b56b176281bfb252c54defef48c9cd1f4e1
|
||||
DISTNAME= compton-20150920
|
||||
DISTNAME= compton-4.0
|
||||
CATEGORIES= x11 wm
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=chjj/}
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=yshui/}
|
||||
GITHUB_TAG= v4
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
MAINTAINER= nia@NetBSD.org
|
||||
HOMEPAGE= https://github.com/chjj/compton
|
||||
COMMENT= Configurable compositing manager for X11
|
||||
LICENSE= mit
|
||||
|
||||
BUILD_DEPENDS+= asciidoc-[0-9]*:../../textproc/asciidoc
|
||||
|
||||
EXTRACT_USING= bsdtar
|
||||
USE_TOOLS+= gmake pkg-config
|
||||
NO_CONFIGURE= yes
|
||||
BUILD_TARGET= compton docs
|
||||
MAKE_FLAGS+= MANDIR=${PREFIX}/${PKGMANDIR}/man1
|
||||
MAKE_FLAGS+= COMPTON_VERSION=git-${PKGVERSION_NOREV}
|
||||
MAKE_FLAGS+= COMPTON_VERSION=${PKGVERSION}
|
||||
|
||||
INSTALLATION_DIRS+= share/examples/compton
|
||||
|
||||
|
@ -25,19 +25,15 @@ post-install:
|
|||
${INSTALL_DATA} ${WRKSRC}/compton.sample.conf \
|
||||
${DESTDIR}${PREFIX}/share/examples/compton
|
||||
|
||||
.include "options.mk"
|
||||
.include "../../devel/libconfig/buildlink3.mk"
|
||||
.include "../../devel/pcre/buildlink3.mk"
|
||||
.include "../../graphics/MesaLib/buildlink3.mk"
|
||||
.include "../../devel/libev/buildlink3.mk"
|
||||
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
|
||||
.include "../../sysutils/dbus/buildlink3.mk"
|
||||
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
|
||||
.include "../../x11/libXcomposite/buildlink3.mk"
|
||||
.include "../../x11/libXdamage/buildlink3.mk"
|
||||
.include "../../x11/libxcb/buildlink3.mk"
|
||||
.include "../../x11/libXext/buildlink3.mk"
|
||||
.include "../../x11/libXfixes/buildlink3.mk"
|
||||
.include "../../x11/libXinerama/buildlink3.mk"
|
||||
.include "../../x11/libXrandr/buildlink3.mk"
|
||||
.include "../../x11/libXrender/buildlink3.mk"
|
||||
.include "../../x11/libX11/buildlink3.mk"
|
||||
.include "../../x11/libdrm/buildlink3.mk"
|
||||
.include "../../x11/pixman/buildlink3.mk"
|
||||
.include "../../x11/xcb-util-image/buildlink3.mk"
|
||||
.include "../../x11/xcb-util-renderutil/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.2 2015/11/04 03:28:26 agc Exp $
|
||||
$NetBSD: distinfo,v 1.3 2018/12/01 13:23:51 nia Exp $
|
||||
|
||||
SHA1 (compton-20150920-d7f95b56b176281bfb252c54defef48c9cd1f4e1.tar.gz) = 97c32266e60eff1db2e9a59c7077e0f56b11ee38
|
||||
RMD160 (compton-20150920-d7f95b56b176281bfb252c54defef48c9cd1f4e1.tar.gz) = 7fe9bc15bdecf08a91e2ef0fe4e139731ec0047b
|
||||
SHA512 (compton-20150920-d7f95b56b176281bfb252c54defef48c9cd1f4e1.tar.gz) = 302635b2a88c72497344f95a67227cb5ebec2149f891eb425eb215c63cd9ac7e70df72bdd48f80238b0a9c236489e093d4a8572a6517fe3931a480ee17659240
|
||||
Size (compton-20150920-d7f95b56b176281bfb252c54defef48c9cd1f4e1.tar.gz) = 163180 bytes
|
||||
SHA1 (compton-4.0.tar.gz) = f94eb9f964f2cc7c547a153c1f7e435bbaa32c8d
|
||||
RMD160 (compton-4.0.tar.gz) = f283e11f9d33b79d3c57c7d52e9013d0539b2e01
|
||||
SHA512 (compton-4.0.tar.gz) = ba585df25792519b8093a5a91d62ca2d3b02dd9df41d787dc4007cee5c8aef7cd0a3c267b58d21026c97b7859f7c5376384dffb7da728a99ccc4122a2ae43679
|
||||
Size (compton-4.0.tar.gz) = 171662 bytes
|
||||
SHA1 (patch-Makefile) = 240dcfc712d9697399a747f4c668a6c86fec317d
|
||||
|
|
31
x11/compton/options.mk
Normal file
31
x11/compton/options.mk
Normal file
|
@ -0,0 +1,31 @@
|
|||
# $NetBSD: options.mk,v 1.1 2018/12/01 13:23:51 nia Exp $
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.compton
|
||||
PKG_SUPPORTED_OPTIONS= dbus libdrm opengl pcre
|
||||
PKG_SUGGESTED_OPTIONS= dbus libdrm opengl pcre
|
||||
|
||||
.include "../../mk/bsd.options.mk"
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mdbus)
|
||||
.include "../../sysutils/dbus/buildlink3.mk"
|
||||
.else
|
||||
MAKE_FLAGS+= NO_DBUS=1
|
||||
.endif
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mlibdrm)
|
||||
.include "../../x11/libdrm/buildlink3.mk"
|
||||
.else
|
||||
MAKE_FLAGS+= NO_VSYNC_DRM=1
|
||||
.endif
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mopengl)
|
||||
.include "../../graphics/MesaLib/buildlink3.mk"
|
||||
.else
|
||||
MAKE_FLAGS+= NO_OPENGL=1
|
||||
.endif
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mpcre)
|
||||
.include "../../devel/pcre/buildlink3.mk"
|
||||
.else
|
||||
MAKE_FLAGS+= NO_REGEX_PCRE=1
|
||||
.endif
|
26
x11/compton/patches/patch-Makefile
Normal file
26
x11/compton/patches/patch-Makefile
Normal file
|
@ -0,0 +1,26 @@
|
|||
$NetBSD: patch-Makefile,v 1.1 2018/12/01 13:23:51 nia Exp $
|
||||
|
||||
Fix undefined symbols.
|
||||
|
||||
Honour CFLAGS.
|
||||
|
||||
--- Makefile.orig 2018-11-19 12:26:47.000000000 +0000
|
||||
+++ Makefile
|
||||
@@ -9,14 +9,14 @@ MANDIR ?= $(PREFIX)/share/man/man1
|
||||
APPDIR ?= $(PREFIX)/share/applications
|
||||
ICODIR ?= $(PREFIX)/share/icons/hicolor/
|
||||
|
||||
-PACKAGES = x11 x11-xcb xcb-renderutil xcb-render xcb-damage xcb-randr xcb-composite xcb-shape xcb-image xcb-xfixes xext pixman-1
|
||||
+PACKAGES = x11 x11-xcb xcb-renderutil xcb-render xcb-damage xcb-randr xcb-composite xcb-shape xcb-image xcb-xfixes xext pixman-1 xcb-present
|
||||
LIBS = -lm -lrt -lev
|
||||
INCS =
|
||||
|
||||
-OBJS = compton.o config.o win.o x.o
|
||||
+OBJS = compton.o config.o diagnostic.o win.o x.o
|
||||
|
||||
# === Configuration flags ===
|
||||
-CFG = -std=c11 -D_GNU_SOURCE -Wall -Wextra -Wno-unused-parameter -Wnonnull
|
||||
+CFG = $(CFLAGS) -std=c11 -D_GNU_SOURCE -Wall -Wextra -Wno-unused-parameter -Wnonnull
|
||||
|
||||
ifeq "$(CC)" "clang"
|
||||
CFG += -Wconditional-uninitialized
|
Loading…
Reference in a new issue