Fix build problem on NetBSD 1.6, and possibly other operating systems, where

ENOTSUP is not defined.
This commit is contained in:
shannonjr 2006-02-05 13:23:14 +00:00
parent 51c061b1ef
commit 64282fe5d3
2 changed files with 16 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.2 2006/01/31 10:44:45 shannonjr Exp $
$NetBSD: distinfo,v 1.3 2006/02/05 13:23:14 shannonjr Exp $
SHA1 (libprelude-0.9.4.tar.gz) = e300561bbbdcdbba4e4d9ca9fafc0529b546c7d0
RMD160 (libprelude-0.9.4.tar.gz) = de86fa000d1b23d3cbc69a013571670d9070a874
@ -6,3 +6,4 @@ Size (libprelude-0.9.4.tar.gz) = 1714892 bytes
SHA1 (patch-aa) = 1d788517feb2ef687777ae6640033d9f177b07f8
SHA1 (patch-ab) = 592f42a6d9217c502eb49e8fb0ba7d17a49f2ada
SHA1 (patch-ac) = 34f11cdf22cbdc843ed0db6ea017a56b2ec780ca
SHA1 (patch-ad) = 3947ebbf63bee2f657d39dc13b53be35bfea1edd

View file

@ -0,0 +1,14 @@
$NetBSD: patch-ad,v 1.1 2006/02/05 13:23:14 shannonjr Exp $
--- ./src/prelude-io.c.orig 2006-01-28 07:48:36.000000000 -0700
+++ ./src/prelude-io.c
@@ -28,6 +28,9 @@
#include <stdlib.h>
#include <unistd.h>
#include <errno.h>
+#ifndef ENOTSUP
+# define ENOTSUP EINVAL
+#endif
#include <sys/poll.h>
#include <sys/ioctl.h>
#include <netinet/in.h>