update to 0.7.21

changes:
* LSN's match MMC-3 specs better.
* Fix bug in vcd-info showing sequence number
* add --without-versioned-libs option
* make -mno-cygwin work
* release number is now preprocessor symbol so applications can make use of
  for compatibility
* More libcdio things moved into libcdio (e.g. MSF printing,
  iso9660 PVD handling)
* use generic list things from libcdio. Eventually everything will
  use glib. But this moves in the right direction by consolidating code
  a little
* Darwin compilation fixes
* Miscellaneous contributed bug fixes
This commit is contained in:
drochner 2005-05-03 10:29:13 +00:00
parent 7b5232bc70
commit 6442e50cdb
4 changed files with 6 additions and 34 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.23 2005/04/11 21:47:30 tv Exp $
# $NetBSD: Makefile,v 1.24 2005/05/03 10:29:13 drochner Exp $
#
DISTNAME= vcdimager-0.7.20
PKGREVISION= 3
DISTNAME= vcdimager-0.7.21
CATEGORIES= sysutils
MASTER_SITES= http://www.vcdimager.org/pub/vcdimager/vcdimager-0.7_UNSTABLE/

View file

@ -1,8 +1,6 @@
$NetBSD: distinfo,v 1.7 2005/02/24 13:40:58 agc Exp $
$NetBSD: distinfo,v 1.8 2005/05/03 10:29:13 drochner Exp $
SHA1 (vcdimager-0.7.20.tar.gz) = b75c9253bbd9f72f8b64b739e0c15bed5ac83bde
RMD160 (vcdimager-0.7.20.tar.gz) = ebf1b492a9d9f4f7fc4fa35511c5eadb3b883d36
Size (vcdimager-0.7.20.tar.gz) = 954324 bytes
SHA1 (patch-aa) = 6cf7c87a391e25addb324c37a9f929813725c712
SHA1 (patch-ab) = 6304d85224534797f52e14d283d79cf1e2be2f3f
SHA1 (vcdimager-0.7.21.tar.gz) = f34b476441982836b51744bac851eaee29d5cf68
RMD160 (vcdimager-0.7.21.tar.gz) = a61a91aebe965fbff2bcc0970641d317a05acb7f
Size (vcdimager-0.7.21.tar.gz) = 983861 bytes
SHA1 (patch-ac) = 7424deb20d9a74f5452491ef5c2b88dd8c0a6338

View file

@ -1,12 +0,0 @@
$NetBSD: patch-aa,v 1.3 2004/04/19 17:58:25 drochner Exp $
--- libvcdinfo.pc.in.orig 2004-04-18 18:52:30.000000000 +0000
+++ libvcdinfo.pc.in 2004-04-18 18:52:52.000000000 +0000
@@ -6,6 +6,6 @@
Name: libvcdinfo
Description: VCD information library
Version: @VERSION@
-Requires: libcdio libvcd
+Requires: libcdio
Libs: -L${libdir} -lvcdinfo
Cflags: -I${includedir}

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ab,v 1.3 2004/10/07 10:02:09 tron Exp $
--- lib/image.c.orig 2003-11-10 12:57:49.000000000 +0100
+++ lib/image.c 2004-10-07 11:57:38.000000000 +0200
@@ -76,7 +76,7 @@
}
int
-vcd_image_sink_write (VcdImageSink *obj, void *buf, uint32_t lsn)
+vcd_image_sink_write (VcdImageSink *obj, void *buf, lsn_t lsn)
{
vcd_assert (obj != NULL);