Be sure we actually use the db stuff as set up by bdb.buildlink3.mk.

This fixes a long standing build failure on SunOS-5.9/sparc and does
not seem to break things on NetBSD.
This commit is contained in:
dmcmahill 2007-10-07 20:49:57 +00:00
parent 643a873c93
commit 648ac07806
3 changed files with 63 additions and 3 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.191 2007/07/04 20:55:02 jlam Exp $
# $NetBSD: Makefile,v 1.192 2007/10/07 20:49:57 dmcmahill Exp $
#
# This pkg does not compile in mod_ssl, only the `mod_ssl EAPI' (a set of
# code hooks that allow mod_ssl to be compiled separately later, if desired).
@ -166,6 +166,18 @@ SUBST_SED.paths+= -e 's,@PKG_SYSCONFDIR@,${PKG_SYSCONFDIR},g'
SUBST_SED.paths+= -e 's,@VARBASE@,${VARBASE},g'
SUBST_STAGE.paths= post-patch
.include "../../mk/bdb.buildlink3.mk"
SUBST_CLASSES+= db
SUBST_STAGE.db= post-patch
SUBST_FILES.db= src/modules/standard/mod_auth_db.module
SUBST_SED.db+= -e 's,@DB_LIB@,${BDB_LIBS},g'
SUBST_SED.db+= -e 's,@DB_VERSION@,${BDB_TYPE},g'
.if defined(BDB_BASE) && !empty(BDB_BASE)
SUBST_SED.db+= -e 's,@DB_CFLAGS@,-I${BDB_BASE}/include,g'
.else
SUBST_SED.db+= -e 's,@DB_CFLAGS@,,g'
.endif
REPLACE_PERL= docs/cgi-examples/printenv
PKG_GROUPS= ${APACHE_GROUP}
@ -176,7 +188,6 @@ MAKE_ENV+= FIND=${FIND:Q} CHGRP=${CHGRP:Q}
.include "../../devel/libmm/buildlink3.mk"
.include "../../textproc/expat/buildlink3.mk"
.include "../../mk/bdb.buildlink3.mk"
.include "../../mk/dlopen.buildlink3.mk"
post-extract:

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.56 2007/06/28 01:24:39 lkundrak Exp $
$NetBSD: distinfo,v 1.57 2007/10/07 20:49:57 dmcmahill Exp $
SHA1 (apache_1.3.37.tar.gz) = b422fac1dda10baa483e8f4378dff58faf3f85b4
RMD160 (apache_1.3.37.tar.gz) = de84adf2fd0a745c32072ca5dc5e1374cfcf04f7
@ -22,6 +22,7 @@ SHA1 (patch-aj) = ac7337b51d7d4ca25cef4020961736404ec79f01
SHA1 (patch-ak) = 1be52fb5fca6c05c7cf489de541e0d52383ee43a
SHA1 (patch-al) = cdb6d8ecbf418024e8a198ebc9c8f15f259397c1
SHA1 (patch-am) = b8551fca1ec8a62b3b420435479a896a7de1dfe0
SHA1 (patch-an) = 45a5bf946628b1e1b2e60c217214965390f7b3d7
SHA1 (patch-ao) = 9ec5f32b2e9cf4c423b5d819fc76f652b27c6c29
SHA1 (patch-aq) = aee36110e604f990a1b017268810a28358c90178
SHA1 (patch-ar) = 882ad0cf40e3f6ebfcf8a210e0ac5e6f7e707909

View file

@ -0,0 +1,48 @@
$NetBSD: patch-an,v 1.6 2007/10/07 20:49:57 dmcmahill Exp $
--- src/modules/standard/mod_auth_db.module.orig 2004-11-24 14:10:19.000000000 -0500
+++ src/modules/standard/mod_auth_db.module
@@ -1,37 +1,11 @@
Name: db_auth_module
ConfigStart
- DB_VERSION=''
- DB_LIB=''
- if ./helpers/TestCompile func db_create; then
- DB_VERSION='Berkeley-DB/3.x'
- elif ./helpers/TestCompile lib db db_create; then
- DB_VERSION='Berkeley-DB/3.x'
- DB_LIB='-ldb'
- elif ./helpers/TestCompile func db_open; then
- DB_VERSION='Berkeley-DB/2.x'
- elif ./helpers/TestCompile lib db db_open; then
- DB_VERSION='Berkeley-DB/2.x'
- DB_LIB='-ldb'
- elif ./helpers/TestCompile lib db2 db_open; then
- DB_VERSION='Berkeley-DB/2.x'
- DB_LIB='-ldb2'
- elif ./helpers/TestCompile func dbopen; then
- DB_VERSION='Berkeley-DB/1.x'
- elif ./helpers/TestCompile lib db dbopen; then
- DB_VERSION='Berkeley-DB/1.x'
- DB_LIB='-ldb'
- elif ./helpers/TestCompile lib db1 dbopen; then
- DB_VERSION='Berkeley-DB/1.x'
- DB_LIB='-ldb1'
- elif TCADDINCL='#include <db.h>' INCLUDES1="$INCLUDES1 -I/usr/include/db1" TLIB="-ldb1" \
- helpers/TestCompile func dbm_open; then
- # For Red Hat 7
- DB_VERSION='Berkeley-DB/1.x'
- DB_LIB='-ldb1'
- CFLAGS="$CFLAGS -I/usr/include/db1"
- fi
- if [ ".$DB_VERSION" != . ]; then
- if [ ".$DB_LIB" != . ]; then
+ DB_VERSION=@DB_VERSION@
+ DB_LIB=@DB_LIB@
+ CFLAGS="$CFLAGS @DB_CFLAGS@"
+
+ if [ ".$DB_VERSION" != "" ]; then
+ if [ ".$DB_LIB" != "" ]; then
LIBS="$LIBS $DB_LIB"
echo " using $DB_VERSION for mod_auth_db ($DB_LIB)"
else