Always return a value from non-void functions.

This commit is contained in:
joerg 2012-11-19 23:22:07 +00:00
parent 45b6034661
commit 655e49d0fe
2 changed files with 30 additions and 2 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.17 2012/11/19 02:54:02 joerg Exp $
$NetBSD: distinfo,v 1.18 2012/11/19 23:22:07 joerg Exp $
SHA1 (falcons-eye-1.9.3-20050216-2/nethack_source_331_jtp_193.zip) = f25a3b77925d247762d18b6f022500aac7c42b29
RMD160 (falcons-eye-1.9.3-20050216-2/nethack_source_331_jtp_193.zip) = a94c3bbdec7a0c034acbe431071342b872c7acc5
@ -24,3 +24,4 @@ SHA1 (patch-bi) = 6b3d0d1eca3a23c3086155c1da3c2965d7092d5f
SHA1 (patch-bj) = 281f1d3b8d9eafe7fbe7ca729861d4bdccea5a41
SHA1 (patch-bk) = f234c26a95d179c4723676c180db95f26c84bb49
SHA1 (patch-win_jtp_winjtp.c) = c304d5ddbb585b5cbf5b8f8f63280ecf1329e99c
SHA1 (patch-win_jtp_winjtp.c) = c304d5ddbb585b5cbf5b8f8f63280ecf1329e99c

View file

@ -1,4 +1,31 @@
$NetBSD: patch-win_jtp_winjtp.c,v 1.1 2012/11/19 02:54:02 joerg Exp $
$NetBSD: patch-win_jtp_winjtp.c,v 1.2 2012/11/19 23:22:07 joerg Exp $
--- win/jtp/winjtp.c.orig 2012-11-19 00:35:09.000000000 +0000
+++ win/jtp/winjtp.c
@@ -1,6 +1,7 @@
/* SCCS Id: @(#)winjtp.c 3.0 2000/11/12 */
/* Copyright (c) Jaakko Peltonen, 2000 */
/* NetHack may be freely redistributed. See license for details. */
+#include <ctype.h>
#include "hack.h"
#include "dlb.h"
@@ -1504,12 +1505,12 @@ menu_item **menu_list;
if (!tempwindow)
{
jtp_messagebox("ERROR: Can't find window for menu selection!");
- return;
+ return -1;
}
if (!tempwindow->menu)
{
jtp_messagebox("ERROR: Window does not have a menu!");
- return;
+ return -1;
}
tempwindow->menu->selectiontype = how;
$NetBSD: patch-win_jtp_winjtp.c,v 1.2 2012/11/19 23:22:07 joerg Exp $
--- win/jtp/winjtp.c.orig 2012-11-19 00:35:09.000000000 +0000
+++ win/jtp/winjtp.c