ghostscript-agpl: fix macOS (with new-clang only?).

This commit is contained in:
schmonz 2024-03-11 21:29:17 +00:00
parent 05b6e51b10
commit 65603a94bc
2 changed files with 19 additions and 1 deletions

View File

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.48 2024/03/11 12:45:37 wiz Exp $
$NetBSD: distinfo,v 1.49 2024/03/11 21:29:17 schmonz Exp $
BLAKE2s (ghostscript-10.03.0.tar.xz) = ba41f0419063e1dec395939e82f57870639c4f8548c63094974c838345ecb241
SHA512 (ghostscript-10.03.0.tar.xz) = 74d7da586eefbf3fb3c085bb4d2b73ee667fd0ae9cff73ece613c77c443148b847086f91802124baf91ac35cdc83be07199799378def92c8fbd96ced7d0ee9a8
@ -10,3 +10,4 @@ SHA1 (patch-base_ttobjs.h) = 378ad7d316a4a9dc53b9c8e612582a7c8e9b3688
SHA1 (patch-base_unix-dll.mak) = 8076ce689807872bf94b552daaf9547b646ca249
SHA1 (patch-configure) = c448faa2f588dd8d7f58a9c1498b3dc5e903a5e2
SHA1 (patch-devices_devs.mak) = e9937d401a278cc6d0a6d4cff78c526375bc18ca
SHA1 (patch-pdf_pdf__sec.c) = 18a88ff5b93b01fbb7b350c9c96399b14dc93b40

View File

@ -0,0 +1,17 @@
$NetBSD: patch-pdf_pdf__sec.c,v 1.1 2024/03/11 21:29:17 schmonz Exp $
Fix incompatible-pointer-types, int-conversion.
--- pdf/pdf_sec.c.orig 2024-03-11 21:22:54.712613675 +0000
+++ pdf/pdf_sec.c
@@ -183,8 +183,8 @@ static int apply_sasl(pdf_context *ctx,
* this easy: the errors we want to ignore are the ones with
* codes less than 100. */
if ((int)err < 100) {
- NewPassword = Password;
- NewLen = Len;
+ NewPassword = &Password;
+ NewLen = &Len;
return 0;
}