Update to 0.18.16:
ver 0.18.16 (2014/09/26) * fix DSD breakage due to typo in configure.ac ver 0.18.15 (2014/09/26) * command - list: reset used size after the list has been processed * fix MixRamp * work around build failure on NetBSD
This commit is contained in:
parent
020ce1ff67
commit
656fb674a8
5 changed files with 6 additions and 55 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.89 2014/09/14 16:48:26 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.90 2014/10/01 11:52:26 wiz Exp $
|
||||
|
||||
DISTNAME= mpd-0.18.14
|
||||
DISTNAME= mpd-0.18.16
|
||||
PKGNAME= ${DISTNAME:S/mpd/musicpd/}
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://www.musicpd.org/download/mpd/0.18/
|
||||
|
|
|
@ -1,9 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.47 2014/09/14 16:48:26 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.48 2014/10/01 11:52:26 wiz Exp $
|
||||
|
||||
SHA1 (mpd-0.18.14.tar.xz) = 5a4b5f5b0447994f3fc186ffd7c16cabeeed2978
|
||||
RMD160 (mpd-0.18.14.tar.xz) = 99bf8fcba73746c9b6782b00e82f76ab0fe02189
|
||||
Size (mpd-0.18.14.tar.xz) = 587484 bytes
|
||||
SHA1 (patch-src_notify.hxx) = 730f415fa8c0181c19bc631d280f25a71171ce3c
|
||||
SHA1 (mpd-0.18.16.tar.xz) = ef510446e858fadf20d36fa2c1bed6f35a51e613
|
||||
RMD160 (mpd-0.18.16.tar.xz) = d49d0376f5b6215a833d26221522dca33d0727b1
|
||||
Size (mpd-0.18.16.tar.xz) = 587724 bytes
|
||||
SHA1 (patch-src_output_HttpdOutputPlugin.cxx) = 6e046d00a4e59c905d8fe014afe854aac1337e8d
|
||||
SHA1 (patch-src_thread_PosixCond.hxx) = 87f648004a09117226f19b47aad4a057aba75371
|
||||
SHA1 (patch-src_thread_PosixMutex.hxx) = e8a70cd990902c39f8a039d39e69a2d238c14baa
|
||||
|
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-src_notify.hxx,v 1.2 2014/09/10 12:16:55 wiz Exp $
|
||||
|
||||
http://bugs.musicpd.org/view.php?id=4110
|
||||
|
||||
--- src/notify.hxx.orig 2014-09-09 20:11:34.000000000 +0000
|
||||
+++ src/notify.hxx
|
||||
@@ -28,9 +28,6 @@ struct notify {
|
||||
Cond cond;
|
||||
bool pending;
|
||||
|
||||
-#ifndef WIN32
|
||||
- constexpr
|
||||
-#endif
|
||||
notify():pending(false) {}
|
||||
|
||||
/**
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-src_thread_PosixCond.hxx,v 1.2 2014/09/10 12:16:55 wiz Exp $
|
||||
|
||||
http://bugs.musicpd.org/view.php?id=4110
|
||||
|
||||
--- src/thread/PosixCond.hxx.orig 2014-09-09 20:08:12.000000000 +0000
|
||||
+++ src/thread/PosixCond.hxx
|
||||
@@ -41,7 +41,7 @@ class PosixCond {
|
||||
pthread_cond_t cond;
|
||||
|
||||
public:
|
||||
- constexpr PosixCond():cond(PTHREAD_COND_INITIALIZER) {}
|
||||
+ PosixCond():cond(PTHREAD_COND_INITIALIZER) {}
|
||||
|
||||
PosixCond(const PosixCond &other) = delete;
|
||||
PosixCond &operator=(const PosixCond &other) = delete;
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-src_thread_PosixMutex.hxx,v 1.2 2014/09/10 12:16:55 wiz Exp $
|
||||
|
||||
http://bugs.musicpd.org/view.php?id=4110
|
||||
|
||||
--- src/thread/PosixMutex.hxx.orig 2014-09-09 20:07:45.000000000 +0000
|
||||
+++ src/thread/PosixMutex.hxx
|
||||
@@ -41,7 +41,7 @@ class PosixMutex {
|
||||
pthread_mutex_t mutex;
|
||||
|
||||
public:
|
||||
- constexpr PosixMutex():mutex(PTHREAD_MUTEX_INITIALIZER) {}
|
||||
+ PosixMutex():mutex(PTHREAD_MUTEX_INITIALIZER) {}
|
||||
|
||||
PosixMutex(const PosixMutex &other) = delete;
|
||||
PosixMutex &operator=(const PosixMutex &other) = delete;
|
Loading…
Reference in a new issue