Remove two patches; upstream says that extending precision is not
the right approach and that he changed the calculation for 0.3.2 in a more robust way. Note that patch-configure will be integrated in next release. Bump PKGREVISION for patch removal.
This commit is contained in:
parent
6e706ca74e
commit
658f5c36ff
5 changed files with 6 additions and 56 deletions
|
@ -1,7 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.51 2011/11/30 18:46:47 tron Exp $
|
||||
# $NetBSD: Makefile,v 1.52 2011/11/30 20:52:46 wiz Exp $
|
||||
|
||||
DISTNAME= audiofile-0.3.2
|
||||
PKGNAME= lib${DISTNAME}
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://www.68k.org/~michael/audiofile/
|
||||
|
||||
|
|
|
@ -1,8 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.17 2011/11/30 14:30:57 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.18 2011/11/30 20:52:46 wiz Exp $
|
||||
|
||||
SHA1 (audiofile-0.3.2.tar.gz) = fb55a3c9153475daa8932d3626797e033d149c1d
|
||||
RMD160 (audiofile-0.3.2.tar.gz) = b55598dd1d5a960599b485c966ef39dda2384c40
|
||||
Size (audiofile-0.3.2.tar.gz) = 722101 bytes
|
||||
SHA1 (patch-af) = 095d0bf52b7545718d8058f6474b6d9c05b6ceab
|
||||
SHA1 (patch-configure) = 011fefbdccf70056eee97896119862bb299ec05e
|
||||
SHA1 (patch-libaudiofile_util.cpp) = be175d47b708fc8262926d014dca4f4ff50093e1
|
||||
SHA1 (patch-configure) = 4e45468433bd0ee11b907ad117938f24b6a2b798
|
||||
|
|
|
@ -1,18 +0,0 @@
|
|||
$NetBSD: patch-af,v 1.2 2011/11/29 19:39:30 wiz Exp $
|
||||
|
||||
see Ubuntu bug 327018
|
||||
|
||||
--- libaudiofile/util.h.orig 2011-05-31 18:04:50.000000000 +0000
|
||||
+++ libaudiofile/util.h
|
||||
@@ -54,9 +54,9 @@ bool _af_pv_getptr (AUpvlist pvlist, int
|
||||
|
||||
bool _af_unique_ids (const int *ids, int nids, const char *idname, int iderr);
|
||||
|
||||
-float _af_format_frame_size (const AudioFormat *format, bool stretch3to4);
|
||||
+double _af_format_frame_size (const AudioFormat *format, bool stretch3to4);
|
||||
int _af_format_frame_size_uncompressed (const AudioFormat *format, bool stretch3to4);
|
||||
-float _af_format_sample_size (const AudioFormat *format, bool stretch3to4);
|
||||
+double _af_format_sample_size (const AudioFormat *format, bool stretch3to4);
|
||||
int _af_format_sample_size_uncompressed (const AudioFormat *format, bool stretch3to4);
|
||||
|
||||
status _af_set_sample_format (AudioFormat *f, int sampleFormat, int sampleWidth);
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: patch-configure,v 1.2 2011/11/30 14:30:57 wiz Exp $
|
||||
$NetBSD: patch-configure,v 1.3 2011/11/30 20:52:46 wiz Exp $
|
||||
|
||||
Fix unportable test(1) construct.
|
||||
Accepted by upstream, will be in next release.
|
||||
|
||||
--- configure.orig 2011-11-29 18:15:23.000000000 +0000
|
||||
+++ configure
|
||||
|
|
|
@ -1,32 +0,0 @@
|
|||
$NetBSD: patch-libaudiofile_util.cpp,v 1.1 2011/11/29 19:39:30 wiz Exp $
|
||||
|
||||
see Ubuntu bug 327018
|
||||
|
||||
--- libaudiofile/util.cpp.orig 2011-05-31 18:04:50.000000000 +0000
|
||||
+++ libaudiofile/util.cpp
|
||||
@@ -283,10 +283,10 @@ int _af_format_sample_size_uncompressed
|
||||
return size;
|
||||
}
|
||||
|
||||
-float _af_format_sample_size (const AudioFormat *fmt, bool stretch3to4)
|
||||
+double _af_format_sample_size (const AudioFormat *fmt, bool stretch3to4)
|
||||
{
|
||||
int compressionIndex;
|
||||
- float squishFactor;
|
||||
+ double squishFactor;
|
||||
|
||||
compressionIndex = _af_compression_index_from_id(fmt->compressionType);
|
||||
squishFactor = _af_compression[compressionIndex].squishFactor;
|
||||
@@ -301,10 +301,10 @@ int _af_format_frame_size_uncompressed (
|
||||
fmt->channelCount;
|
||||
}
|
||||
|
||||
-float _af_format_frame_size (const AudioFormat *fmt, bool stretch3to4)
|
||||
+double _af_format_frame_size (const AudioFormat *fmt, bool stretch3to4)
|
||||
{
|
||||
int compressionIndex;
|
||||
- float squishFactor;
|
||||
+ double squishFactor;
|
||||
|
||||
compressionIndex = _af_compression_index_from_id(fmt->compressionType);
|
||||
squishFactor = _af_compression[compressionIndex].squishFactor;
|
Loading…
Reference in a new issue