cleanup of Python support - remove version dependencies
This commit is contained in:
parent
e5edc53ce2
commit
65bdfe160a
6 changed files with 118 additions and 13 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.12 2002/01/25 02:00:11 rh Exp $
|
||||
# $NetBSD: Makefile,v 1.13 2002/01/28 09:36:52 drochner Exp $
|
||||
|
||||
DISTNAME= Guppi-0.40.0
|
||||
PKGNAME= ${DISTNAME:S/G/g/}
|
||||
|
@ -23,12 +23,15 @@ USE_X11BASE= YES
|
|||
LTCONFIG_OVERRIDE= ${WRKSRC}/ltconfig
|
||||
PLIST_SUBST+= LOCALBASE=${LOCALBASE}
|
||||
|
||||
CONFIGURE_ENV+= PYTHONBIN=${PYTHONBIN}
|
||||
MAKE_ENV+= PYTHONBIN=${PYTHONBIN}
|
||||
|
||||
post-install:
|
||||
${TEST} ${PREFIX} = ${LOCALBASE} || \
|
||||
${LN} -fs ${PREFIX}/share/aclocal/libguppi.m4 \
|
||||
${LOCALBASE}/share/aclocal/libguppi.m4
|
||||
|
||||
.include "../../lang/python/pyversion.mk"
|
||||
.include "../../lang/python/application.buildlink.mk"
|
||||
.include "../../devel/libglade/buildlink.mk"
|
||||
.include "../../devel/readline/buildlink.mk"
|
||||
.include "../../x11/gnome-core/buildlink.mk"
|
||||
|
|
|
@ -1,5 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.4 2001/11/13 03:16:50 damon Exp $
|
||||
$NetBSD: distinfo,v 1.5 2002/01/28 09:36:52 drochner Exp $
|
||||
|
||||
SHA1 (Guppi-0.40.0.tar.bz2) = 0b550374163fb6f9913a3cdde8fe7b50c56e72a7
|
||||
Size (Guppi-0.40.0.tar.bz2) = 1071424 bytes
|
||||
SHA1 (patch-aa) = 728aa34049f726bb36a1d7bf1c9c2ebba79df10c
|
||||
SHA1 (patch-aa) = 9ee4b2d5900a943b8e57d15272020e6f6f0f5b34
|
||||
SHA1 (patch-ab) = 0ab01c26e2b2ae3416455a18d069b63ac1bbdbf6
|
||||
SHA1 (patch-ac) = 170601ba500106c6831c8297055f1dd446520203
|
||||
SHA1 (patch-ad) = f6700919492a5977973b8994e2cdd5d55bf5ce61
|
||||
|
|
|
@ -1,13 +1,73 @@
|
|||
$NetBSD: patch-aa,v 1.3 2001/11/13 03:16:51 damon Exp $
|
||||
$NetBSD: patch-aa,v 1.4 2002/01/28 09:36:53 drochner Exp $
|
||||
|
||||
--- configure.orig Thu Oct 18 13:39:03 2001
|
||||
+++ configure
|
||||
@@ -10821,7 +10821,7 @@
|
||||
LIBGUPPI_INCLUDEDIR='-I${includedir} -I${includedir}/libguppi -I${includedir}/libguppitank'
|
||||
LIBGUPPI_INCLUDEDIR="$LIBGUPPI_INCLUDEDIR $STANDARD_CFLAGS"
|
||||
LIBGUPPI_LIBS="-lguppitank -lguppi"
|
||||
-LIBGUPPI_LIBS="$LIBGUPPI_LIBS $STANDARD_LDFLAGS"
|
||||
+LIBGUPPI_LIBS="$LIBGUPPI_LIBS -L$LOCALBASE/lib/python2.0/config -lpython2.0 $STANDARD_LDFLAGS"
|
||||
--- configure.orig Thu Oct 18 19:39:03 2001
|
||||
+++ configure Sat Jan 26 21:08:28 2002
|
||||
@@ -10350,42 +10350,13 @@
|
||||
|
||||
python_msg=no
|
||||
|
||||
-if test "$enable_python" = "yes"; then
|
||||
-# Extract the first word of "python", so it can be a program name with args.
|
||||
-set dummy python; ac_word=$2
|
||||
-echo $ac_n "checking for $ac_word""... $ac_c" 1>&6
|
||||
-echo "configure:10358: checking for $ac_word" >&5
|
||||
-if eval "test \"`echo '$''{'ac_cv_prog_python_val'+set}'`\" = set"; then
|
||||
- echo $ac_n "(cached) $ac_c" 1>&6
|
||||
-else
|
||||
- if test -n "$python_val"; then
|
||||
- ac_cv_prog_python_val="$python_val" # Let the user override the test.
|
||||
-else
|
||||
- IFS="${IFS= }"; ac_save_ifs="$IFS"; IFS=":"
|
||||
- ac_dummy="$PATH"
|
||||
- for ac_dir in $ac_dummy; do
|
||||
- test -z "$ac_dir" && ac_dir=.
|
||||
- if test -f $ac_dir/$ac_word; then
|
||||
- ac_cv_prog_python_val="true"
|
||||
- break
|
||||
- fi
|
||||
- done
|
||||
- IFS="$ac_save_ifs"
|
||||
- test -z "$ac_cv_prog_python_val" && ac_cv_prog_python_val="false"
|
||||
-fi
|
||||
-fi
|
||||
-python_val="$ac_cv_prog_python_val"
|
||||
-if test -n "$python_val"; then
|
||||
- echo "$ac_t""$python_val" 1>&6
|
||||
-else
|
||||
- echo "$ac_t""no" 1>&6
|
||||
-fi
|
||||
+python_val=true
|
||||
|
||||
if $python_val; then
|
||||
|
||||
- PY_PREFIX=`python -c 'import sys ; print sys.prefix'`
|
||||
- PY_EXEC_PREFIX=`python -c 'import sys ; print sys.exec_prefix'`
|
||||
- PY_VERSION=`python -c 'import sys ; print sys.version[0:3]'`
|
||||
+ PY_PREFIX=`${PYTHONBIN} -c 'import sys ; print sys.prefix'`
|
||||
+ PY_EXEC_PREFIX=`${PYTHONBIN} -c 'import sys ; print sys.exec_prefix'`
|
||||
+ PY_VERSION=`${PYTHONBIN} -c 'import sys ; print sys.version[0:3]'`
|
||||
if test -f $PY_PREFIX/include/python$PY_VERSION/Python.h; then
|
||||
PY_LIBS="-lpython$PY_VERSION"
|
||||
PY_LIB_LOC="-L$PY_EXEC_PREFIX/lib/python$PY_VERSION/config"
|
||||
@@ -10400,7 +10371,7 @@
|
||||
|
||||
|
||||
|
||||
- PY_BUILD_CMD='python $(top_srcdir)/build-tools/gen-py.py'
|
||||
+ PY_BUILD_CMD='${PYTHONBIN} $(top_srcdir)/build-tools/gen-py.py'
|
||||
|
||||
|
||||
python_val=true
|
||||
@@ -10455,12 +10426,6 @@
|
||||
|
||||
fi ### Closes if $python_val; then
|
||||
|
||||
-else
|
||||
- echo "$ac_t""***" 1>&6
|
||||
- echo "$ac_t""*** Python support explicitly blocked by --disable-python option." 1>&6
|
||||
- echo "$ac_t""***" 1>&6
|
||||
- python_val=false
|
||||
-fi
|
||||
|
||||
|
||||
|
||||
|
|
13
math/guppi/patches/patch-ab
Normal file
13
math/guppi/patches/patch-ab
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ab,v 1.1 2002/01/28 09:36:54 drochner Exp $
|
||||
|
||||
--- python-modules/Guppi/Makefile.in.orig Sat Jan 26 21:46:50 2002
|
||||
+++ python-modules/Guppi/Makefile.in Sat Jan 26 21:47:56 2002
|
||||
@@ -438,7 +438,7 @@
|
||||
cat $(srcdir)/start.py $(python_wrappers) $(srcdir)/end.py > __init__.py
|
||||
|
||||
__init__.pyc: __init__.py
|
||||
- python $(srcdir)/compilefile.py __init__.py
|
||||
+ ${PYTHONBIN} $(srcdir)/compilefile.py __init__.py
|
||||
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||
# Otherwise a system limit (for SysV at least) may be exceeded.
|
13
math/guppi/patches/patch-ac
Normal file
13
math/guppi/patches/patch-ac
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ac,v 1.1 2002/01/28 09:36:55 drochner Exp $
|
||||
|
||||
--- python-modules/Guppi/plot/Makefile.in.orig Sat Jan 26 21:48:53 2002
|
||||
+++ python-modules/Guppi/plot/Makefile.in Sat Jan 26 21:49:21 2002
|
||||
@@ -336,7 +336,7 @@
|
||||
cat $(srcdir)/start.py $(python_wrappers) $(srcdir)/end.py > __init__.py
|
||||
|
||||
%.pyc: %.py
|
||||
- python $(srcdir)/../compilefile.py $<
|
||||
+ ${PYTHONBIN} $(srcdir)/../compilefile.py $<
|
||||
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||
# Otherwise a system limit (for SysV at least) may be exceeded.
|
13
math/guppi/patches/patch-ad
Normal file
13
math/guppi/patches/patch-ad
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ad,v 1.1 2002/01/28 09:36:56 drochner Exp $
|
||||
|
||||
--- python-modules/Guppi/data_impl/Makefile.in.orig Sat Jan 26 21:50:47 2002
|
||||
+++ python-modules/Guppi/data_impl/Makefile.in Sat Jan 26 21:51:53 2002
|
||||
@@ -332,7 +332,7 @@
|
||||
cat $(srcdir)/start.py $(python_wrappers) $(srcdir)/end.py > __init__.py
|
||||
|
||||
%.pyc: %.py
|
||||
- python $(srcdir)/../compilefile.py $<
|
||||
+ ${PYTHONBIN} $(srcdir)/../compilefile.py $<
|
||||
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||
# Otherwise a system limit (for SysV at least) may be exceeded.
|
Loading…
Reference in a new issue