Update php53 to 5.3.22.

PHP                                                                        NEWS
|||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
21 Feb 2013, PHP 5.3.22

- Zend Engine:
  . Fixed bug #64099 (Wrong TSRM usage in zend_Register_class alias). (Johannes)
  . Fixed bug #63899 (Use after scope error in zend_compile). (Laruence)

- Core
  . Fixed bug #63943 (Bad warning text from strpos() on empty needle).
    (Laruence)

- Date:
  . Fixed bug #55397 (comparsion of incomplete DateTime causes SIGSEGV).
    (Laruence, Derick)

- FPM:
  . Fixed bug #63999 (php with fpm fails to build on Solaris 10 or 11). (Adam)

- SOAP
  . Added check that soap.wsdl_cache_dir conforms to open_basedir
    (CVE-2013-1635). (Dmitry)
  . Disabled external entities loading (CVE-2013-1643). (Dmitry)

- SPL:
  . Fixed bug #64106 (Segfault on SplFixedArray[][x] = y when extended). (Nikita Popov)
This commit is contained in:
taca 2013-02-22 03:06:16 +00:00
parent 1cace43330
commit 65c606391b
5 changed files with 9 additions and 25 deletions

View file

@ -1,10 +1,9 @@
# $NetBSD: Makefile,v 1.36 2013/02/06 23:22:37 jperkin Exp $
# $NetBSD: Makefile,v 1.37 2013/02/22 03:06:16 taca Exp $
#
# We can't omit PKGNAME here to handle PKG_OPTIONS.
#
PKGNAME= php-${PHP_BASE_VERS}
PKGREVISION= 1
CATEGORIES= lang
HOMEPAGE= http://www.php.net/

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile.common,v 1.21 2013/01/17 16:18:24 taca Exp $
# $NetBSD: Makefile.common,v 1.22 2013/02/22 03:06:16 taca Exp $
# used by lang/php53/Makefile.php
# used by lang/php/ext.mk
# used by meta-pkgs/php53-extensions/Makefile
@ -38,7 +38,7 @@ EXTRACT_SUFX?= .tar.bz2
MAINTAINER?= pkgsrc-users@NetBSD.org
HOMEPAGE?= http://www.php.net/
PHP_BASE_VERS= 5.3.21
PHP_BASE_VERS= 5.3.22
PHP_EXTENSION_DIR= lib/php/20090630
PLIST_SUBST+= PHP_EXTENSION_DIR=${PHP_EXTENSION_DIR}

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile.php,v 1.28 2013/01/17 16:18:24 taca Exp $
# $NetBSD: Makefile.php,v 1.29 2013/02/22 03:06:16 taca Exp $
# used by lang/php53/Makefile
# used by www/ap-php/Makefile
@ -58,7 +58,7 @@ PKG_SUGGESTED_OPTIONS+= inet6 ssl
.if !empty(PKG_OPTIONS:Msuhosin)
SUHOSIN_PHPVER= 5.3.21
. if ${SUHOSIN_PHPVER} != ${PHP_BASE_VERS} && ${PHP_BASE_VERS} != 5.3.21
. if ${SUHOSIN_PHPVER} != ${PHP_BASE_VERS} && ${PHP_BASE_VERS} != 5.3.22
PKG_FAIL_REASON+= "The suhosin patch is currently not available for"
PKG_FAIL_REASON+= "this version of PHP. You may have to wait until"
PKG_FAIL_REASON+= "an updated patch is released or temporarily"

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.57 2013/02/17 13:10:13 taca Exp $
$NetBSD: distinfo,v 1.58 2013/02/22 03:06:16 taca Exp $
SHA1 (php-5.3.21.tar.bz2) = d67d2569b4782cf2faa049f22b08819ad8b15009
RMD160 (php-5.3.21.tar.bz2) = 84aa653af6fbe66c02a572ad1add3daf6e46bb1e
Size (php-5.3.21.tar.bz2) = 11362683 bytes
SHA1 (php-5.3.22.tar.bz2) = 8a0948040d70bd7ebf1f3001c4462649b43d5ab0
RMD160 (php-5.3.22.tar.bz2) = dc51c94f4201aeb3bef03df8d1def780a1ab60f5
Size (php-5.3.22.tar.bz2) = 11366482 bytes
SHA1 (suhosin-patch-5.3.21-0.9.10.patch.bz2) = 7df6bb0f39fe4111a96a7d6ce694f954f1796c48
RMD160 (suhosin-patch-5.3.21-0.9.10.patch.bz2) = 4f2039676592c94fd923cdf7a35255d663ab56df
Size (suhosin-patch-5.3.21-0.9.10.patch.bz2) = 33131 bytes

View file

@ -1,15 +0,0 @@
$NetBSD: patch-sapi_fpm_fpm__fpm_sockets.h,v 1.2 2012/08/17 15:32:31 taca Exp $
Silly bug. 'sun' is of course taken on SunOS.
--- sapi/fpm/fpm/fpm_sockets.h.orig 2012-08-15 17:05:42.000000000 +0000
+++ sapi/fpm/fpm/fpm_sockets.h
@@ -25,7 +25,7 @@
enum fpm_address_domain fpm_sockets_domain_from_address(char *addr);
int fpm_sockets_init_main();
int fpm_socket_get_listening_queue(int sock, unsigned *cur_lq, unsigned *max_lq);
-int fpm_socket_unix_test_connect(struct sockaddr_un *sun, size_t socklen);
+int fpm_socket_unix_test_connect(struct sockaddr_un *sock, size_t socklen);
static inline int fd_set_blocked(int fd, int blocked) /* {{{ */