Update to 3.141592. From the changelog:
* Add new hooks: canremove, canrename, rename. (intrigeri) * rename: Refactor subpage rename handling code into rename hook. (intrigeri) * po: New plugin, suporting translation of wiki pages using po files. (intrigeri) * Add build machinery to build po files to translate the underlay wikis, * Add further build machinery to generate translated underlays from the po file, for use by wikis whose primary language is not English. * Add Danish basewiki translation by Jonas Smedegaard. * img: Fix adding of dependency from page to the image. * pagestats: add among parameter, which only counts links from specified pages (smcv) * pagestats: when making a tag cloud, don't emit links where the tag is unused (smcv) * map: Avoid emitting an unclosed ul element if the map is empty. (harishcm) * inline: Add pagenames parameter that can be used to list a set of pages to inline, in a specific order, without using a PageSpec. (smcv) * Add getsource plugin (Will, smcv) Note that the new po plugin won't work until textproc/po4a is updated to at least 0.34. Any takers?
This commit is contained in:
parent
2df46bde89
commit
65e3d8fc2d
10 changed files with 159 additions and 35 deletions
|
@ -1,8 +1,7 @@
|
|||
ikiwiki is a wiki compiler.
|
||||
|
||||
It converts wiki pages into html pages suitable for publishing on a
|
||||
website. Unlike many wikis, ikiwiki does not have its own ad-hoc means
|
||||
of storing page history, and instead uses an revision control system.
|
||||
|
||||
This means you can edit wiki sources in your favourite editor, and
|
||||
rebuild the website, rather than using an online browser form.
|
||||
Ikiwiki is a wiki compiler. It converts wiki pages into HTML pages
|
||||
suitable for publishing on a website. Unlike many wikis, ikiwiki
|
||||
does not have its own ad hoc means of storing page history, instead
|
||||
using a revision control system such as Subversion or Git. This
|
||||
means that in addition to the usual web interface, you can edit
|
||||
wiki sources in your favorite editor. There are many other features,
|
||||
including support for blogging, as well as a large array of plugins.
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.28 2009/07/24 17:52:00 schmonz Exp $
|
||||
# $NetBSD: Makefile,v 1.29 2009/08/12 21:14:35 schmonz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= ikiwiki_3.14159
|
||||
DISTNAME= ikiwiki_3.141592
|
||||
PKGNAME= ${DISTNAME:S/_/-/}
|
||||
CATEGORIES= www textproc
|
||||
MASTER_SITES= ${MASTER_SITE_DEBIAN:=pool/main/i/ikiwiki/}
|
||||
|
@ -30,6 +30,7 @@ DEPENDS+= p5-XML-Simple-[0-9]*:../../textproc/p5-XML-Simple
|
|||
DEPENDS+= p5-XML-RSS-[0-9]*:../../textproc/p5-XML-RSS
|
||||
DEPENDS+= p5-File-MimeInfo-[0-9]*:../../devel/p5-File-MimeInfo
|
||||
DEPENDS+= p5-gettext-[0-9]*:../../devel/p5-gettext
|
||||
#DEPENDS+= po4a-[0-9]*:../../textproc/po4a
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PKGBASE}
|
||||
PERL5_PACKLIST= auto/IkiWiki/.packlist
|
||||
|
@ -37,10 +38,13 @@ USE_LANGUAGES= # none
|
|||
USE_TOOLS+= gmake msgfmt perl:run xgettext
|
||||
|
||||
REPLACE_PERL+= ikiwiki-mass-rebuild ikiwiki-transition ikiwiki-update-wikilist
|
||||
REPLACE_PERL+= ikiwiki-w3m.cgi ikiwiki.in mdwn2man pm_filter
|
||||
REPLACE_PERL+= *.pm IkiWiki/*.pm IkiWiki/*/*.pm* *.setup */*/*.setup t/*.t
|
||||
REPLACE_PERL+= ikiwiki-w3m.cgi ikiwiki.in gitremotes mdwn2man pm_filter
|
||||
REPLACE_PERL+= *.pm IkiWiki/*.pm IkiWiki/*/*.pm* *.setup */*.setup */*/*.setup
|
||||
REPLACE_PERL+= po/po2wiki t/*.t
|
||||
REPLACE_PERL+= plugins/externaldemo # XXX not installed
|
||||
|
||||
REPLACE_PYTHON+=plugins/proxy.py plugins/pythondemo plugins/rst
|
||||
|
||||
SUBST_CLASSES+= sysconfdir
|
||||
SUBST_STAGE.sysconfdir= post-patch
|
||||
SUBST_FILES.sysconfdir= ikiwiki-mass-rebuild ikiwiki-update-wikilist
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.14 2009/07/09 22:15:09 schmonz Exp $
|
||||
@comment $NetBSD: PLIST,v 1.15 2009/08/12 21:14:35 schmonz Exp $
|
||||
bin/ikiwiki
|
||||
bin/ikiwiki-makerepo
|
||||
bin/ikiwiki-transition
|
||||
|
@ -26,6 +26,7 @@ share/ikiwiki/basewiki/ikiwiki/markdown.mdwn
|
|||
share/ikiwiki/basewiki/ikiwiki/openid.mdwn
|
||||
share/ikiwiki/basewiki/ikiwiki/pagespec.mdwn
|
||||
share/ikiwiki/basewiki/ikiwiki/pagespec/attachment.mdwn
|
||||
share/ikiwiki/basewiki/ikiwiki/pagespec/po.mdwn
|
||||
share/ikiwiki/basewiki/ikiwiki/preprocessordirective.mdwn
|
||||
share/ikiwiki/basewiki/ikiwiki/searching.mdwn
|
||||
share/ikiwiki/basewiki/ikiwiki/subpage.mdwn
|
||||
|
@ -163,6 +164,7 @@ share/ikiwiki/templates/microblog.tmpl
|
|||
share/ikiwiki/templates/misc.tmpl
|
||||
share/ikiwiki/templates/page.tmpl
|
||||
share/ikiwiki/templates/passwordmail.tmpl
|
||||
share/ikiwiki/templates/pocreatepage.tmpl
|
||||
share/ikiwiki/templates/recentchanges.tmpl
|
||||
share/ikiwiki/templates/renamesummary.tmpl
|
||||
share/ikiwiki/templates/rssitem.tmpl
|
||||
|
@ -170,13 +172,3 @@ share/ikiwiki/templates/rsspage.tmpl
|
|||
share/ikiwiki/templates/searchform.tmpl
|
||||
share/ikiwiki/templates/searchquery.tmpl
|
||||
share/ikiwiki/templates/titlepage.tmpl
|
||||
share/locale/bg/LC_MESSAGES/ikiwiki.mo
|
||||
share/locale/cs/LC_MESSAGES/ikiwiki.mo
|
||||
share/locale/da/LC_MESSAGES/ikiwiki.mo
|
||||
share/locale/de/LC_MESSAGES/ikiwiki.mo
|
||||
share/locale/es/LC_MESSAGES/ikiwiki.mo
|
||||
share/locale/fr/LC_MESSAGES/ikiwiki.mo
|
||||
share/locale/gu/LC_MESSAGES/ikiwiki.mo
|
||||
share/locale/pl/LC_MESSAGES/ikiwiki.mo
|
||||
share/locale/sv/LC_MESSAGES/ikiwiki.mo
|
||||
share/locale/vi/LC_MESSAGES/ikiwiki.mo
|
||||
|
|
|
@ -1,9 +1,13 @@
|
|||
$NetBSD: distinfo,v 1.17 2009/07/24 05:09:02 schmonz Exp $
|
||||
$NetBSD: distinfo,v 1.18 2009/08/12 21:14:35 schmonz Exp $
|
||||
|
||||
SHA1 (ikiwiki_3.14159.tar.gz) = bbfb095776d14a5e2737e9008fa49072b36f8fd6
|
||||
RMD160 (ikiwiki_3.14159.tar.gz) = c7330c8964669f598343918bfc85ace2585459cf
|
||||
Size (ikiwiki_3.14159.tar.gz) = 1222039 bytes
|
||||
SHA1 (patch-aa) = e8c8e6ca75d3afe7ac36a3bb2295a69283be6607
|
||||
SHA1 (ikiwiki_3.141592.tar.gz) = d71451f867cd8641fae64b7e2db69a2a434e35d1
|
||||
RMD160 (ikiwiki_3.141592.tar.gz) = af73196378badae022ac6176cb723d321a16fec1
|
||||
Size (ikiwiki_3.141592.tar.gz) = 1330900 bytes
|
||||
SHA1 (patch-aa) = 88c864357522f419956cf4efba509467d1670a97
|
||||
SHA1 (patch-ab) = bbec6e7a4e6772d995a0b084a3875b83950eb194
|
||||
SHA1 (patch-ac) = a9ed34c766b40dbf36069c7d2550fcec95b95304
|
||||
SHA1 (patch-ad) = 5720c313ea335a182417b2339ee2e8ef204fc11d
|
||||
SHA1 (patch-ae) = b23e2c81e0dba9bc88fd2bdc88de5e60eb74e16f
|
||||
SHA1 (patch-af) = 48571175d57d24b3053d5477167a3718c6396588
|
||||
SHA1 (patch-ag) = b65b9c11ec01d481df4a3942df6b1c1dc34438a7
|
||||
SHA1 (patch-ah) = e0e15501e5f13c1667253d837539caad86676c72
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: options.mk,v 1.4 2009/07/24 14:35:14 schmonz Exp $
|
||||
# $NetBSD: options.mk,v 1.5 2009/08/12 21:14:35 schmonz Exp $
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.ikiwiki
|
||||
PKG_SUPPORTED_OPTIONS= ikiwiki-amazon-s3 ikiwiki-search
|
||||
|
@ -22,11 +22,15 @@ DEPENDS+= p5-PerlMagick-[0-9]*:../../graphics/p5-PerlMagick
|
|||
.endif
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mpython)
|
||||
REPLACE_PYTHON+=plugins/proxy.py plugins/rst
|
||||
DEPENDS+= ${PYPKGPREFIX}-docutils-[0-9]*:../../textproc/py-docutils
|
||||
.include "../../lang/python/application.mk"
|
||||
.else
|
||||
CHECK_INTERPRETER_SKIP+= lib/ikiwiki/plugins/*
|
||||
CHECK_INTERPRETER_SKIP+=lib/ikiwiki/plugins/*
|
||||
# and no python dependency, so let's not use a system python by mistake
|
||||
REPLACE_INTERPRETER+= python
|
||||
REPLACE.python.old= .*python[^[:space:]]*
|
||||
REPLACE.python.new= ${LOCALBASE}/bin/python
|
||||
REPLACE_FILES.python= ${REPLACE_PYTHON}
|
||||
.endif
|
||||
|
||||
.if !empty(PKG_OPTIONS:Msvn)
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: patch-aa,v 1.9 2009/07/24 05:09:02 schmonz Exp $
|
||||
$NetBSD: patch-aa,v 1.10 2009/08/12 21:14:35 schmonz Exp $
|
||||
|
||||
--- Makefile.PL.orig 2009-05-27 16:32:36.000000000 -0400
|
||||
--- Makefile.PL.orig 2009-07-23 09:25:36.000000000 -0400
|
||||
+++ Makefile.PL
|
||||
@@ -25,6 +25,8 @@ PROBABLE_INST_LIB=$(shell \\
|
||||
|
||||
|
@ -11,7 +11,40 @@ $NetBSD: patch-aa,v 1.9 2009/07/24 05:09:02 schmonz Exp $
|
|||
|
||||
tflag=$(shell if [ -n "$$NOTAINT" ] && [ "$$NOTAINT" != 1 ]; then printf -- "-T"; fi)
|
||||
extramodules=$(shell if [ "$$PROFILE" = 1 ]; then printf -- "-d:Profile"; fi)
|
||||
@@ -94,14 +96,14 @@ extra_install:
|
||||
@@ -42,7 +44,6 @@ extra_build: ikiwiki.out ikiwiki.setup d
|
||||
./mdwn2man ikiwiki-makerepo 1 doc/ikiwiki-makerepo.mdwn > ikiwiki-makerepo.man
|
||||
./mdwn2man ikiwiki-transition 1 doc/ikiwiki-transition.mdwn > ikiwiki-transition.man
|
||||
./mdwn2man ikiwiki-update-wikilist 1 doc/ikiwiki-update-wikilist.mdwn > ikiwiki-update-wikilist.man
|
||||
- $(MAKE) -C po
|
||||
|
||||
docwiki: ikiwiki.out
|
||||
$(PERL) -Iblib/lib $(extramodules) $(tflag) ikiwiki.out -libdir . -setup docwiki.setup -refresh
|
||||
@@ -50,14 +51,13 @@ docwiki: ikiwiki.out
|
||||
extra_clean:
|
||||
rm -rf html doc/.ikiwiki
|
||||
rm -f *.man ikiwiki.out ikiwiki.setup plugins/*.pyc
|
||||
- $(MAKE) -C po clean
|
||||
|
||||
underlay_install:
|
||||
install -d $(DESTDIR)$(PREFIX)/share/ikiwiki
|
||||
for dir in `cd underlays && find . -follow -type d ! -regex '.*\.svn.*'`; do \
|
||||
install -d $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir; \
|
||||
for file in `find underlays/$$dir -follow -maxdepth 1 -type f`; do \
|
||||
- cp -aL $$file $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir 2>/dev/null || \
|
||||
+ cp -pRL $$file $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir 2>/dev/null || \
|
||||
install -m 644 $$file $(DESTDIR)$(PREFIX)/share/ikiwiki/$$dir; \
|
||||
done; \
|
||||
done
|
||||
@@ -76,7 +76,7 @@ extra_install: underlay_install
|
||||
install -d $(DESTDIR)$(PREFIX)/share/ikiwiki/examples/$$dir; \
|
||||
done
|
||||
for file in `cd doc/examples; find . -type f ! -regex '.*\.svn.*'`; do \
|
||||
- cp -aL doc/examples/$$file $(DESTDIR)$(PREFIX)/share/ikiwiki/examples/$$file 2>/dev/null || \
|
||||
+ cp -pRL doc/examples/$$file $(DESTDIR)$(PREFIX)/share/ikiwiki/examples/$$file 2>/dev/null || \
|
||||
install -m 644 doc/examples/$$file $(DESTDIR)$(PREFIX)/share/ikiwiki/examples/$$file; \
|
||||
done
|
||||
|
||||
@@ -95,14 +95,14 @@ extra_install: underlay_install
|
||||
install -m 755 $$file $(DESTDIR)$(PREFIX)/lib/ikiwiki/plugins; \
|
||||
done
|
||||
|
||||
|
@ -33,7 +66,11 @@ $NetBSD: patch-aa,v 1.9 2009/07/24 05:09:02 schmonz Exp $
|
|||
|
||||
install -d $(DESTDIR)$(PREFIX)/sbin
|
||||
install ikiwiki-mass-rebuild $(DESTDIR)$(PREFIX)/sbin
|
||||
@@ -117,10 +119,10 @@ extra_install:
|
||||
@@ -114,14 +114,13 @@ extra_install: underlay_install
|
||||
install ikiwiki.out $(DESTDIR)$(PREFIX)/bin/ikiwiki
|
||||
install ikiwiki-makerepo ikiwiki-transition ikiwiki-update-wikilist $(DESTDIR)$(PREFIX)/bin/
|
||||
|
||||
- $(MAKE) -C po install DESTDIR=$(DESTDIR) PREFIX=$(PREFIX)
|
||||
|
||||
# These might fail if a regular user is installing into a home
|
||||
# directory.
|
||||
|
|
19
www/ikiwiki/patches/patch-ac
Normal file
19
www/ikiwiki/patches/patch-ac
Normal file
|
@ -0,0 +1,19 @@
|
|||
$NetBSD: patch-ac,v 1.5 2009/08/12 21:14:35 schmonz Exp $
|
||||
|
||||
--- po/Makefile.orig 2009-07-21 10:58:12.000000000 -0400
|
||||
+++ po/Makefile
|
||||
@@ -63,12 +63,12 @@ underlays_copy_stamp:
|
||||
# copy all the files we want to translate into a srcdir
|
||||
for file in `cd ..; find underlays -follow -name \*.mdwn`; do \
|
||||
install -d $$(dirname $$file); \
|
||||
- cp -aL ../$$file $$file 2>/dev/null || \
|
||||
+ cp -pRL ../$$file $$file 2>/dev/null || \
|
||||
install -m 644 ../$$file $$file; \
|
||||
done
|
||||
install -d underlays/directives/ikiwiki/directive
|
||||
for file in `cd ..; find doc/ikiwiki/directive/ -maxdepth 1 -type f`; do \
|
||||
- cp -a ../$$file underlays/directives/ikiwiki/directive || \
|
||||
+ cp -pR ../$$file underlays/directives/ikiwiki/directive || \
|
||||
install -m 644 ../$$file underlays/directives/ikiwiki/directive; \
|
||||
done
|
||||
install -d underlays/empty
|
24
www/ikiwiki/patches/patch-af
Normal file
24
www/ikiwiki/patches/patch-af
Normal file
|
@ -0,0 +1,24 @@
|
|||
$NetBSD: patch-af,v 1.1 2009/08/12 21:14:35 schmonz Exp $
|
||||
|
||||
--- IkiWiki/Plugin/inline.pm.orig 2009-07-31 10:13:10.000000000 -0400
|
||||
+++ IkiWiki/Plugin/inline.pm
|
||||
@@ -186,7 +186,6 @@ sub preprocess_inline (@) {
|
||||
my @list;
|
||||
|
||||
if (exists $params{pagenames}) {
|
||||
-
|
||||
foreach my $p (qw(sort pages)) {
|
||||
if (exists $params{$p}) {
|
||||
error sprintf(gettext("the %s and %s parameters cannot be used together"),
|
||||
@@ -194,9 +193,8 @@ sub preprocess_inline (@) {
|
||||
}
|
||||
}
|
||||
|
||||
- @list = split ' ', $params{pagenames};
|
||||
- my $_;
|
||||
- @list = map { bestlink($params{page}, $_) } @list;
|
||||
+ @list = map { bestlink($params{page}, $_) }
|
||||
+ split ' ', $params{pagenames};
|
||||
|
||||
$params{pages} = join(" or ", @list);
|
||||
}
|
23
www/ikiwiki/patches/patch-ag
Normal file
23
www/ikiwiki/patches/patch-ag
Normal file
|
@ -0,0 +1,23 @@
|
|||
$NetBSD: patch-ag,v 1.1 2009/08/12 21:14:35 schmonz Exp $
|
||||
|
||||
--- IkiWiki/Render.pm.orig 2009-07-31 10:13:10.000000000 -0400
|
||||
+++ IkiWiki/Render.pm
|
||||
@@ -379,12 +379,13 @@ sub refresh () {
|
||||
$links{$page}=[];
|
||||
$renderedfiles{$page}=[];
|
||||
$pagemtime{$page}=0;
|
||||
- prune($config{destdir}."/".$_)
|
||||
- foreach @{$oldrenderedfiles{$page}};
|
||||
+ foreach my $old (@{$oldrenderedfiles{$page}}) {
|
||||
+ prune($config{destdir}."/".$old);
|
||||
+ }
|
||||
delete $pagesources{$page};
|
||||
- foreach (keys %destsources) {
|
||||
- if ($destsources{$_} eq $page) {
|
||||
- delete $destsources{$_};
|
||||
+ foreach my $source (keys %destsources) {
|
||||
+ if ($destsources{$source} eq $page) {
|
||||
+ delete $destsources{$source};
|
||||
}
|
||||
}
|
||||
}
|
18
www/ikiwiki/patches/patch-ah
Normal file
18
www/ikiwiki/patches/patch-ah
Normal file
|
@ -0,0 +1,18 @@
|
|||
$NetBSD: patch-ah,v 1.1 2009/08/12 21:14:35 schmonz Exp $
|
||||
|
||||
--- IkiWiki/Plugin/po.pm.orig 2009-08-10 15:59:01.000000000 -0400
|
||||
+++ IkiWiki/Plugin/po.pm
|
||||
@@ -10,7 +10,12 @@ use warnings;
|
||||
use strict;
|
||||
use IkiWiki 3.00;
|
||||
use Encode;
|
||||
-use Locale::Po4a::Common qw(nowrapi18n !/.*/);
|
||||
+eval q{use Locale::Po4a::Common qw(nowrapi18n !/.*/)};
|
||||
+if ($@) {
|
||||
+ print STDERR gettext("warning: Old po4a detected! Recommend upgrade to 0.35.")."\n";
|
||||
+ eval q{use Locale::Po4a::Common qw(!/.*/)};
|
||||
+ die $@ if $@;
|
||||
+}
|
||||
use Locale::Po4a::Chooser;
|
||||
use Locale::Po4a::Po;
|
||||
use File::Basename;
|
Loading…
Reference in a new issue